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INTRODUCTION
AutoCAD is the industry leader among all CAD products. It is the most widely used CAD software. The
commands and concepts introduced by AutoCAD are utilized by other systems. As a student, learning
AutoCAD provides you with a greater advantage as compared to any other CAD software.
Autodesk Inventor as a topic of learning is vast, and having a wide scope. It is package of many modules
delivering a great value to enterprises. It offers a set of tools, which are easy-to-use to design, document
and simulate 3D models. Using this software, you can speed up the design process and reduce the product
development costs. This book provides a step-by-step approach for users to learn Autodesk Inventor and
AutoCAD. It is aimed for those with no previous experience CAD. Each chapter has components explained
with the help of real world models.
Scope of this book
This book is written for students and engineers who are interested to learn AutoCAD and Autodesk
Inventor for designing mechanical components and assemblies, and then create drawings.
Part-1


Chapter 1, “Introduction to AutoCAD 2018”, gives an introduction to AutoCAD. The user interface
and terminology are discussed in this chapter.



Chapter 2, “Drawing Basics”, explores the basic drawing tools in AutoCAD. You will create simple
drawings using the drawing tools.



Chapter 3, “Drawing Aids”, explores the drawing settings that will assist you in creating drawings.



Chapter 4, “Editing Tools”, covers the tools required to modify drawing objects or create new objects
using the existing ones.



Chapter 5, “Multi View Drawings”, teaches you to create multi view drawings standard projection
techniques.



Chapter 6, “Dimensions and Annotations”, teaches you to apply dimensions and annotations to a
drawing.



Chapter 7, “Parametric Tools”, teaches you to create parametric drawings. Parametric drawings are
created by using the logical operations and parameters that control the shape and size of a drawing.



Chapter 8, “Section Views”, teaches you to create section views of a component. A section view is the
inside view of a component when it is sliced.



Chapter 9, “Blocks, Attributes and Xrefs”, teaches you to create Blocks, Attributes and Xrefs. Blocks are
group of objects in a drawing that can be reused. Attributes are notes, or values related to an object.
Xrefs are drawing files attached to another drawing.



Chapter 10, “Layouts and Annotative Objects”, teaches you create layouts and annotative objects.
Layouts are the digital counterparts of physical drawing sheets. Annotative objects are dimensions,
notes and so on which their sizes with respect to drawing scale.



Chapter 11, “Templates and Plotting”, teaches you create drawing templates and plot drawings.



Chapter 12, “3D Modeling Basics”, explores the basic tools to create 3D models.



Chapter 13, “Solid Editing Tools”, covers the tools required to edit solid models and create new objects
by using the existing ones.



Chapter 14, “Creating Architectural Drawings”, introduces you to architectural design in AutoCAD.
You will design a floor plan and add dimensions to it.

Part-2


Chapter 1 introduces Autodesk Inventor. The user interface and terminology are discussed in this
chapter.



Chapter 2 takes you through the creation of your first Inventor model. You create simple parts.



Chapter 3 teaches you to create assemblies. It explains the Top-down and Bottom-up approaches for
designing an assembly. You create an assembly using the Bottom-up approach.



Chapter 4 teaches you to create drawings of the models created in the earlier chapters. You will also
learn to place exploded views, and part list of an assembly.



Chapter 5: In this chapter, you will learn additional modeling tools to create complex models.



Chapter 6 introduces you to Sheet Metal modeling. You will create a sheet metal part using the tools
available in the Sheet Metal environment.



Chapter 7 teaches you create Top-down assemblies. It also introduces you create mechanisms by
applying joints between the parts.



Chapter 8 teaches you to apply dimensions and annotations to a 2D drawing.



Chapter 9 teaches you to add 3D annotations and tolerances to a 3D model.
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Chapter 1: Introduction to AutoCAD 2018
In this chapter, you will learn about:



AutoCAD user interface



Customizing user interface



Important AutoCAD commands

Introduction
AutoCAD is legendary software in the world of Computer Aided Designing (CAD). It has completed 35 years by
the 2017. If you are a new user of this software, then the time you spend on learning this software will be a wise
investment. If you have used previous versions of AutoCAD, you will be able to learn the new enhancements. I
welcome you to learn AutoCAD using this book through step-by-step examples to learn various commands and
techniques.

System requirements
The following are system requirements for running AutoCAD smoothly on your system.



Microsoft Windows 8/8.1, Windows 7, Windows 10.



CPU Type:


32-bit: 1 gigahertz (GHz) or faster 32-bit (x86) processor



64-bit: 1 gigahertz (GHz) or faster 64-bit (x64) processor



2 GB of RAM (4GB Recommended) for 32-bit.



4GB of RAM (8GB Recommended) for 64-bit.



Resolution 1360 x 2160 (1920 x 1080 or higher recommended) with True Color.



Resolutions up to 3840 x 2160 supported on Windows 10, 64 bit systems (with capable display card) for
High Resolution & 4K Displays.



6 GB of free space for installation.



Windows display adapter capable of 1360 x 2160 with True Color capabilities. DirectX® 9 or DirectX 11
compliant card recommended.



Windows Internet Explorer 11 or later.



.NET Framework Version 4.6
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Starting AutoCAD 2018
To start AutoCAD 2018, double-click the AutoCAD 2018 icon on your Desktop (or) click Start > All apps >
AutoCAD 2018 > AutoCAD 2018.

AutoCAD user interface
When you double-click the AutoCAD 2018 icon on the desktop, the AutoCAD 2018 initial screen will appear.

On the Initial Screen, click Start Drawing to open a new drawing file. The drawing file consists of a graphics
window, ribbon, menu bar, toolbars, command line, and other screen components, depending on the workspace
that you have selected.
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Changing the Color Scheme
AutoCAD 2018 is available in two different color schemes: Dark and Light. You can change the color scheme by
using the Options dialog. Click the right mouse button and select Options from the shortcut menu. On the
Options dialog, click the Display tab and select an option from the Color Scheme drop-down.

Workspaces in AutoCAD
There are three workspaces available in AutoCAD: Drafting & Annotation, 3D Basics, and 3D Modeling. By
default, the Drafting & Annotation workspace is activated. You can create 2D drawings in this workspace. You
can also activate other workspaces by using the Workspace drop-down on the top-left corner or the Workspace
Switching menu on the lower-right corner of the window.
3
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Tip: If the Workspace drop-down is not displayed at the top left corner, then click the down arrow next to Quick Access
Toolbar. Next, select Workspace from the drop-down; the Workspace drop-down will be visible on the Quick Access Toolbar.

Drafting & Annotation Workspace
This workspace has all the tools to create a 2D drawing. It has a ribbon located at the top of the screen. The ribbon
is arranged in a hierarchy of tabs, panels, and tools. Panels such as Draw, Modify, and Layers consist of tools
which are grouped based on their usage. Panels in turn are grouped into various tabs. For example, the panels
such as Draw, Modify, and Layers are located in the Home tab.

3D Basics and 3D Modeling Workspaces
These workspaces are used to create 3D models. You will learn more about these workspaces in Chapter 12. The
other components of the user Interface are discussed next.

4
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Application Menu
The Application Menu appears when you click on the icon located at the top left corner of the window. The
Application Menu consists of a list of self-explanatory menus. You can see a list of recently opened documents or
a list of currently opened documents by clicking the Recent Documents and Open Documents buttons,
respectively. The Search Bar is used to search for any command. You can type any keyword in the search bar and
find a list of commands related to it.

Quick Access Toolbar
This is located at the top left corner of the window and helps you to access commands, quickly. It consists of
commonly used commands such as New, Save, Open, Save As, and so on.

File tabs
File tabs are located below the ribbon. You can switch between different drawing files by using the file tabs. Also,
you can open a new file by using the + button, easily.

5
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Graphics Window
Graphics window is the blank space located below the file tabs. You can draw objects and create 3D graphics in the
graphics window. The top left corner of the graphics window has In-Canvas Controls. Using these controls, you
can set the orientation and display style of the model.

ViewCube
The ViewCube allows you to navigate in the 3D Modeling and 2D drafting environments. Using the ViewCube,
you can set the orientation of the model. For example, you can select the top face of the ViewCube to set the
orientation to Top. You can click the corner points to set the view to Isometric.

Navigation Bar
The Navigation Bar contains navigation tools such as Steering wheel, Pan, Zoom, Orbit, and ShowMotion.
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Command line
The command line is located below the graphics window. It is very easy to execute a command using the
command line. You can just type the first letter of a command and it lists all the commands starting with that
letter. This helps you to activate commands very easily and increases your productivity.

Also, the command line shows the current state of the drawing. It shows various prompts while working with any
command. These prompts are series of steps needed to successfully execute a command. For example, when you
activate the LINE command, the command line displays a prompt, “Specify the first point”. You need to click in
the graphics window to specify the first point of the line. After specifying the first point, the prompt, “Specify next
point or [Undo]:” appears. Now, you need to specify the next point of the line. It is recommended that you should
always have a look at the command line to know the next step while executing a command.

Status Bar
Status Bar is located at the bottom of the AutoCAD window. It contains many buttons which help you to create a
drawing very easily. You can turn ON or OFF these buttons just by clicking on them. Some buttons are hidden by
default. You can display more buttons on the status bar by clicking the Customization button at the bottom right
corner and selecting the options from the menu. The buttons available on the status bar are briefly discussed in the
following section.

Button

Description
This button is hidden by default. You can show it by using the
Customization menu. It displays the drawing coordinates when you

Coordinates

move the pointer in the graphics window. You can turn OFF this
button by clicking on it.
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Infer Constraints

This icon automatically creates constraints when you draw objects in
the graphics window. Constraints are logical operations which control
the shape of a drawing. You can turn it ON or OFF by clicking on it.

Snap Mode (F9)

The Snap mode aligns pointer only with the Grid points. When you
turn ON this button, the pointer will be able to select only the Grid
points.

Grid Display (F7)

It turns the Grid display ON or OFF. You can set the spacing between
the grid lines by clicking the drown arrow next to the Snap Mode
button and selecting the Snap Settings option. You can use grid lines
along with the Snap Mode to draw objects easily and accurately.

Ortho Mode (F8)

Polar Tracking (F10)

It turns the Ortho Mode ON or OFF. When the Ortho Mode is ON,
only horizontal or vertical lines can be drawn.

This icon turns ON or OFF the Polar Tracking. When the Polar
Tracking is turned ON, you can draw lines easily at regular angular
increments, such as 5, 10, 15, 23, 30, 45, or 90 degrees. You will notice
that a trace line is displayed when the pointer is at a particular angular
increment. You can set the angular increment by clicking the down
arrow next to this button and selecting the required angle.
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This icon is used to switch between planes while drawing isometric
views. The grid lines are also displayed if the Grid Mode is turned
ON. The orientation of the grid lines change based on the selected
Isometric Drafting

Object Snap (F3)

isoplane option.

This icon turns ON or OFF the Object Snap mode. When this mode is
turned ON, you can easily select the key points of objects such as
endpoints, midpoint, and center point and so on.

3D Object Snap (F4)

This icon turns ON or OFF the 3D Object Snap. The 3D Object Snap is
used to select the key points of 3D objects.

Object Snap Tracking (F11)

This icon is used to turn ON or OFF the Object Snap Tracking mode.
When this mode is turned ON, you can easily select points by using
the trace lines originating from the key points.

Dynamic UCS (F6)

This icon turns ON/OFF the Dynamic UCS. When the Dynamic UCS
is turned ON, you can draw and create objects on any face of a 3D
Model, dynamically.
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Dynamic Input (F12)

This icon turns ON or OFF the Dynamic Input mode. When this mode
is turned ON, a dynamic input box is attached to the pointer along
with a prompt. You can directly enter a value in the dynamic input
box. You can use Dynamic Input in place of command line.

Show/Hide Lineweight

This icon turns ON or OFF the lineweight. Line weight is the thickness
of objects. You can set the thickness of objects by specifying the
lineweight. If the Lineweight is turned OFF, the objects are displayed
with the default thickness.

Transparency

This icon turns ON or OFF the transparency of an object. You can set
the transparency using the Layer Properties Manager.
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Quick Properties

This button is used to display some important properties of a selected
object.

Selection Cycling

This icon turns ON or OFF the Selection Cycling. Selection Cycling is
very useful while selecting overlapped objects. Turn ON the selection
cycling and click on the overlapping objects. Select the required object
from the Selection list.

Annotation Monitor

This icon turns the Annotation Monitor ON or OFF. The Annotation
Monitor checks whether the annotations are attached to their
respective objects. When an annotation is not attached to any object, it
displays an error message.

Model or Paper Space

This icon switches between the Model space and Paper space. Model
space is used to create drawings and Paper space is used to print
drawings.
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Annotation Scale

This icon controls the size of annotative objects. Annotative objects are
dimensions, texts, notes and other objects which can be sized as per
the drawing scale.

Annotation Visibility

This icon displays annotative objects that are not created in the current
scale.

AutoScale

Annotation Scale

Workspace Switching

Hardware Acceleration On/Off

This icon resizes the annotative objects as per the new drawing scale.

This icon changes the annotation scale of objects.

This icon changes the workspace.

This icon increases or decreases the graphics speed. Right click on this
icon and select Graphic Performance to display the Graphic
Performance dialog. On this dialog, you can turn ON/OFF the
Hardware acceleration. In AutoCAD 2018, you can turn ON/OFF the
smooth line display irrespective of the Hardware acceleration status.
Click OK to close the dialog.
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Isolate Objects

This icon hides or isolates objects in a drawing. If you hide an object, it
will be hidden and all the other objects in the drawing will be visible.
If you isolate an object, the other objects in the drawing will be hidden
and the selected object will be visible.

Lock UI

This icon locks the toolbars, panel, tool palettes and other User
Interface elements at their current position. Click the down arrow next
to this icon to view the options to lock the user interface.

System Variables
System variables control the behavior of various functions and commands in AutoCAD. Usually, the system
variables have two or more values. You can control a system variable value from the command line. For example,
the MIRRTEXT system variable controls the direction of text when you mirror it. The 0 value retains the text
direction when you mirror it. Whereas, the 1 value reverses the text direction when you mirror it.

In AutoCAD, you can also control the system variables by using the System Variable Monitor dialog. Type
SYSVARMONITOR in the command line and press Enter to open this dialog. A list of system variables, which are
monitored by default appears on the dialog. You can know the function of a system variable by clicking the Help
icon located next to it. You can change a system variable value in the Preferred column of the dialog. The
Status column shows a yellow triangle if you have changed the default value of a system variable. The Enable
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balloon notification option shows a balloon on the status bar, if you changed any system variable value. You can
click the Reset All button to restore the default values of system variables.

You can monitor more system variables by clicking the Edit List button. Next, on the Edit System Variable List
dialog, select a system variable from the Available system variables list, and click the Add (>>) button. You can
also remove system variables from the Monitored system variables list by selecting them and clicking the Remove
(<<) button. Click OK on both the dialogs after changing the values.
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In AutoCAD 2018, the System Variable Monitor icon appears on the Status bar when you change the value of
anyone of the system variable. Right click on this icon to display a menu. The options on this menu are: Configure
System Variable Monitor, Reset System Variables, and Display Notification. The Configure System Variable
Monitor option displays the System Variable Monitor dialog, whereas the Reset System Variables option resets
the system variables to default values. The Display Notification option displays a balloon when there is a change
in the value of any system variable.

Menu Bar
Menu Bar is not displayed by default. However, you can display the Menu Bar in other workspaces by clicking on
the down-arrow located at the right side of the Quick Access Toolbar and selecting the Show Menu Bar option.
The Menu Bar is located at the top of the window just below the title bar. It contains various menus such as File,
Edit, View, Insert, Format, Tools, Draw, Dimensions, Modify, and so on. Clicking on any of the word on the Menu
Bar displays a menu. The menu contains various tools and options. There are also sub-options available on the
menu. These sub-options are displayed if you click on an option with an arrow. If you click on an option with (…),
a dialog will appear.
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Changing the display of the Ribbon
You can change the display of the ribbon by clicking the arrow button located at
the top of it. The ribbon can be displayed in three different modes as shown below.

You can use the GALLERYVIEW system variable to hide or show galleries on the ribbon. The system variable
value 1 displays a gallery for dimension styles, blocks, table styles, and mleader styles. The value 0 hides the
gallery view.
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Dialogs and Palettes
Dialogs and Palettes are part of AutoCAD user interface. Using a dialog or a palette, you can easily specify many
settings and options at time. Examples of dialogs and palettes are as shown below.

Tool Palettes
Tool Palettes provide you with another way of selecting tools and placing objects. You can display Tool Palettes by
clicking View > Palettes > Tool Palettes on the ribbon. A Tool Palette is similar to a palette except that it has many
palettes grouped in the form of tabs. You can select tools from the Tool Palettes as well as drag and place objects
(blocks) into the drawing. You can also create a new Tool Palette and add frequently used tools and objects to it.
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Shortcut Menus
Shortcut Menus appear when you right-click in the graphics window. AutoCAD provides various shortcut menus
in order to help you access tools and options very easily and quickly. There are various types of` shortcut menus
available in AutoCAD. Some of them are discussed next.

Right-click Menu
This shortcut menu appears whenever you right-click in the graphics window without activating any command or
selecting any object.

Select and Right-click menu
This shortcut menu appears when you select an object from the graphics window and right-click. It consists of
editing and selection options.

Command Mode shortcut menu
This shortcut menu appears when you activate a command and right-click. It shows options depending upon the
active command. The shortcut menu below shows the options related to the RECTANGLE command.
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Grip shortcut menu
This shortcut menu is displayed when you select a grip of an object, move the pointer and right-click. It displays
various operations that can be performed using grip.

Selection Window
A selection window is used to select multiple elements of a drawing. You can select multiple elements by using
two types of selection windows. The first type is a rectangular selection window. You can create this type of
selection window by defining its two diagonal corners. When you define the first corner of the selection window
on the left and second corner on the right side, the elements which completely fall under the selection window will
be selected.
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However, if you define the first corner on the right side and second corner of the left side, the elements, which fall
completely or partially under the selection window, will be selected.

The second type of selection window is the Lasso. Lasso is an irregular shape created by clicking and dragging the
pointer across the elements to select. If you drag the pointer from the left to right, the elements falling completely
under the lasso will be selected.

If you drag the pointer from right to left, the elements, which fall completely or partially under the lasso, will be
selected.

In AutoCAD 2018, you can specify the first corner of the selection window at one portion of a large drawing. Next,
zoom and pan to the rest of the drawing, and then specify the second corner of the selection window. By doing so,
you can select the portion of the drawing, which is currently not visible in the screen.
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Starting a new drawing
You can start an AutoCAD document by using the Get Started section or by using the Select template dialog.

Get Started Section on the Initial Screen
To start a new drawing, click Create at the bottom of the initial screen, and then select a template from Get Started
> Templates drop-down.
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The Select Template dialog
To start a new drawing, click the New button on anyone of the following:


Quick Access Toolbar



Application Menu

The Select Template dialog appears when you click the New button. In this dialog, select the acad.dwt (inch units)
or acadiso.dwt (metric units) template for creating a 2D drawing. Select the acad3D.dwt or acadiso3D.dwt
template for creating 3D models.
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Help
Press F1 or type a keyword in the Search bar located at the top right corner of the window to get help for any topic.
On the Autodesk AutoCAD 2018 –Help window, click the Find option next to the topic; an animated arrow
appears on the window showing the tool location.
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Command List
Various commands in AutoCAD are given in the table below:

Command

Alias

APPLOAD

Description
Activates the Load/Unload Applications dialog.

ADCENTER

DC

Opens the DesignCenter palette.

ALIGN

AL

Used to align objects with other objects.

ARC

A

Used to create an arc.

AREA

ARRAY

Displays the area of a selected closed object.

AR

ASE

Creates Rectangular, Path or Polar 2D arrays.

Displays the dbConnect Manager palette.

ATTDEF

ATT

Displays the Attribute Definition dialog.

ATTEDIT

ATE

Used to edit Attributes.

AUDIT

Used to check and fix errors.

AUTOCONSTRAIN

Used to apply constraints automatically.

AUTOPUBLISH

Used to create a DWF file.

BACTION

AC

Used to add an action to a dynamic block. This
command is available in Block Editor.
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BLOCK

BMAKE

Used to create a block.

B

BMPOUT

Used to create a block.

Used to create a Raster image out of the drawing.

BOUNDARY

BO

Used to create a hatch boundary.

BREAK

BR

Used to break an object.

CAL

Used to calculate mathematical expressions.

CHAMFER

CHA

Used to create chamfers.

CHPROP

CH

Changes the properties of a selected object.

CIRCLE

C

Used to create a circle.

COLOR

COL

Displays the Select Color dialog.

COPYTOLAYER

COPY

Used to copy objects from one layer to another.

CO

Used to copy objects inside a drawing.

COPYCLIP

Used to copy objects from one drawing to another.

CUSTOMIZE

Used to customize tool palettes.

DDEDIT

ED

Used to edit a note or annotation.
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DIMSTYLE

D

Used to create or modify a dimension style.

DDMODIFY

Displays the Properties palette.

DELCONSTRAINT

Used to delete constraints.

OSNAP

OS

DDPTYPE

VIEW

Used to set Object Snap settings.

Used to set the point style and size.

V

DGNEXPORT

Used to save views by names.

Used to export the drawing to Microstation (DGN)
format.

DGNIMPORT

Used to import a Microstation (DGN) format file.

DIMCONSTRAINT

DCON

Used to apply dimensional constraints to objects.

DIMLINEAR

DLI

Used to create a linear dimension.

DIMALIGNED

DAL

Used to create an aligned dimension.

DIMARC

DAR

Used to dimension the arc length.

DIMRADIUS

DIMRAD

Used to create at radial dimension.

DIMJOGGED

JOG

Used to create a jogged dimension.
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DIMDIAMETER

DIMDIA

Used to create a diameter dimension.

DIMANGULAR

DAN

Used to create an angular dimension.

DIMORDINATE

DOR

Used to create ordinate dimension.

DIMCONTINUE

DIMCONT

Used to create continuous dimensions from an existing
one.

DIMBASELINE

DIMBASE

Used to create baseline dimensions.

DIMINSPECT

Used to create an inspection dimension.

-DIMSTYLE

Update a dimension according the dimension style.

DIMSPACE

Used to adjust space between dimensions.

DIMBREAK

Used to break the extension line of a dimension when it
intersects with another dimension.

DIMOVERRIDE

Used to override the system variables of a selected
dimension.

DIMCENTER

Used to create a center mark of a circle.

DIMEDIT

DIMED

Used to edit a dimension.

DIMTEDIT

DIMTED

Used to edit the dimension text.

DIMDISASSOCIATE

Disassociates a dimension from the object.
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DIST

DI

DISTANTLIGHT

Used to measure the distance between two points.

Used to create distant light.

DIVIDE

DIV

Places evenly spaced objects on a line segment

DONUT

DO

Used to create a donut.

DVIEW

Used to get the aerial view of a drawing.

DXBIN

Used to open a DXB file.

DXFIN

Used to open a DXF file.

DXFOUT

Used to save a file in DXF format.

ELLIPSE

EL

Used to create an ellipse.

ERASE

E

Used to erase objects.

EXIT

EXPLODE

Used to close AutoCAD.

X

EXPLORER

Used to explode or ungroup objects.

Displays Windows Explorer.

EXPORT

EXP

Used to export data.

EXTEND

EX

Used to extend an object up to another.
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FILLET

F

FILTER

GEOMCONSTRAINT

Used to create a fillet at the corner.

Used to set object selection filters.

GCON

GRADIENT

Used to apply geometric constraints.

Used to apply gradient to a closed area.

GROUP

G

Used to group objects.

HATCH

H

Used to apply hatch to a closed area.

HATCHEDIT

HE

Used to edit hatch.

HELP

HIDE

Display the Help window.

HI

ID

IMAGE,

Changes the Visual Style to Hidden.

Displays the coordinate values of a selected point.

IM

Used to attach an Image reference.

IAD

Used to adjust images.

IMAGEATTACH

IMAGEADJUST

IMAGECLIP

Used to crop an image.

IMPORT

Used to import other forms of CAD data.
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INSERT

I

INSERTOBJ

Used to insert a block.

Used to insert an object into the drawing.

ISOPLANE

CTRL+E

Used to set the current isometric plane.

JOIN

J

Used to join end points of two linear or curved objects.

LAYCUR

LAYER

The Layer of the selected objects will be made current.

LA

Used to create a new layer and modify its properties.

LAYFRZ

Used to freeze the layer of a selected object.

LAYISO

Isolates the layer of a selected object.

LAYOUT

Used to modify layouts.

LAYOFF

Used to turn off the layer of a selected object.

LAYON

Used to turn ON all the layers.

LAYOUTWIZARD

Displays the Create Layout dialog.

LENGTHEN

LEN

Used to increase the length of an object.

LIMITS

Used to set the drawing limits.

LIMMAX

Used to set the maximum limit of a drawing.
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LINE

L

Used to create a line.

LINETYPE

LT

Used to set the linetype.

LIST

LI

Lists the properties of a selected object in the text
window.

LOAD

Imports the shapes that can be used by the SHAPE
command.

LTSCALE

LTS

Used to set the linetype scale.

MEASURE

ME

Used to place points or blocks at measured intervals on
an object.

MENU

Used to load a customization file.

MENULOAD

Used to load or unload a customizable file.

MIRROR

MI

MLEDIT

MLINE

Used to edit a multiline.

ML

MLSTYLE

MOVE

MSLIDE

Used to create a mirror image of an object.

Used to create multiple parallel lines.

Used to create and modify a multiline style.

M

Used to move selected objects.

Used to create slide out of a drawing.
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MSPACE

MS

MSTRETCH

Used to switch from paper space to model space.

Used to stretch multiple objects at a time.

MTEXT

MT or T

Used to write text in multiple lines.

MVIEW

MV

Used to create and modify viewports.

MVSETUP

NEW

Used to set drawing specifications for printing purpose.

CTRL+N

NOTEPAD

OFFSET

Used to open a new file.

Used to edit file in Notepad.

O

Creates a parallel copy of a selected object at a specified
distance.

OOPS

Used to undo the ERASE command.

OPEN

Used to open an existing file.

OPTIONS

OP

ORTHO

OSNAP

PAGESETUP

Used to set various options related to the drawing.

Turns ON/OFF the Ortho Mode.

OS

Used to the Object Snap settings.

Used to specify the printing properties of a layout.
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PAN

P

Used to drag a drawing to view its different portions.

PARAMETER

PAR

Used to assign expressions to a dimensional constraint.

PBRUSH

Opens the Windows Paint application.

PEDIT

PE

Used to edit polylines.

PLINE

PL

Used to create a polyline. A polyline is a single object
which can have continuous lines and arcs.

PLOT

CTRL+P

Used to plot a drawing.

POINT

PO

Used to place a point in the drawing.

POLYGON

POL

Used to create a polygon.

PREVIEW

PRE

Used to preview the plotted drawing.

PROPERTIES

PR

Displays the Properties palette.

PSOUT

PURGE

Used to create a postscript file.

PU

Used to remove the unwanted data from the drawing.

QDIM

Used to create a quick dimension.

QSAVE

Used to save the current drawing.
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QUICKCALC

QC

Displays the QuickCalc calculator.

QUIT

Used to close the current drawing session.

RAY

Used to create a line that starts from a selected point and
extends up to infinity.

RECOVER

Used to repair and open the damaged files.

RECOVERALL

Used to repair a damaged file along with the attached
external references.

RECTANG

Used to create a polyline rectangle.

REDEFINE

Used to restore an AutoCAD command which has been
overridden.

REDRAW

R

Refreshes the current viewport.

UNDEFINE

Used to override an existing command with a new one.

REDO

Used to cancel the previous UNDO command.

REDRAWALL

RA

Refreshes all the viewports in a drawing.

REGEN

RE

Regenerates the current viewport of a drawing.

REGENALL

REA

Regenerates all the viewports of a drawing.

REGION

REG

Convert the area enclosed by objects into a region.

34

Part 1: AutoCAD Basics
RENAME

REN

Used to rename blocks, viewports, dimension styles and
so on.

REVCLOUD

Used to highlight a portion of drawing by creating a
cloud around it.

RIBBON

Displays the ribbon.

RIBBONCLOSE

Hides the ribbon.

SAVE

CTRL+S

Saves the currently opened drawing.

SAVEAS

Saves the drawing with another name and location.

SAVEIMG

Used to save a rendered output file.

SCALE

SC

Used to increase or decrease the size of a drawing.

SCRIPT

SCR

Used to load a script file. A script is used to run various
commands in a sequential manner.

SETVAR

SET

Used to list or change a system variable.

SHAPE

Used to insert a shape into a drawing.

SHELL

Used to enter MS-DOS commands.

SKETCH

Used to draw freehand sketches.

SOLID

SO

Used to create filled triangles or quadrilaterals.
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SPELL

SP

Used to check the spelling of a text.

SPLINE

SPL

Used to create a spline (curved object).

SPLINEDIT

SPE

Used to edit a spline.

STATUS

Used to display the details of a drawing such as limits,
model space usage, layers and so on.

STRETCH

S

Used to stretch objects.

STYLE

ST

Used to create or modify the text style.

TABLET

TA

Allows using a tablet for creating drawings.

TBCONFIG

Used to customize user interface.

TEXT

Used to enter text in the drawing.

THICKNESS

TH

TOLERANCE

Used to set a thickness value to 2D objects.

Used to apply geometric tolerances to the drawing.

TOOLBAR

TO

Used to customize toolbars.

TRIM

TR

Used to trim unwanted portions of an object.

UCS

Used to specify the location of the user coordinate
system.
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UNDO

CTRL+Z (or) U

Used to undo the last operation.

UNITS

UN

Set the units of the drawing

VIEW

Used to save and restore model space, layout, and preset
views.

VPLAYER

Used to control the layer visibility in paper space.

VPORTS

Used to create multiple viewports in model space of
paper space.

VSLIDE

WBLOCK

Used to show an image slide file.

W

WMFIN

Used to convert a block into a drawing.

Used to import a Windows Metafile. This file contains
drawing data and image data. But only drawing data is
imported.

WIPEOUT

Used to wipeout a portion of the drawing.

WMFOPTS

Used to specify options for importing a Windows
Metafile.

WMFOUT

XATTACH

Used to save objects as Windows Metafile.

XA

Used to attach a drawing as an external reference.
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XLINE

XL

Used to create construction lines. Construction lines
extend to infinity and help in drawing objects.

XREF

XR

Used to attach a drawing as an external reference.

ZOOM

Z

Used to Zoom in or out of a drawing.

3D Commands
Command

Shortcut

Description

3DARRAY

3A

Used to create three-dimensional arrays of an objects.

3DALIGN

3AL

Used align 3D objects.

3DFACE

3F

Used to create three sided or four 3D surface.

3DMESH

Used to create freeform 3D mesh.

3DCORBIT

Used to rotate a view in the 3D space with continuous
motion.

3DDISTANCE

Used to control the distance.

3DEDITBAR

Used to add and edit control vertices on a NURBS
surface or spline.

3DFLY

Used to view the 3D model as if you are flying through.

3DFORBIT

Used to freely rotate a view in 3D space.
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3DMOVE

3M

Used to move the objects in 3D space.

3DORBIT

3DO

Used to rotate the view constrained along horizontal or
vertical axis.

3DORBITCTR

Used to set the center for rotating view in 3D space.

3DPAN

Used to pan the 3D models horizontally or vertically.
This is used when working in perspective view.

3DPOLY

3P

Used to create a 3D polyline.

3DPRINT

3DP

Used to print the model in 3D (plastic prototype).

3DROTATE

3DSCALE

Used to rotate 3D objects in 3D space.

3S

Used to increase or decrease the size of 3D object along
the X, Y, Z directions.

3DSIN

Used to import a 3ds Max file.

3DDWF

Export the 3D model to a 3D DWF file.

3DWALK

Used to view the 3D model as if you are walking through
it.

ANIPATH

Used to create an animation when you are navigating
through the model.

BOX

Used to create a 3D box.
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CONE

Used to create a 3D cone.

CONVERTOLDLIGHTS

Used to convert lights created in previous releases to the
current format.

CONVERTOLDMATERIALS

Used to convert old materials to new format

CONVTONURBS

Used to convert a surface to NURBS. You can edit can
easily edit a NURBS by using control vertices displayed
on it.

CONVTOSOLID

Used to convert 3D meshes, polylines and circles to 3D
solids.

CONVTOSURFACE

Used to convert objects to surfaces.

CVADD

Used to add control vertices to a NURBS surface or
spline.

CVREMOVE

Used to remove control vertices from a NURBS surface
or spline.

CVHIDE

Used to hide the control vertices of a NURBS surface or
splines,

CVSHOW

Used to display the control vertices of a NURBS surface
or splines.

CVREBUILD

Used to rebuild the control vertices of a NURBS surface.

CYLINDER

Used to create a 3D Cylinder.
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EDGESURF

EXTRUDE

Used to create a mesh surface from four adjacent edges.

EXT

Used to extrude a closed region or polyline.

FILLETEDGE

Used to blend an edge of a 3D object.

FLATSHOT

Used to create a 2D representation of a 3D model.

FREEPOINT

Used to create point light that emits light in all
directions.

FREESPOT

Used to create a spot light without any target.

HELIX

Used to create a helical or spiral curve.

INTERFERE

Used to create a 3D solid at the interference point of the
various solid objects.

INTERSECT

IN

Used to create a 3D solid at the intersection portion of
solid.

LIGHT

Used to create a light.

LIGHTLIST

Displays the lights available in the current 3D model.

LOFT

Used to create 3D solid or surface between various cross
sections.

MATERIALS

Displays the Material Browser.
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MATERIALASSIGN

Used to assign a material to the model.

MATERIALMAP

Used to the control the texture.

MATERIALATTACH

Used to associate materials with layers.

MESH

Used to create 3D mesh objects.

MESHREFINE

Used to refine the mesh of 3D mesh objects.

MESHSMOOTH

Used to increase the smoothness of mesh objects.

MIRROR3D

Used to mirror 3D objects in 3D space.

OFFSETEDGE

Used to create a parallel copy of an edge at a specified
distance.

PFACE

Used to create a 3D Polyface mesh by specifying vertices.

PLAN

Displays the top view of the 3D model.

PLANESURF

Used to create a planar surface.

POINTLIGHT

Used to create point light that emits light in all
directions.

PRESSPULL

Used to extrude or subtract material.

PYRAMID

Used to create a pyramid.

42

Part 1: AutoCAD Basics

-RENDER

Used to specify settings for rendering.

RENDERCROP

Used to render a rectangular portion of a 3D model.

RENDERENVIRONMENT

Used to control visual properties rendered image.

RENDEREXPOSURE

Used to control the lighting of a rendered image.

RENDERONLINE

Used to render an image in Autodesk 360 (cloud).

RENDERPRESETS

Used to specify preset values for rendering an image.

RENDERWIN

Displays the render window.

REVOLVE

REV

Used to create a revolved solid.

REVSURF

Used to create a revolved surface.

RMAT

Displays the Material Browser.

RPREF

RPR

Used to specify advanced render settings.

SECTION

SEC

Used to create section plane in a 3D model.

SLICE

SL

Used to slice a 3D model.

SOLPROF

Create a profile from a 3D model in a paper space.

SOLIDEDIT

Used to edit faces and edges of a 3D solid.
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SPACETRANS

Used to calculate equivalent model space and paper
space distance.

SPHERE

Used to create a 3D sphere.

SPOTLIGHT

Used to create a spotlight that emits light like a torch.

STLOUT

Used to export a file to STL format.

SUNPROPERTIES

Displays the Sun properties palette.

SURFBLEND

BLENDSRF

Used to create a continuous blend surface between two
surfaces.

SURFEXTEND

Used to lengthen a surface up to another surface.

SURFEXTRACTCURVE

Used to create Isoline curves on a surface, solid, or a face
in U and V directions.

SURFFILLET

Used to create a surface fillet between two surfaces.

SURFOFFSET

Used to create parallel surface at a specified distance.

SURFNETWORK

Used to create a surface from various curves in U and V
directions.

SURFPATCH

Used to create a surface using the edges forming a closed
loop.
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SURFSCULPT

Used to create a closed surface by trimming and
combining the surfaces that form a region together.

SURFTRIM

Used to trim portions of a surface at intersections with
other surfaces.

SURFUNTRIM

Used to untrim the trimmed surface.

SWEEP

Used to create 3D solid or surface by sweeping a profile
along a path.

TABSURF

Used to create a mesh from an line or curve swept along
a straight path

TORUS

TOR

Used to create a torus.

UNION

UNI

Used to combine various solids into one.

VISUALSTYLES

Used to create and modify visual styles.

VPOINT

Used to set the viewing direction of the 3D model.

WEDGE

XEDGES

WE

Used to create a wedge shape.

Used to create a 3D wireframe from a 3D solid.
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Drawing Lines

Chapter 2: Drawing
Basics

You can draw a line by specifying its start point and
end point using the Line tool. However, there are
various methods to specify start and end of a line.

In this chapter, you will learn to do the following:


These methods are explained in the following
examples.

Draw lines, rectangles, circles, ellipses, arcs,
polygons, and polylines



Use the Erase, Undo and Redo tools

Example 1 (using the Absolute Coordinate



Draw entities using the absolute coordinate

System)

points

In this example, you will create lines by specifying

Draw entities using the relative coordinate

points in the absolute coordinate system. In this

points

system, you specify the points with respect to the

Draw entities using the tracking method

origin (0, 0). A point will be specified by entering its




X and Y coordinates separated by a comma, as

Drawing Basics

shown in figure below.

This chapter teaches you to create simple drawings.
You will create these drawings using the basic
drawing tools. These tools include Line, Circle,
Polyline, and Rectangle and so on and they are
available in the Draw panel of the ribbon, as shown
below. You can also activate these tools by typing
them in the command line.



Start AutoCAD 2018 by clicking the
AutoCAD 2018 icon on your desktop.



On the Welcome screen, click Start Drawing
> Templates > acadISO-Named Plot
Styles.dwt. This starts a new drawing using
the ISO template.



Click Zoom > Zoom All on the Navigation
Bar; the entire area in the graphics window
will be displayed.
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below.



Turn OFF the Grid Display by pressing the



Click Save on the Quick Access Toolbar.



Save as Line-example1.dwg.



Close the file.

F7 key.


Click the Customization button on the
status bar, and then select Dynamic Input
from the flyout. This displays the Dynamic
Input icon on the status bar.

Example 2 (using Relative Coordinate
system)


In this example, you will draw lines by defining its

Turn OFF the Dynamic Input icon. You will

end points in the relative coordinate system. In the

learn about Dynamic Input later in this

relative coordinate system, you define the location

chapter.

of a point with respect to the previous point. For this
purpose, the symbol, ‘@’ is used before the point
coordinates. This symbol means that the coordinate
values are defined in relation with the previous
point.



To draw a line, click Home > Draw > Line
on the ribbon, or enter LINE or L in the
command line.



Type 50, 50 and press ENTER.



Type 150, 50 and press ENTER.



Type 150,100 and press ENTER.



Type 50,100 and press ENTER.



Select the Close option from the command


line. This creates a rectangle, as shown
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Example 3 (using Polar Coordinate




Select the acadISO-Named Plot Styles

system)

template. Click Open.

In the polar coordinate system, you define the
location of a point by entering two values: distance

Type-in Z in the command line to activate

from the previous point and angle from the zero

the ZOOM command.


degrees. You enter the distance value along with the

Click the All option in the command line.

@ symbol and angle value with the < symbol. You

This displays the entire area in the graphics

have to make a note that AutoCAD measures the

window.


angle in anti-clockwise direction.

Turn OFF the Grid icon on the status bar.

Drawing Task



Turn OFF the Dynamic Input mode, if
active.



Click Home > Draw > Line on the ribbon, or
enter LINE or L in the command line.



Type 100,100 and press ENTER. This defines



the first point of the line.

Open a new file using the acadISO-Named
Plot Styles.dwt template.



Type @50,0 and press ENTER.



Type @0,20 and press ENTER.



Type @100,0 and press ENTER.



Turn OFF the Grid icon on the status bar.



Type @0,-20 and press ENTER.



Turn OFF the Dynamic Input mode, if



Type @50,0 and press ENTER.



Type @0,120 and press ENTER.



Type @-50,0 and press ENTER.



Type @0,-20 and press ENTER.



Type 50,50 and press Enter key.



Type @-100,0 and press ENTER.



Type @110<0 and press ENTER.



Type @0,20 and press ENTER.



Type @20<90 and press ENTER.



Type @-50,0 and press ENTER.



Type @80<120 and press ENTER.



Select the Close option from the command



Type @30<180 and press ENTER.

line.



Type @80<240 and press ENTER.



Save the file as Line-example2.dwg.



Select the Close option from the command



Close the file.



Click Zoom > Zoom All on the Navigation
Bar.

active.


Click Home > Draw > Line on the ribbon, or
enter LINE or L in the command line.

line.
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Save the file as Line-example3.dwg.



Close the file.



Press the TAB key and type 0 as angle. Next,
press ENTER.

Example 4 (using Direct Distance Entry)
In the direct distance entry method, you draw a line
by entering its distance and angle values. You use
the Dynamic Input mode in this method.



Move the pointer vertically upwards and
type-in 100 as length.



Press the TAB key and type 90 as angle.
Next, press ENTER.



Move the pointer horizontally toward left
and type 50.





Open a new file using the acadISO-Named

Next, press ENTER.

Plot Styles.dwt template.




Turn OFF the Grid and Snap Mode icons on



Click Zoom > Zoom All on the Navigation

Press the TAB key and type 90 as angle.
Next, press ENTER.

Bar.


Move the pointer vertically downwards and
type 20.

the Status Bar.


Press the TAB key and type 180 as angle.



Activate the Dynamic Input icon on the

Move the pointer horizontally toward left
and type 50.

Status Bar.



Press the TAB key and type 180 as angle.
Next, press ENTER.




type 40.

Click Home > Draw > Line on the ribbon, or



enter LINE or L in the command line.


Press the TAB key and type 90 as angle.
Next, press ENTER.

Define the first point of the line by typing



50,50 and pressing ENTER.


Move the pointer vertically downwards and

Move the pointer horizontally toward left
and type 50.

Move the pointer horizontally toward right



and type-in 150 in the length box.

Press the TAB key and type 180 as angle.
Next, press ENTER.



Click the Close option in the command line.



Save and close the file.

Erasing, Undoing and Redoing

50
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below using the Line tool.



Click Home > Modify > Erase on the ribbon

Drawing Circles

or Enter ERASE or E in the command line.

The tools in the Circle drop-down on the Draw
panel can be used to draw circles. You can also typein the CIRCLE command in the command line and
create circles. There are various methods to create


Select the lines shown below and press

circles. These methods are explained in the

ENTER. This erases the lines.

following examples.

Example 1(Center, Radius)
In this example, you will create a circle by
specifying its center and radius value.



Click the Undo button on the Quick Access
Toolbar. This restores the lines.



Click the Redo button on the Quick Access
Toolbar. This erases the lines again.




Type E in the command line and press the

Radius

SPACEBAR; the ERASE command will be



activated.


Click Home > Draw > Circle > Center,
on the ribbon.

Select an arbitrary point in the graphics
window to specify the center point.

Drag a selection lasso as shown below and



press ENTER; the entities will be erased.
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Example 2(Center, Diameter)



In this example, you will create a circle by

on the ribbon. The message, “Specify first

specifying its center and diameter value.






end point of circle's diameter:” appears in

Click Home > Draw > Circle > Center,
Diameter

Click Home > Draw > Circle > 2-Point

the command line.


on the ribbon. The message,

Select the center point of the left side circle;

“Specify center point for circle or

the message, “Specify second end point of

[3P/2P/Ttr (tan tan radius)]:” appears in

circle's diameter:” appears in the command

the command line.

line.


Pick a point in the graphics window, which

Select the center point of the right side

is approximately horizontal to the previous

circle; the circle will be created a shown

circle.

below.

Type 40 as the diameter and press ENTER;

Example 4(3-Point)

the circle will be created.

In this example, you will create a circle by

Example 3(2-Point)

specifying three points. The circle will pass through

In this example, you will create a circle by

these three points.

specifying two points. The first point is to specify



Open a new file.

the location of the circle and the second defines the



Use the Line tool and create the drawing
shown in figure below. The coordinate

diameter.


points are also given in the figure.

Click the down arrow next to the Object
Snap

icon on the status bar. A flyout

appears. The options in this flyout are
called Object Snaps. You will learn about
these Object Snaps later in Chapter 3.


Activate the Center option, if it is not
already active.





Now, you will create a circle by selecting

Click Home > Draw > Circle > 3-Point
on the ribbon.

the center points of the previous circles.
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circle will be created passing through the
selected points.

Click the / button and then the 2 button on
the Number Pad.



Click the = button; the value 28.8675 is
displayed in the value box.

Example 5 (Tan, Tan, Radius)
In this example, you will create a circle by selecting
two objects, and then specifying the radius of the
circle. This creates a circle tangent to the selected
objects.


Click Home > Utilities > Measure > Radius
on the ribbon. The message, “Select arc


or circle: “appears in the command line.


Select the circle passing through the three

Click Home > Draw > Circle > Tan, Tan,
Radius

vertices of the triangle; the radius and

on the ribbon; the message,

“Specify point on object for first tangent of

diameter values of the circle will be

circle:” appears in the command line.

displayed above the command line.



Select the horizontal line of the triangle; the
message, “Specify point on object for
second tangent of circle:” appears in the
command line.



Select anyone of the inclined lines; the
message, “Specify radius of circle” appears
in the command line.



Click the Paste value to command line
button on the Quick Calculator; the value
28.8675 will be pasted in the command line.



Click Home > Utilities > Quick Calculator
on the ribbon; the Quick Calculator
appears.



Type-in 57.7350 in the Quick Calculator.
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Select the two inclined lines. This creates a
circle tangent to the selected lines.



Press ENTER to specify the radius; the circle


will be created touching all three sides of

Save and close the file.

the triangle.

Drawing Arcs
An arc is a portion of a circle. The total angle of an
arc will always be less than 360 degrees, whereas the
total angle of a circle is 360 degrees. AutoCAD
provides you with eleven ways to draw an arc. You
can draw arcs in different ways by using the tools


available in the Arcs drop-down of the Draw panel.

Save and close the file.

The usage of these tools will depend on your

Example 6 (Tan, Tan, Tan)

requirement. Some methods to create arcs are

In this example, you will create a circle by selecting

explained in the following examples.

three objects to which it will be tangent.


Click the Open button on the Quick Access
Toolbar; the Select File dialog appears.



Browse to the location of Lineexample3.dwg file and double-click on it;
the file will be opened.



Click Home > Draw > Circle > Tan, Tan,
Tan



on the ribbon.

Select the bottom horizontal line of the
drawing.
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Example 1 (3-Point)
In this example, you will create an arc by specifying
three points. The arc will pass through these points.


Open the Line-example1.dwg file.



Expand the Draw panel in the Home tab
and select the Multiple Points tool.

Example 2 (Start, Center, End)
In this example, you will draw an arc by specifying
its start, center and end points. The first two points
define the radius of the arc and third point defines
its included angle.


Type 100,120 in the command line and


press ENTER. This places a point above the

Click Home > Draw > Arc > Start, Center,
End on the ribbon. The message, “Specify

rectangle.

start point of arc or [Center]:” appears in
the command line.
The included angle of the arc is measured in
the counter-clockwise direction. Press and
hold the Ctrl key, if you want to reverse the
direction.


Click the down arrow next to the Object
Snap



window to define the start point of an arc.

icon on the status bar, and then

The message, “Specify center point of arc:”

select the Node option from the menu.


Pick an arbitrary point in the graphics

appears.

Click Home > Draw > Arc > 3-Point on the



ribbon. The message, “Specify start point of

Pick a point to define the radius of the
circle. You can also type-in the radius value

arc or [Center]:” appears in the command

and press ENTER; the message, “Specify

line.

end point of arc or [Angle/chord Length]:”



Select the top left corner of the rectangle.

appears.



Select the point located above the rectangle.

You will notice that, as you move the



Select the top right corner of the rectangle;
the three-point arc will be created.

pointer, the included angle of the arc
changes.
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Pick a point to define the included angle of
the arc. You can also type the angle value
and press ENTER.

Example 3 (Start, End, Direction)




Likewise, create another arc.

Use the Line tool and create the drawing
shown in figure below. The dimensions are
also given in the figure. (Use anyone of the
procedures given in the Drawing Lines
section)

Drawing Polylines
A Polyline is a single object that consists of line
segments and arcs. It is more versatile than a line as
you can assign a width to it. In the following
example, you will create a closed polyline.

Example 1


Click Home > Draw > Arc > Start, End,
Direction on the ribbon.



Select the start and end points of the arc as
shown in figure.



Move the pointer vertically downward and


click to specify the direction.

Activate the Ortho Mode

on the Status

Bar.


Click Home > Draw > Polyline

on the

ribbon or enter PLINE or PL in the
command line; the message, “Specify start
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point:” appears in the command line.


Select an arbitrary point in the graphics
window.



Move the pointer horizontally toward right



Open a new file.



Click Home > Draw > Rectangle

ribbon, or enter RECTANG or REC in the

and type 100. Next, press ENTER.


command line; the message, “Specify first

Select the Arc option from the command

corner point or

line.


[Chamfer/Elevation/Fillet/Thickness/Widt

Move the pointer vertically upward and

h]:” appears in the command line.

type 50. Next, press ENTER.




Select the Line option from the command

point or [Area/Dimensions/Rotation]:”

Move the pointer horizontally toward left

appears in the command line.

and type 50. Next, press ENTER.




Move the pointer vertically upward and

Move the pointer diagonally toward right
and click to create a rectangle.

type 50. Next, press ENTER.


Pick an arbitrary point in the graphics
window; the message “Specify other corner

line.


on the

Select the Arc option from the command
line.



Move the pointer horizontally toward left
and type 50. Next, press ENTER.



Select the CLose option from the command
line.

Example 2
Now, when you select a line segment from the

In this example, you will create a rectangle by

sketch, the whole sketch will be selected. This is

specifying its length and width.

because the polyline created is a single object.

Drawing Rectangles
A rectangle is a four sided single object. You can
create a rectangle by just specifying its two diagonal
corners. However, there are various methods to
create a rectangle. These methods are explained in
the following examples.


Example 1

Click Home > Draw > Rectangle on the
ribbon, or enter RECTANG or REC in the

In this example, you will create a rectangle by

command line.

specifying its corner points.
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Specify the first corner of the rectangle by

Enter area of rectangle in current units:

picking an arbitrary point in the graphics

Type 20000 and press ENTER.

window.

Calculate rectangle dimensions based on

Follow the prompt sequence given next:

[Length/Width] <Length>: Select the Width

Specify other corner point or

option from the command line.

[Area/Dimensions/Rotation]: Select the

Enter rectangle width: Type 100 and press

Dimensions option from the command line

ENTER; the length will be calculated

Specify length for rectangles: Type 400 and

automatically.

press ENTER.
Specify width for rectangles: Type 200 and

Example 4

press ENTER.

In this example, you will create a rectangle with

Specify other corner point or

chamfered corners.

[Area/Dimensions/Rotation]: Move the
pointer upward and click to create the
rectangle.

Example 3
In this example, you will create a rectangle by



specifying its area and width.

Click Home > Draw > Rectangle on the
ribbon, or enter RECTANG or REC in the
command line.



Follow the prompt sequence given next:
Specify first corner point or
[Chamfer/Elevation/Fillet/Thickness/Width
]: Select the Chamfer option from the



command line.
Click Home > Draw > Rectangle on the

Specify first chamfer distance for

ribbon, or enter RECTANG or REC in the

rectangles: Type 20 and press ENTER.

command line.




Specify second chamfer distance for

Specify the first corner of the rectangle by

rectangles: Type 20 and press ENTER.

picking an arbitrary point.

Specify first corner point or

Follow the prompt sequence given next:

[Chamfer/Elevation/Fillet/Thickness/Width

Specify other corner point or

]: Click at an arbitrary point in the graphics

[Area/Dimensions/Rotation]: Select the

window to specify the first corner.

Area option from the command line

Specify other corner point or
[Area/Dimensions/Rotation]: Move the
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pointer diagonally toward right and click to
specify the second corner.

Example 5
In this example, you will create a rectangle with
rounded corners.





Click Home > Draw > Rectangle on the

ribbon, or enter RECTANG or REC in the

ribbon, or enter RECTANG or REC in the

command line.

command line.


Click Home > Draw > Rectangle on the



Follow the prompt sequence given next:

Specify the first corner of the rectangle by
picking an arbitrary point.



Specify first corner point or

Follow the prompt sequence given next:

[Chamfer/Elevation/Fillet/Thickness/Width
]: Select the Fillet option from the command

Specify other corner point or

line.

[Area/Dimensions/Rotation]: Select the

Specify fillet radius for rectangles: Type 50

Rotation option from the command line.

and press ENTER.

Specify rotation angle or [Pick points]:

Specify first corner point or

Type 60 and press ENTER.

[Chamfer/Elevation/Fillet/Thickness/Width

Specify other corner point or

]: Click at an arbitrary point in the graphics

[Area/Dimensions/Rotation]: Select the

window to specify the first corner.

Dimensions option from the command line.

Specify other corner point or

Specify length for rectangles: Type 400 and

[Area/Dimensions/Rotation]: Move the

press ENTER.

pointer diagonally toward right and click to

Specify width for rectangles: Type 300 and

specify the second corner.

press ENTER.

Example 6

Drawing Polygons

In this example, you will create an inclined
rectangle.

A Polygon is a single object having many sides
ranging from 3 to 1024. In AutoCAD, you can create
regular polygons having sides with equal length.
There are two methods to create a polygon. These
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methods are explained in the following examples.

circumscribed circle. A circumscribed circle is an
imaginary circle which is tangent to all the sides of a

Example 1

polygon.

In this example, you will create a polygon by
specifying the number of sides, and then specifying
the length of one side.



Type POL in the command line and press
ENTER; the POLYGON command will be
activated.





Click Home > Draw > Polygon on the
ribbon.

Follow the prompt sequence given next:
Enter number of sides <5>: Type 8 and
press ENTER.
Specify center of polygon or [Edge]: Select
an arbitrary point
Enter an option [Inscribed in



circle/Circumscribed about circle] <C>:

Follow the prompt sequence given next.

Select the Inscribed in circle option from

Enter number of sides <4>: Type 5 and

the command line.

press ENTER.

Specify radius of circle: Type 20 and press

Specify center of polygon or [Edge]: Select

ENTER; a polygon will be created with its

the Edge option from the command line.

corners touching the imaginary circle.

Specify first endpoint of edge: Select an
arbitrary point.

Drawing Splines

Specify second endpoint of edge: Type 20

Splines are non-uniform curves, which are used to

and press ENTER.

create irregular shapes. In AutoCAD, you can create
splines by using two methods: Spline Fit and Spline

Example 2

CV. These methods are explained in the following

In this example, you will create a polygon by

examples:

specifying the number of sides, and drawing an
imaginary circle (inscribed circle). The polygon will
be created with its corners located on the imaginary
circle. You can also create a polygon with the
60
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Example 1: (Spline Fit)
In this example, you will create a spline using the
Spline Fit method. In this method you need to
specify various points in the graphics window. The
spline will be created passing through the specified

Example 2: (Spline CV)

points.

In this example, you will create a spline by using the
Spline CV method. In this method, you will specify



Start a new drawing file.



Use the Line tool and create a sketch similar

various points called control vertices. As you specify
the control vertices, imaginary lines are created

to the one shown below.

connecting them. The spline will be drawn tangent
to these lines.





Expand the Draw panel in the Home tab
and select the Spline CV button.



Select the four corners of the sketch in the

Expand the Draw panel in the Home tab
and select the Spline Fit button; the
message, “Specify first point or
[Method/Knots/Object]:” appears in the
command line.

same sequence as in the earlier example.



Select the lower-left corner of the sketch; the


message, “Enter next point or [start
Tangency/toLerance]:” appears in the
command line.


Select the top-left corner point of the sketch.



Similarly, select the top-right and lower-

Example 2:


right corners; a spline will be attached to the
pointer.


Press ENTER; a spline with control vertices
will be created.

Press ENTER to create the spline.
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Activate the Spline CV button.
Select Object from the command line.

Next, press ENTER; the message, “Specify



Select the polyline and press Enter; the

appears in the command line.

distance to other axis or [Rotation]:”

polyline is converted in a spline.



Type 10 and press ENTER; the ellipse will
be created.

Example 2 (Axis, End)
In this example, you will draw an ellipse by

Drawing Ellipses

specifying three points. The first two points define

Ellipses are also non-uniform curves, but they have

the location and length of the first axis. The third

a regular shape. They are actually splines created in

point defines the second axis of the ellipse.

a regular closed shape. In AuoCAD, you can draw
an ellipse in three different ways by using the tools
available in the Ellipse drop-down of the Draw
panel. The three different ways to draw ellipses are
explained in following examples.

Example 1 (Center)
In this example, you will draw an ellipse by


specifying three points. The first point defines the

Activate the Dynamic Input on the status
bar, if it is not active.

center of the ellipse. Second and third points define


the two axes of the ellipse.

Click Home > Draw > Ellipse > Axis, End
on the ribbon.



Select an arbitrary point to specify an axis
endpoint.



Type 50 as length of the first axis and press
TAB.



Click Home > Draw > Ellipse > Center
on the ribbon; the message, “Specify



Type 60 as angle and press ENTER.



Type 10 as radius of the second axis and

center of ellipse:” appears in the command

press ENTER; the ellipse will be created

line.

inclined at 60-degree angle.

Select an arbitrary point in the graphics
window; the message, “Specify endpoint of
axis:” appears in the command line.





Move the pointer horizontally and type 20.
62

Part 1: AutoCAD Basics


Example 3 (Elliptical Arc)

Type 0 and press ENTER to specify the start
angle.

In this example, you will draw an elliptical arc. To


draw an elliptical arc, first you need to define the

Type 240 and press ENTER to specify the
end angle.

location and length of the first axis. Next, define the
radius of the second axis; an ellipse will be

Exercises

displayed. Now, you need to define the start angle
of the elliptical arc. The start angle can be any angle
between 0 and 360. After defining the start angle,
you need to specify the end angle of the elliptical
arc.



Turn on the Ortho Mode on the Status bar.



Click Home > Draw > Ellipse > Elliptical
Arc on the ribbon.



Select an arbitrary point to specify an axis
endpoint.



Move the pointer horizontally toward left
and type 60. Next, press ENTER to specify
the axis length.



Move the pointer upward and type 15.
Next, press ENTER to specify the length of
another axis.
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Example:

Chapter 3: Drawing
Aids
In this chapter, you will learn to do the following:


Use Grid and Snap



Use Ortho Mode and Polar Tracking



Use Object Snaps and Object Snap Tacking



Create Layers and assign properties to it



Zoom and Pan drawings



Click Application Menu > New; the Select
Template dialog appears.



Select the acadISO-Named Plot Styles
template. Click Open.



On the Status bar, click the down arrow next

Drawing Aids

to the Snap Mode

This chapter teaches you to define the drawing

Settings. The Drafting Settings dialog

settings, which will assist you to easily create a

appears.

icon and select Snap

drawing in AutoCAD. Most drawing settings can be



Click the Snap and Grid tab on the dialog.

turned on or off from the status bar. You can also



Set Grid X spacing to 10 and press TAB key;

access additional drawing settings by right-clicking

the Grid Y spacing is updated with the

on the button located on the status bar.

same value.


Set Major line every to 10.



Select the Snap On check box.



Make sure that Snap X spacing and Snap Y

Setting Grid and Snap
Grid is the basic drawing setting. It makes the
graphics window appear like a graph paper. You
can turn ON the grid display by clicking the Grid
icon on the status bar or just pressing F7 on the
keyboard.

Snap is used for drawing objects by using the

spacing is set to 10.

intersection points of the grid lines. When you turn
the Snap Mode ON, you will be able to select only
grid points. In the following example, you will learn
to set the grid and snap settings.



Make sure that the Grid snap option is
selected in the Snap type group.
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On the Status bar, click the Customization
option, and then select LineWeight from
the flyout. This shows the LineWeight icon



Click OK on the dialog.



Activate the Grid

on the status bar.


icon on the Status Bar.

Activate the Show/Hide Lineweight
icon located on the status bar.

Setting the Limits of a drawing



Right click on the Show/Hide Lineweight

You can set the limits of a drawing by defining its

icon, and then select Lineweight Settings.

lower-left and top-right corners. By setting Limits of

The Lineweight Settings dialog appears.

a drawing, you will define the size of the drawing
area. In AutoCAD, limits are set to some default
values. However, you can redefine the limits to
change the drawing area as per your requirement.


Type Limits at the command line and press
ENTER.



Type 0,0 and press ENTER to define the



On the Lineweight Settings dialog, select
0.40 mm from the Default drop-down.

lower limit.
Now, you need to define the upper limit.



Click OK.



Type 80,50 and press ENTER key.



Type L in the command line and press



On the Navigate Bar, click Zoom > Zoom

ENTER.


All; the graphics window will be zoomed to

Type 10,10 and press ENTER to define the
first point.

the limits.


Move the pointer horizontally toward right

Setting the Lineweight

and click on the sixth grid point from the

Line weight is the thickness of the objects that you

first point.


draw. In AutoCAD, there is a default lineweight

Move the pointer vertically upwards and

assigned to objects. However, you can set a new

select the third grid point from the second

lineweight. The method to set the lineweight is

point.


explained below.

Move the pointer horizontally toward left
and select the second grid point from the
previous point.
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Move the pointer vertically downwards and
select the grid point next to the previous
point.



Move the pointer horizontally toward left
and select the second grid point from the
previous point.



Move the pointer vertically upwards and
select the grid point next to the previous
point.



Move the pointer horizontally toward left
and select the second grid point from the



Open a new AutoCAD file.



Deactivate the Grid Display and Snap
Mode icons on the status bar.

previous point.




Right-click and select Close.

Click the Ortho Mode

icon on the status

bar.


Click Zoom All on the Navigation Bar.



Click the Line button on the Draw panel.



Select an arbitrary point to define the
starting point.




Move the pointer toward right, type 100 and
press ENTER; you will notice that a

Save and close the file.

horizontal line is created.


Using Ortho mode and Polar

Move the pointer upwards, type 50 and
press ENTER; you will notice that a vertical

Tracking

line is created.


Ortho mode is used to draw orthogonal (horizontal

Click the Polar Tracking icon on the status
bar.

or vertical) lines. Polar Tracking is used to constrain
the lines to angular increments. In the following
example, you will create a drawing with the help of
Ortho Mode and Polar Tracking.



Click the down arrow next to the Polar
tracking icon, and select 30 from the menu.
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easily turn-off the ‘Dimension’ layer for a clearer
view of the object lines.

You will notice a track line at 30-degree
increments when you rotate the pointer.


Move the pointer and stop when the tooltip
displays <150 angle value.

Layer Properties Manager
The Layer Properties Manager is used to create and
manage layers. To open Layer Properties Manager,
click Home > Layers > Layer Properties on the


Type 50 and press ENTER when the tooltip
displays

ribbon or enter LA in the command line.

<150o.



Move the pointer toward left.



Type 100 and press ENTER when the tooltip
displays <180o.

The components of the Layer Properties Manager



Move the pointer vertically downward.

are shown below. The Tree View section is used for



Type 50 and press ENTER when the tooltip

displaying layer filters, group, or state information.

displays <270 o.

The List View section is the main body of the Layer

Right-click and select Close.

Properties Manager. It lists the individual layers



that currently exist in the drawing.

Using Layers
Layers are like a group of transparent sheets that are
combined into a complete drawing. The figure
below displays a drawing consisting of object lines
and dimension lines. In this example, the object lines
are created on the ‘Object’ layer, and dimensions are

The List View section contains various properties.

created on the layer called ‘Dimension’. You can

You can set layer properties and perform various
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operations in the List View section. A brief

Creating a New Layer

explanation of each layer property is given below.

You can create a new layer by using anyone of the
following methods:
1.

Click the New Layer button on the Layer

Status –Shows a green check when a layer is set to

Properties Manager; a new layer with the

current.

name ‘Layer1’ appears in Name field. Next,

Name - Shows the name of the layer.

enter the name of the layer in the Name

On – Used to turn on/off the visibility of a layer.

field.

When a layer is turned on, it shows a yellow lightbulb. When you turn off a layer, it shows a grey
light-bulb.

2.

Freeze/Thaw – It is used to freeze the objects of a

Right-click in the Name field and select
New Layer from the shortcut menu.

layer so that they cannot be modified. Also, the

3.

visibility of the object is turned off.
Lock/Unlock- It is used to lock the layer so that the

Select an existing layer, and then type
ENTER or comma (,).

Making a layer current

objects on it cannot be modified.

If you want to draw objects on a particular layer,

Color – It is used to assign a color to the layer.

then you have to make it current. You can make a

Linetype – It is used to assign a linetype to the layer.

layer current using the methods listed below.

Lineweight – It is used to define the lineweight
(thickness) of objects on the layer.

1.

Select the layer from the List view and click the
Set Current button on the Layer Properties
Manager.

color, linetype, and lineweight while plotting a

2.

Double-click on the Name field of the layer.

drawing.

3.

Right-click on the layer and select Set current.

Plot – It is used to control which layer will be

4.

Select the layer from the Layer drop-down of the

Transparency – It is used to define the transparency
of the layer. You set a transparency level from 0 to
90 for all objects on a layer.
Plot Style – It is used to override the settings such as

plotted.

Layer panel.

New VP Freeze – It is used to create and freeze a
layer in any new viewport.
Description – It is used to enter a detailed
description about the layer.
In the AutoCAD 2018, you can display the Layer
drop-down on the Quick Access Toolbar. To do this,
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click the down arrow next to the Quick Access

drawing. They allow you to select keypoints of

Toolbar and select Layer from the menu.

objects while creating a drawing. You can activate
the required Object Snap by using the Object snap
shortcut menu. Press and hold the SHIFT key and
right-click to display this shortcut menu. Note that
the object snaps can be used only when a drawing
command is active.

5.

Click the Make Current

button on the

Layers panel. Next, select an object; the layer
related to the selected object will become
current.

Deleting a Layer
You can delete a layer by using anyone of the
following methods:
1.

The functions of various Object Snaps are explained
next.

Click the Delete Layer button or press
ALT+D.

2.

Endpoint: Snaps to the endpoints of lines and arcs.

Right-click in the Name field and select
Delete Layer from the shortcut menu.

You will learn more about layers in later chapters.
Midpoint: Snaps to the midpoint of a line.

You can find an example related to layers in the
Offset tool section of chapter 4.

Using Object Snaps
Object Snaps are important settings that improve
your performance and accuracy while creating a
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Intersection: Snaps to the intersections of objects.
Quadrant: Snaps to four key points located on a
circle.

Apparent Intersection: Snaps to the projected
intersection of two objects in 3D space.

Extension: Creates a temporary extension line when

Tangent: Snaps to the tangent points of arcs and

the pointer passes through the endpoints of a line or

circles.

an arc. You can pick points along the temporary
extension lines.

Center: Snaps to the centers of circles and arcs.
Perpendicular: Snaps to a perpendicular location on
an object.

Geometric Center: Snaps to the center point of a
closed geometry created by a single object such as
polyline, rectangle or polygon.
Parallel: It is used to draw an object parallel to
another object.
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From: Locates a point at a specified distance and
direction from a selected reference point.

Node: Snaps to points of dimension` lines, text
objects, dimension text and so on.

Midpoint Between 2 Points: Snaps to the middle
point of two selected points.
Insert: Snaps to the insertion point of blocks, shapes
and text.

Nearest: Snaps to the nearest point found along any
object.

Running Object Snaps
Previously, you have learned to select Object Snaps
from the shortcut menu. However, you can make
Object Snap modes available continuously instead of
selecting them every time. You can do this by using
the Running Object Snaps. To use the Running
Object Snaps, click the down arrow next to the

None: Deactivates Object Snap.

Object Snaps button on the status bar and select the
required object snap from the menu.

Temporary Track Point: It is used to locate a point
by using trace lines from a reference point.
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following example, you will learn to cycle through
different object snaps.

Example:


Click the down arrow next to the Object
Snap button and select the Object Snap
Settings option; the Drafting Settings
dialog appears. Select the Select All check
box and click the OK button.



Draw the objects as shown below.



Click the Circle button on the Draw panel.



Place the pointer on the drawing. Press the

You can also select the Object Snap Settings option
from the menu to open the Drafting Settings dialog.
In this dialog, you can select the required Object
Snaps by selecting check boxes.

TAB key; you will notice that the object
snaps change.



Click when the Center snap is displayed
and draw a circle.

Cycling through Object Snaps
After setting the Running Object Snap settings,
AutoCAD displays object snaps depending on the
shape of the object. However, you can cycle through
the object snaps by pressing the TAB key. In the
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Using Object Snap Tracking

Move the pointer and place it on the
endpoint of the lower horizontal line.

Object Snap tracking is the movement of pointer
along the trace lines originating from the keypoints
of objects. Object Snap Tracking works only when
the Object Snap mode is turned on. In the following
example, you will learn to use Object Snap Tracking
for creating objects.

Example:




Move the pointer vertically upward; you
will notice the trace line, as shown below.



Click on the trace line to create an inclined

Select the Object Snap Tracking button
from the Status bar.

(OR)


Open the Drafting Settings dialog and click

line.

the Object Snap tab.




Select the Object Snap Tracking On check

Snap the pointer to the endpoint of the
lower horizontal line and click.

box.



Click OK.



Use the Line tool and draw the objects as



Right-click and select Enter.

shown below.



Click the Circle button on the Draw panel of
the ribbon.



Place the pointer over the lower endpoint of
the inclined line and move horizontally; you
will notice that a trace line is displayed.



Press the ENTER key twice to start drawing
lines from the last point.
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Place the pointer on the midpoint of the
lower horizontal line; a vertical trace line is
displayed from the midpoint of the
horizontal line as show below.



Click at the point where the horizontal and
vertical trace lines intersect. Next, create a
circle as shown below.

The LTGAPSELECTION system variable when set
to 1 helps you to select the line by clicking in the
gaps. You can turn OFF this feature by setting the

Linetype gap selection

LTGAPSELECTION system variable to 0.

AutoCAD 2018 makes it easy to select linetypes such
as centerlines, dashed dotted lines, hidden,

Using Zoom tools

phantom, and so on. Earlier, it was difficult to select

Using the zoom tools, you can magnify or reduce a

these linetypes by clicking in the gaps. Now, you

drawing. You can use these tools to view the minute

can select them by clicking in the gaps.

details of a very complicated drawing. The Zoom
tools can be accessed from the Navigation Bar,
Command line, and Menu Bar.

You can also snap to the line at the gaps.
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Click Zoom > Zoom Window on the
Navigation Bar.



Specify the first point of the zoom window,
as shown.



Move the pointer diagonally toward right,
and then specify the second point, as shown.
The area inside the window will be
magnified.

Zooming with the Mouse Wheel
Zooming using the mouse wheel is one of the easiest
methods.


Roll the mouse wheel forward to zoom into
a drawing.



Roll the mouse wheel backwards to zoom
out of the drawing.



Press the mouse wheel and drag the mouse
to pan the drawing.

Using Zoom Extents
Using the Zoom Extents tool, you can zoom to the

Using Zoom-Previous

extents of the largest object in a drawing.

After magnifying a small area of the drawing, you



Click Zoom Extents on the Navigation Bar.



You can also double-click on the mouse

can use the Zoom-Previous tool to return to the
previous display.

wheel to zoom to extents.



Click Zoom > Zoom Previous on the
Navigation Bar.

Using Zoom-Window
Using the Zoom-Window tool, you can define the

Using Zoom-Realtime

area to be magnified by selecting two points

Using the Zoom-Realtime tool, you can zoom in or

representing a rectangle.

zoom out of a drawing dynamically.
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Using Zoom Dynamic

Click Zoom > Zoom Realtime on the

With the Zoom Dynamic tool, you can zoom to a

Navigation Bar; the pointer is changed to a

particular portion of a drawing by using a viewing

magnifying glass with plus and minus

box.

symbols.




Press and hold the left mouse button and



Click Zoom Dynamic on the Navigation

drag the mouse forward to zoom into the

Bar; the drawing will be zoomed to its

drawing.

limits. In addition, a viewing box is attached

Drag the mouse backward to zoom out of

to the pointer.

the drawing.

Using Zoom-All
The Zoom All tool is used to adjust the drawing
space to the limits set by using the LIMITS
command.




Click Zoom > Zoom All on the Navigation

Click and drag the pointer to define the size
of the viewing box.

Bar; the drawing will be zoomed to its
limits.



Left-click and move the pointer to the area
to be zoomed.



Click the right mouse button. The area
covered by the viewing box is magnified.
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Using Zoom-Scale



Using the Zoom-Scale tool, you can zoom in or

Enter 10X in the command line to magnify the
location of point by ten times.

zoom out of a drawing by entering zoom scale
factors directly from your keyboard.


Click Zoom > Zoom Scale on the
Navigation Bar. The message, “Enter a scale
factor (nX or nXP)” appears in the
command line.



Enter the scale factor 0.25 to scale the

Using Zoom-Object

drawing to 25% of the full view.


Using the Zoom Object tool, you can magnify a

Enter the scale factor 0.25X to scale the

portion of the drawing by selecting one or more

drawing to 25% of the current view.


objects.

Enter the scale factor 0.25XP to scale the
drawing to 25% of the paper space.



Bar.

Using Zoom-Center


Using the Zoom Center tool, you can zoom to an
area of the drawing based on a center point and
magnification value.




Click Zoom > Zoom Object on the Navigation

Select one or more objects from the drawing and
press ENTER; the objects will be magnified.

Using Zoom-In

Click Zoom > Zoom Center on the Navigation
Bar; the message, “Specify Center point”

Using the Zoom In tool, you can magnify the

appears in the command line.

drawing by a scale factor of 2.

Select a point in the drawing to which you want


to zoom in; the message, “Enter magnification

Click Zoom > Zoom-In on the Navigation Bar;
the drawing is magnified to double.

or height” appears in the command line.
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Using Zoom-Out



Click Pan on the Navigation Bar.



Press and hold the left mouse button and drag

The Zoom-out tool is used to de-magnify the display
screen by a scale factor of 0.5.

Panning Drawings
After zooming into a drawing, you may want to
view an area which is outside the current display.
You can do this by using the Pan tool.

the mouse; a new area of the drawing, which is
outside the current view, is displayed.

Exercises
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Chapter 4: Editing
Tools
In this chapter, you will learn the following tools:


The Move tool



The Copy tool



The Rotate tool

The Move tool moves a selected object(s)



The Scale tool

from one location to a new location without



The Trim tool



The Extend tool



The Fillet tool



The Chamfer tool



The Mirror tool



The Explode tool



The Stretch tool



The Polar Array tool



The Offset tool



The Path Array tool



The Rectangular Array tool

The Move tool

changing its orientation. To move objects, you must
activate this tool and select the objects from the
graphics window. After selecting the objects, you
must define the ‘base point’ and the ‘destination
point’.

Example:


Create the drawing as shown below.



Click Home > Modify > Move on the
ribbon, or enter M in the command line.

Editing Tools



In previous chapters, you have learned to create

Click on the circle located at the right-side,
and then right-click to accept the selection.

some simple drawings using the basic drawing



tools. However, to create complex drawings, you

Select the center of the circle as the base
point.

may perform various editing operations. The tools to
perform the editing operations are available in the
Modify panel on the Home ribbon. You can click the



Make sure that the Ortho Mode is activated.



Move the pointer toward right and pick a
point as shown below. This moves the circle

down arrow on this panel to find more editing tools.

to the new location.

Using these editing tools, you can modify existing
objects or use existing objects to create new or
similar objects.
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The Copy tool

point’ and the angle of rotation. This rotates the
object(s) about the base point.

The Copy tool is used to copy objects and
place them at a required location. This tool is



similar to the Move tool, except that object will

Click Home > Modify > Rotate on the
ribbon or enter RO in the command line.

remain at its original position and a copy of it will be



placed at the new location.

Select the circles as shown below, and then
right-click to accept.

Example:


Draw two circles of 80 mm and 140 mm
diameter, respectively.




Select the center of the other circle as the
base point.

Click Home > Modify > Copy on the ribbon
or enter CO in the command line.



Select the two circles, and then right-click to
accept the selection.



Select the center of the circle as the base
point.



Make sure that the Ortho Mode is active.



Move the pointer toward right.



Type 200 and press ENTER.



Select Exit from the command line. This



Select the Copy option from the command
line.



Type -90 as the rotation angle and press
ENTER; the selected objects are rotated by
90 degrees.

creates a copy of the circles at the new
location.

The Rotate tool
The Rotate tool rotates an object or a group of

The Scale tool

objects about a base point. Activate this tool

The Scale tool changes the size of objects. It

and select the objects from the graphics window.

reduces or enlarges the size without

After selecting objects, you must define the ‘base

changing the shape of an object.
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Click Home > Modify > Scale on the ribbon
or enter SC in the command line.



Select the circles as shown below and rightclick to accept the selection.



Type 150 as the radius of the circle and press
ENTER.



Select the center point of the selected circles
as the base point.



Type 0.8 as the scale factor and press



ENTER.



Likewise, create other circles of radius 100
and 120.

Likewise, scale the circles located at the top
to 0.7.

The Trim tool
When an object intersects with another object,
you can remove its unwanted portion by using the
Trim tool. To trim an object, you must first activate
the Trim tool, and then select the cutting edge


(intersecting object) and the portion to be removed.

Click Home > Draw > Circle > Tan, Tan,

If there are multiple intersection points in a drawing,

Radius on the ribbon.


you can simply select the select all option from the

Select the two circles shown below to define
the tangent points.
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command line; all the objects in the drawing objects
will act as ‘cutting edges’.




Start a new drawing.



Create a sketch as shown below using the

Click Home > Modify > Trim on the ribbon

Line tool.

or enter TR in the command line.
Now, you must select the cutting edges.


Press ENTER to select all the objects as the
cutting edges.
Now, you must select the objects to be
trimmed.



Select the large circles one by one; the circles



will be trimmed.

Click Home > Modify > Trim > Extend on
the ribbon or enter EX in the command line.



Select the vertical line as the boundary edge.
Next, right-click.



Select the horizontal open line. This will
extend the line up to the boundary edge.



Likewise, trim the other circles as shown
below.



Save and close the drawing.

The Extend tool
The Fillet tool

The Extend tool is similar to the Trim tool but
its use is opposite of it. This tool is used to extend

The Fillet tool converts the sharp corners into

lines, arcs and other open entities to connect to other

round corners. You must define the radius

objects. To do so, you must select the boundary up

and select the objects forming a corner. The

to which you want to extend the objects, and then

following figure shows some examples of rounding

select the objects to be extended.

the corners.
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Select the Radius option from the command
line.



Start a new drawing.



Type Limmax in the command line and
press ENTER.





Type 5 and press ENTER.



Select the vertical and horizontal lines, as
shown below.



Notice that a fillet is created.

The Chamfer tool

Set the maximum limit to 100,100 and press

The Chamfer tool replaces the sharp corners

ENTER.


Click Zoom All on the Navigation Bar.



Click Home > Draw > Polyline on the

with an angled line. This tool is similar to the
Fillet tool, except that an angled line is placed at the
corners instead of rounds.

ribbon.


Define the start point as 20, 50.



Draw the lines as shown below.



Click Home > Modify > Fillet > Chamfer
on the ribbon or enter CHA in the
command line.



Follow the prompt sequence given next:

Select first line or
[Undo/Polyline/Distance/Angle/Trim/mEthod/
Multiple]: Select the Distance option from the
command line.


Right-click and select Enter.



Click Home > Modify > Fillet on the ribbon

Define first chamfer distance <0.0000>: Enter 8

or enter F in the command line.

as the first chamfer distance and press ENTER.
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Define second chamfer distance <8.0000>:
Press ENTER to accept 8 as the second chamfer

Select the drawing by clicking on it, and
then press Enter.

distance.

Select first line or
[Undo/Polyline/Distance/Angle/Trim/mEthod/
Multiple]: Select the vertical line on the rightside.



Select the first point of the mirror line as
shown below.

Select second line or shift-select to apply
corner or [Distance/Angle/Method]: Select the
horizontal line connected to the vertical line.



Make sure that the Ortho Mode on the
status bar is active.



Move the pointer toward right and click.



Select the No option from the command line
to retain the source objects.

The Mirror tool
The Mirror tool creates a mirror image of
objects. You can create symmetrical drawings
using this tool. Activate this tool and select the
objects to mirror, and then define the ‘mirror line’
about which the objects will be mirrored. You can
define the mirror line by either creating a line or
selecting an existing line.


Click Home > Modify > Mirror on the
ribbon or enter MI in the command line.
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The Explode tool
The Explode tool explodes a group of objects
into individual objects. For example, when
you create a drawing using the Polyline tool, it acts
as a single object. You can explode a polyline or
rectangle or any group of objects using the Explode
tool.


Click Home > Draw > Arc > Start, End,
Direction on the ribbon.



Select the start point of the arc as shown.



Select the end point of the arc as shown.



Click on the portion of the drawing created
using the Polyline tool; you will notice that
the complete polyline is selected as a single
object.



Click Home > Modify > Explode on the
ribbon or enter X in the command line.



Make sure that the Ortho Mode is active.



Move the pointer toward right and click.



Select the polylines from the drawing.



Press ENTER; the polyline is exploded into
individual objects.

Now, you can select the individual objects of the
polyline.
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The Stretch tool

Move the pointer downward and click to
stretch the drawing.

The Stretch tool lengthens or shortens
drawings or parts of drawings. Note that you
cannot stretch circles using this tool. In addition, you
must select the portion of the drawing to be
stretched by dragging a window.


Click Home > Modify > Stretch on the
ribbon or enter STRETCH in the command



line.


Create a crossing window to select the

Save and close the file.

The Polar Array tool

objects of the drawing.

The Polar Array tool creates an arrangement
of objects around a point in a circular form.
The following example shows you to create a polar
array.





Create two concentric circles of 140 and 50
diameters.



Type C in the command line and press

Press ENTER (or) right-click to accept the
selection.



Select the base point as shown below.

ENTER.


Press and hold the Shift key, right-click and
select Quadrant from the shortcut menu.

88

Part 1: AutoCAD Basics




Select the quadrant point of the circle as
shown below.

Select the arc created after trimming the
circle. Next, right-click to accept the
selection.



Type 30 as radius and press ENTER.



Make sure that Object Snap is activated.



Select the center of the large circle as the
center of the array; the Array Creation tab
appears in the ribbon.



In the Items panel of the Array Creation tab,
set the Items value to 4.



Click Home > Modify > Trim on the ribbon.



Select the large circle as the cutting edge and
right-click.



Notice that the Rotate Items button is active in the

Select the circle on the quadrant as the object

Properties panel of the Array Creation tab. This

to be trimmed.

rotates the objects of the polar array. If you
deactivate this button, the polar array is created
without rotating the objects as shown in figure.



Press Enter.



Click Home > Modify > Array > Polar
Array on the ribbon or ARRAYPOLAR in

In addition, the Associative button is active by

the command line.

default. This ensures that you can edit the array after
creating it.
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Rotate Items buttons are active. Next, click
the Close Array button on the ribbon.



Click Home > Modify > Offset on the
ribbon or enter O in the command line.



Click the Trim button on the Modify panel.



Press ENTER to select all objects as cutting



ENTER.

edges.


Type 20 as the offset distance and press

Trim the unwanted portions as shown



Select the polyline loop.



Click outside the loop to create the parallel
copy.

below.

The Offset tool



Select Exit from the command line.



Click Home > Layers > Layer Properties on
the ribbon (or) type LA in the command

The Offset tool creates parallel copies of lines,

line; the Layer Properties Manager appears.

polylines, circles, arcs and so on. To create a parallel



copy of an object, first you must define the offset

Click the New layer button on the Layer
Properties Manager. Enter Centerline in the

distance, and then select the object. Next, you must

Name field.

define the side in which the parallel copy will be
placed.


Create the drawing shown below using the
Polyline tool. Do not add dimensions.


Click the Set current
the new layer.
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Click in the Linetype field of the current
layer; the Select Linetype dialog appears.

Select the Layer option from the command
line.



Select the Current option from the
command line; this ensures that the offset
entity will be created with the currently



active layer properties. If you select the

On the Select Linetype dialog, click the

Source option, the offset entity will be

Load button; the Load or Reload Linetypes

created with the properties of the source

dialog appears.

object.


Type 10 as the offset distance and press
ENTER.



Select the outer loop of the drawing.



Move the pointer inwards and click to create
the offset entity.



Select the CENTER2 Linetype from this
dialog. Click OK. This adds the linetype to
the Select Linetype dialog.



Click on the Layer drop-down on the Layer
panel of the ribbon.



Select the CENTER2 linetype from the
Select Linetype dialog and click OK.



Close the Layer Properties Manager.



Click the Offset button on the Modify
panel.
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Select the 0 layer from the drop-down.



Create a circle of 12 mm diameter.
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The Path Array tool
The Path Array tool creates an array of objects
along a path (line, polyline, circle, helix,
spline, and so on).



Click Home > Modify > Array > Path Array
on the ribbon or enter ARRAYPATH in the
command line.



Select the circle and right-click.



Select the centerline as the path; the preview



Click the Close Array button.



Save and close the file.

of the path array appears.



The Rectangular Array tool

Click the Divide method on the Properties
panel. Now, you must enter the number of

The Rectangular Array tool creates an array of

items in the path array.

objects along the X and Y directions.

If you select the Measure method, you must
enter the distance between the items in the
path array.



Open a new AutoCAD file and draw the
sketch shown below. Do not add
dimensions. (refer to the Drawing
Rectangles and Drawing Circles section in
Chapter 2 to know the procedure to draw
the rectangle and circle)



Set the Items count to 12.

Notice that the Align Items button is active by
default. As a result, the items are aligned with the
path. If you deactivate this button, the items will not
be aligned with the path.
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Set the Between value in the Rows panel to
60.





Click Close Array on the ribbon.

Draw a circle of 10mm diameter concentric
to the fillet.

Editing Using Grips
When you select objects from the graphics window,


small squares appear on them. These squares are

Click Home > Modify > Array >

called grips. You can use these grips to stretch,

Rectangular Array on the ribbon or enter

move, rotate, scale, and mirror objects, change

ARRAYRECT in the command line.


properties, and perform other editing operations.

Select the small circle and right-click; a
rectangular array with default values
appears.

Grips displayed on selecting different objects are
shown below.

In addition, the Array Creation tab appears.


Set the Columns count to 2.



Set the Rows count to 2.



Set the Between value in the Columns panel
to 60.
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The following table gives you the details of the editing operations that can be performed when you select and
drag grips.
Object

Grip

Editing Operation
Scale: Select anyone of the grips on the circumference and move
the pointer to scale a circle.

Grip on circumference

Circle
Move: Select the center grip of the circle and move the pointer.

Center point grip

Stretch: Select the grip on the circumference and move the
pointer.

Grip on circumference
Arc

Center point grip

Move: Select the center grip of the arc and move the pointer.
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Move: Select the Midpoint grip and move the pointer

Midpoint Grip

Line
Stretch/Lengthen: Select an endpoint grip and move the pointer.
Endpoint Grip

Stretch: Select the corner grips and move the pointer.

Polylines,
Rectangles,
Polygons

Corner Grips
Add/Remove Vertex: Place the pointer on the corner grip and
select Add Vertex/Remove Vertex.
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Convert to Arc: Place the pointer on the midpoint grip and select
Convert to Arc.

Midpoint Grips
Convert to Line: Place the pointer on the midpoint grip of a
polyline arc and select Convert to Line.

Ellipse

Center Grip

Move: Select the center grip and move the pointer.
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Stretch: Select a grip on circumference and move the pointer.
Grips on circumference

Stretch: Select a grip on the spline and move the pointer.

Fit Points
Add/Remove Fit Point: Place the pointer on a fit point and select
Add Fit Point or Remove Fit Point.

Spline

Stretch Vertices: Select the control vertices of a CV spline and
move the pointer.

Control Vertices

Add/Remove Vertices: Place the pointer on a control vertex and
select Add Vertex or Remove Vertex.
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Refine Vertices: Place the pointer on a control vertex and select
Refine Vertices.

Modifying Rectangular Arrays
You can use grips to edit rectangular arrays
dynamically. Various array editing operations using
grips are given next.

Moving a Rectangular array


Create a rectangular array as shown below.

Adding/Removing Level to a Rectangular
array


Place the pointer on the lower left grip of the
rectangular array; a shortcut menu appears.



Select Level Count from the shortcut menu;
the message, “Specify number of levels”



appears in the command line.

Select the array; you will notice that grips
are displayed on it.



Select the grip located at the lower left
corner and move the array, as shown below.
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Type 3 and press ENTER.



Click the Home button near the ViewCube
to view the levels.
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Change the view to Top view by using the
In-Canvas controls.

the pointer and click.

Changing the Column and Row Count




Next, enter the number of columns or drag



To change the column and row count, place

To change the row count only, click the top

the pointer on the top right corner grip; a

left corner grip and drag the pointer. You

shortcut menu appears.

can also enter the row count in the

Select Row and Column Count from the

command line.

shortcut menu; the message, “Specify
number of rows and columns” appears in
the command line.


Type 5 in the command line and press
ENTER; the number of rows and columns
are changed to 5.



If you only want to change the column
count; place the pointer on the lower right
corner grip of the array.

Changing the Column and Row Spacing


To change the total column and row
spacing, place the pointer on the top right
corner grip and select Total Row and
Column Spacing from the shortcut menu.



Select Colum Count from the shortcut
menu.
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Type 80 in the command line; the spacing
between the columns and rows is adjusted



to fit the total length.

If you want to change the distance between
the individual columns, click the second
column grip and drag the pointer.



To change the total column spacing only,
place the pointer on the lower right corner
grip and select Total Column Spacing from
the shortcut menu.


You can also enter the distance in the
command line.



Likewise, you can change the total row
spacing and distance between the individual
rows by using the grips shown below.



Next, enter the total column distance or drag
the pointer and click.
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Editing the Source Item of the Rectangular
Array


Create a rectangular array as shown below.



Click Close Array on the Array Creation

Changing the Axis Angle of the
Rectangular Array


To change the Axis angle of the rows, place
the pointer on the lower right corner grip
and select Axis angle from the shortcut
menu.



Type the angle and press ENTER. Note that
the angle is calculated from the first column
of the array. For example, if you enter 60 as
the axis angle, the rows will be inclined by
60 degrees from the first column.

tab.


Select the rectangular array; the Array tab
appears in the ribbon.



Click the Edit Source button on the Option
panel; the message, “Select item in array”
message appears in the command line.





Likewise, you can change the axis angle of
the columns by using the top left corner
grip.
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Select the lower left triangle of the
rectangular array; the Array Editing State
message box appears.
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Click OK; the array editing state is
activated.



Select Stretch Radius from the shortcut
menu.

Draw a circle and trim the unwanted
portion as shown below.




Move the pointer outward or inward and

Click Save Changes on the Edit Array panel

click. You can also enter a new radius value

of the ribbon.

of the polar array.

Modifying Polar Arrays
Similar to editing rectangular arrays, you can also
edit a polar array by using grips. Various array
editing operations using grips are given next.

Changing the Radius of a Polar array


Create the polar array, as shown in figure.

Changing the Row Count of a Polar array


Place the pointer on the base grip of the
array and select Row Count from the
shortcut menu.



Move the pointer outward and click. You
can also enter the number of the rows in the
command line.



Select the polar array; grips will be
displayed on it.



Place the pointer on the base grip, as shown
in figure.
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To change the distance between the
individual rows, click the second row grip
and move the pointer outward. You can also
enter the distance in the command line.



You can again change the Row Count by
using the last row grip.

Changing the Angle between the Items


To change the angle between the items, click
the second radial grip and enter the new
angle value.

Changing the Row Spacing


To change the total row spacing, place the
pointer on the last row grip and select Total
Row Spacing.

Changing the Fill angle of the array


The default fill angle of a polar array is 360
degrees. To change the fill angle, place the
pointer on the base grip and select Fill



Next, move the pointer and click. You can

Angle from the shortcut menu.

also enter the total row spacing value in the
command line.
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Type 5 and press Enter to specify the
maximum arc length.



Specify the first and second corners of the
revision cloud. You can also select the
Object option, and select an object from the
graphics window. The selected object will be
converted into a revision cloud.



Enter a new value for the fill angle or drag
the pointer and click.


Changing the Item count of a Polar array


Select the revision cloud and notice the
grips. You can use the midpoint grip to

Select the polar array and enter a new item

stretch or add new vertices to the revision

count in the Items box of the Array ribbon.

cloud.

Revision Clouds
Revision clouds are used to highlight the areas in a

You can use the corner point grip to stretch,

drawing. You can create revision clouds using three

add, or remove vertices.

different tools.

Example 1:


Start a new drawing using the acadISO
template.



On the ribbon, click Annotate > Markup >
Revision Cloud > Rectangular

Example 2:


(or)

click Home > Draw > Revision Cloud >

Revision Cloud > Polygonal

Rectangular.


Select Arc Length from the command line.



Type 3 and press Enter to specify the

On the ribbon, click Annotate > Markup >
(or) click

Home > Draw > Revision Cloud >
Polygonal.


minimum arc length.
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Select Calligraphy from the command line.

Home > Draw > Revision Cloud >



Specify the corners of the revision cloud and

Freehand.

press Enter.



Specify the start point of the revision cloud.



Move the pointer around the area to be
highlighted.



Move the pointer onto the start point to
close the cloud.

Example 3:


On the ribbon, click Annotate > Markup >
Revision Cloud > Freehand

(or) click

Exercises
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Chapter 5: Multi
View Drawings
In this chapter, you will learn to create:


Orthographic Views



Auxiliary Views



Named Views

Multi view Drawings
To manufacture a component, you must create its
engineering drawing. The engineering drawing
consists of various views of the object, showing its
true shape and size so that they can be clearly

The following figure shows the orthographic views

dimensioned. This can be achieved by creating the

that will be created when an object is projected using

orthographic views of the object. In the first section

the Third Angle Projection method.

of this chapter, you will learn to create orthographic
views of an object. The second section introduces
you to auxiliary views. The auxiliary views clearly
describe the features of a component, which are
located on an inclined plane or surface.

Creating Orthographic Views
Orthographic Views are standard representations of
an object on a sheet. These views are created by
projecting an object onto three different planes (top,
front, and side planes). You can project an object by
using two different methods: First Angle Projection
and Third Angle Projection. The following figure
shows the orthographic views that will be created
when an object is projected using the First Angle

Example:

Projection method.

In this example, you will create the orthographic
views of the part shown below. The views will be
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created by using the Third Angle Projection
method.

Click Zoom > Zoom All on the Navigation
Bar.
Next, you need to draw construction lines.
They are used as references to create actual
drawings. You will create these construction
lines on the Construction layer so that you
can hide them when required.



Click Home > Draw > Construction line on
the ribbon or enter XLINE in the command
line.



Open a new drawing using the acadISO –
Named Plot Styles.dwt template.



Click the Layer Properties button on the


Layers panel; the Layer Properties Manager

the graphics window.

appears.




Click the New Layer button on the Layer

Move the pointer upward and click to create
a vertical construction line.

Properties Manager to create new layers.


Click anywhere in the lower left corner of



Create two new layers with the following

Move the pointer toward right and click to
create a horizontal construction line.

properties.
Layer Name

Lineweight

Linetype

Construction

0.00 mm

Continuous

Object

0.30 mm

Continuous



Press ENTER to exit the tool.



Click the Offset button on the Modify
panel.



Type 100 as the offset distance and press
ENTER.



Select the vertical construction line.



Move the pointer toward right and click to
create an offset line.





Right-click on the Construction layer and

Offset tool.

select Set current.


Close the Layer Properties Manager.



Activate the Ortho Mode icon on the status

Right-click and select Enter to exit the



Press the SPACEBAR on the keyboard to
start the Offset tool again.

bar.
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Type 75 as the offset distance and press
ENTER.



Select the horizontal construction line.



Move the pointer above and click to create
the offset line.



Press ENTER to exit the Offset tool.



Likewise, create other offset lines as shown
below.



Right-click and select Enter to exit the Line
tool.



Activate the Show/Hide Lineweight button
on the status bar.



Likewise, create the outlines of the top and
side views.



Activate the Object layer.

Now, you must create object lines.


Click the Line button on the Draw panel.



Create an outline of the front view by

Next, you must turn off the Construction
layer.

selecting the intersection points between the


construction lines.

Click on the Layer drop-down in the Layers
panel.



Click the light-bulb of the Construction
layer; the layer will be turned off.
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Use the Offset tool and create two parallel
lines on the front view, as shown below.



Use the Trim tool and trim the unwanted
objects.



Use the Trim tool and trim the unwanted
lines of the front view as shown below.


Create other offset lines and trim the
unwanted portions as shown below.



Use the Offset tool to create the parallel line
as shown below.




Deactivate the Ortho Mode

icon on the

status bar.

Use the Offset tool and create offset lines in



the Top view as shown below.
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Click the Line button on the Draw panel.
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Press and hold the SHIFT key and rightclick. Select the From option.

Move the pointer near the horizontal line of
the front view and click at the intersection
point as shown below. Press ENTER to exit
the tool.



Select the endpoint of the line in the front
view as shown below.

Next, you must create the right side view. To do


Move the pointer on the vertical line and

this, you must draw a 45- degree miter line and

enter 40 in the command line; the first point

project the measurements of the top view onto the

of the line is specified at a point 40 mm

side view.

away from the endpoint. Also, a rubber



band line will be attached to the pointer.


Click on the Layer drop-down in the Layers
panel.

Move the pointer onto the endpoint on the



top view as shown below.

Click the light-bulb icon of the Construction
layer; the Construction layer is turned on.



Select the Construction layer from the Layer
drop-down to set it as the current layer.



Draw an inclined line by connecting the
intersection points of the construction lines
as shown below.



Move the pointer vertically downward; you
will notice the track lines.
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Click the Construction Line button on the
Draw panel.



Select the Hor option from the command



Set the Object layer as current.

line and create the projection lines as shown



Click the Offset button on the Modify
panel.

below.


Select the Through option from the
command line.



Select the lower horizontal line of the side
view.



Right-click to exit the Construction Line
tool.





Press ENTER and select the Ver option from

Select the end point on the front view as
shown below.

the command line.


Create the vertical projection lines as shown
below.



Use the Trim tool trim the extend portions
of the construction lines.
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Use the Line tool and create the objects in

But many components have features located on

the side view as shown below.

inclined faces. You cannot get the true shape and
size for these features by using the orthographic
views. To see an accurate size and shape of the
inclined features, you must create an auxiliary view.
An auxiliary view is created by projecting the
component onto a plane other than horizontal, front
or side planes. The following figure shows a





Turn off the Construction layer by clicking

component with an inclined face. When you create

on the light-bulb of the Construction layer.

orthographic views of the component, you will not

Trim the unwanted portions on the right

be able to get the true shape of the hole on the

side view.

inclined face.

The drawing after creating all the views is

To get the actual shape of the hole, you must create

shown below.



an auxiliary view of the object as shown below.

Save the file as ortho_views.dwg. Close the
file.

Example:
In this example, you will create an auxiliary view of

Creating Auxiliary Views

the object shown below.

Most of the components are represented by using
orthographic views (front, top and/or side views).
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Move the pointer upward and type 25 in the
command line. Next, press ENTER.



Open a new AutoCAD file.



Create four new layers with the following
properties.



Layer Name

Lineweight

Linetype

Construction

0.00 mm

Continuous

Object

0.50 mm

Continuous

Hidden

0.30 mm

HIDDEN

Centerline

0.30 mm

CENTER



Press ESC to exit the Copy tool.



Click the Rotate button on the Modify panel
and select the copied rectangle. Press
ENTER to accept.



Select the lower right corner of the rectangle
as the base point.



Type 45 as the angle and press ENTER.



Create another rectangle approximately 60

Select the Construction layer from the Layer
drop-down in the Layers panel.



Create a rectangle at the lower left corner of

mm above the previous one. Note the left

the graphics window, as shown in figure.

vertical lines of the two rectangles should be
collinear with each other.



Select the rectangle and click the Copy
button on the Modify panel.



Select the lower left corner of the rectangle
as the base point.



Make sure that the Ortho mode is activated.
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The rectangle located at the top is
considered as top view and the below one as



the front view.




Select the Object layer from the Layer dropdown in the Layers panel.

Click the Explode button on the Modify



Activate the Line tool and select the

panel and select the newly created rectangle.

intersection points on the front view, as

Next, right-click to explode the rectangle.

shown.

Activate the Offset tool and select the
Through option from the command line.



Select the left vertical line of the top
rectangle.



Select anyone of the through points, as
shown; the selected vertical line is offset
through the selected point.



Again, select the left vertical line.



Move the pointer, and then select the
remaining through point.


Likewise, create the object lines in the top
view, as shown below.
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Select the Construction layer from the
Layers panel.



Click the Construction Line button on the
Draw panel.



Select the Offset option from the command
line. Next, select the Through option.



Select the inclined line on the front view.
Next, select the intersection point as shown
below.



Likewise, create other construction lines as
shown below.
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command.
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Activate the Construction Line command
and select Offset from the command line.
Type 80 and press ENTER.
Select the inclined line of the front view, as
shown.
Move the pointer toward right and click to
create the construction line.



Set the Construction layer as current layer.
Create projection lines from the circle.



Create the other object lines, hidden lines,
and center lines, as shown below.



Create other construction lines, as shown.
The offset dimensions are given in the
figure.



The drawing after hiding the Construction
layer is shown next.




Set the Object layer as current layer. Next,
create the object lines using the intersection
points between the construction lines.



Use the Circle tool and create a circle of 35
mm diameter.
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Click the New button on the View Manager
dialog; the New View/Shot Properties
dialog appears.



Select the Define Window option from the
Boundary section of the New View/Shot
Properties dialog.



Create a window on the front view, as
shown below.

Creating Named views
While working with a drawing, you may need to
perform numerous zoom and pan operations to
view key portions of a drawing. Instead of doing
this, you can save these portions with a name. Then,
restore the named view and start working on them.


Open the ortho_views.dwg file (The
drawing file created in the Orthographic



Press ENTER to accept.



Enter Front in the View name box.



Click OK on the New View/Shot Properties

Views section of this chapter).


Click the View tab on the ribbon.



Click the right mouse button on the ribbon
and select Show Panels > Views. This
displays the Views panel on the ribbon.



To create a named view, click View > Views
> View Manager on the ribbon; the View
Manager dialog appears.

dialog.


Likewise, create the named views for the top
and right views of the drawing.
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To set the Top view to current, select it from
the Views tree and click the Set Current
button on the dialog. Next, click OK on the
View Manager dialog; the Top view will be
zoomed and fitted to the screen.



Exercise 3

Save and close the file.

Create the orthographic and auxiliary views of the
object shown below.

Exercise 1
Create the orthographic views of the object shown
below.

Exercise 2
Create the orthographic views of the object shown
below.
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Exercise 4
Create the orthographic and auxiliary views of the
object shown below.
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Chapter 6: Dimensions and Annotations
In this chapter, you will learn to do the following:


Create Dimensions



Create Dimension Style



Add Leaders



Create Centerlines



Add Dimensional Tolerances



Add Geometric Tolerances



Edit Dimensions

Dimensioning
In previous chapters, you have learned to draw shapes of various objects and create drawings. However, while
creating a drawing, you also need to provide the size information. You can provide the size information by
adding dimensions to the drawings. In this chapter, you will learn how to create various types of dimensions.
You will also learn about some standard ways and best practices of dimensioning.

Creating Dimensions
In AutoCAD, there are many tools available for creating dimensions. You can access these tools from the Ribbon,
Command line, and Menu Bar.

The following table gives you the functions of various dimensioning tools.

Tool

Shortcut

Function

Dimension

DIM

This tool creates a dimension based on the selected geometry.
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Create a rectangle, circle, arc, and two intersecting lines, as
shown in the previous figure.



Click Annotate > Dimensions > Dimension on the ribbon.



Select a line, move the pointer, and click to create the linear
dimension.



Select a circle, move the pointer, and click to position the
diameter dimension.



Select an arc, move the pointer, and click to position the radial
dimension.



Place the pointer on the arc, type L, and press Enter. Select the
arc, move the pointer, and click to position the arc length
dimension.



Place the pointer on the arc, type A, and press Enter. Select the
arc, move the pointer, and click to position the angle of the arc.



Select two non-parallel lines and position the angular dimension
between them.

Likewise, you can create other types of dimensions using the Dimension
tool.

Linear

DLI

This tool creates horizontal and vertical dimensions.



Click Annotate > Dimensions > Dimension drop-down> Linear
on the ribbon.



Select the first and second points of the dimension.



Move the pointer in horizontal direction to create a vertical
dimension (or) move in the vertical direction to create a
horizontal dimension.



Click to position the dimension.
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Aligned

DAL

This tool creates a linear dimension parallel to the object.



Click Annotate > Dimensions > Dimension drop-down >
Aligned on the ribbon.



Select the first and second points of the dimension line (or) press
Enter and select the line.



Arc Length

DAR

Move the pointer and click to position the dimension.

It dimensions the total or partial length of an arc.



Click Annotate > Dimensions > Dimension drop-down > Arc
Length on the ribbon.



Select an arc from the drawing.



If you want to dimension only a partial length of an arc, select
Partial option from the command line. Next, select the two
points on the arc.


Continue

DCO

Move pointer and click to position the dimension.

It creates a linear dimension from the second extension line of the
previous dimension.



Create a linear dimension by selecting the first and second
points.
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Click Annotate > Dimensions > Continue on the ribbon; a chain
dimension is attached to the pointer.

Baseline

DBA



Select the third and fourth points of the chain dimension.



Position the chain dimension. Next, right-click and select Enter.

It creates dimensions by using the previously created dimension, as
shown below.



Create a linear dimension by selecting the first and second
points.
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Click Annotate > Dimensions > Continue > Baseline on the
ribbon.

Angular

DAN



Select the base dimension.



Select the third and fourth point of the baseline dimension. Next,
right-click and select Enter.

It creates an angular dimension.



Click Annotate > Dimensions > Dimension drop-down > Angle
on the ribbon.



Select the first line and second line.



Move the pointer and position the angle dimension.



To create an angle dimension on an arc, select the arc and
position the dimension.



To create an angle dimension on a circle, select two points on the
circle and position the angle dimension.
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Diameter

DIA

It adds a diameter dimension to a circle or an arc.



Click Annotate > Dimensions > Dimension drop-down>
Diameter on the ribbon.



Select a circle or an arc and position the dimension.

Radius

DRA

It adds a radial dimension to an arc or circle.

Jogged

DJO

It creates jogged dimensions. A jogged dimension is created when it is
not possible to show the center of an arc or circle.



Click Annotate > Dimensions > Dimension drop-down >
Jogged on the ribbon.



Select an arc or circle.



Select a new center point override.



Locate the dimension and the jog location.
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Dimension,
Dimjogline

DJL

It creates a jogged linear dimension.



Click Annotate > Dimensions > Dimension, Dimjogline on the
ribbon.

Center Mark

CENTERMARK



Select the linear dimension to add a jog.



Define the location of the jog on the dimension.

It adds a center mark to a circle or an arc.



Click Annotate > Centerlines > Center Mark on the ribbon.



Select an arc or a circle; the center mark will be positioned at its
center.

Centerline

CENTERLINE

It creates a centreline between two lines. The centreline has the
associative property. It changes with the position of the lines
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Click Annotate > Centerlines > Centerline on the ribbon.



Select two lines which are parallel or non-parallel to each other; a
centreline is created between them.



Ordinate

DOR

Change the position of the lines; the centreline also changes.

It creates ordinate dimensions based on the current position of the User
Coordinate System (UCS).



Click Annotate > Dimensions > Dimension drop-down >
Ordinate on the ribbon.



Select the point of the object.



Move the pointer in the vertical direction and click to position
the X-Coordinate value.



Select the point of the object.
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Move the pointer in the horizontal direction and click to position
the Y-Coordinate value.

Quick
Dimension

QDIM

It dimensions one or more objects at the same time.



Click Annotate > Dimensions > Quick Dimension on the
ribbon.

Adjust Space



Select one or more objects from a drawing.



Right-click and position the dimensions.

In the following figure, the drawing on the left side has congested
dimensions, whereas the right side drawing has dimensions with ample
space between them. You can use the Adjust Space tool to adjust the
space between the dimensions.

DIMSPACE


Click Annotate > Dimensions > Adjust Space on the ribbon.



Select the base dimension from which the other dimensions are
to be adjusted.



Select the dimensions to adjust.



Right-click to accept.



Enter the space value or select the Auto option; the dimensions
will be adjusted with respect to the base dimension.
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Break

DIMBREAK

It adds breaks to a dimension, extension, and leader lines.



Click Annotate > Dimensions > Break on the ribbon.



Select the dimension to add a break.



Select the dimension or object intersecting the dimension
selected in the previous step. This breaks the dimension by the
intersecting object.


Inspect

DIMINSPECT

Right-click to exit the tool.

It creates an inspection dimension. The inspection dimension describes
how frequently the dimension should be checked during inspection
process to ensure the quality of the component.



Click Annotate > Dimensions > Inspect on the ribbon; the
Inspection Dimension dialog appears.
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Click the Select dimensions button on the dialog and select the
dimension to apply the inspection rate.



Right-click to accept.



Select the shape of the inspection from the Shape section.



Enter the Inspection rate. 100% means that the value will be
checked every time during the inspection process. 50% means
half the times.



If required, select the Label check box and enter the inspection
label.



Click OK.



Example:
In this example, you will create the drawing as
shown in figure and add dimensions to it.

Create four new layers with the following
settings.
Layer

Lineweight

Linetype

Construction

0.00 mm

Continuous

Object

0.50 mm

Continuous

Hidden

0.30 mm

HIDDEN2

Dimensions

Default

Continuous



Type LIMMAX and press ENTER.



Type 100, 100 and press ENTER to set the
maximum limit of the drawing.
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Click Zoom All on the Navigation Bar.



Create the drawing on the Object and
Hidden layers.

The Dimension Style Manager dialog appears.



Select the Dimensions layer from the Layer
drop-down in the Dimensions panel.

The basic nomenclature of dimensions is given
below.

Creating a Dimension Style
The appearance of the dimensions depends
on the dimension style that you use. You can create
a new dimension style using the Dimension Style
Manager dialog. In this dialog, you can specify
various settings related to the appearance and
behaviour of dimensions. The following example
By default, the ISO-25 or the Standard dimension

helps you to create a dimension style.

style is active. If the default dimension style does not


Expand the Annotation panel on the Home

suit the dimensioning requirement, you can create a

ribbon tab and click Dimension Style.

new dimension style and modify the nomenclature
of the dimensions.
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To create a new dimension style, click the
New button on the Dimension Style

In the Text placement section, set the
Vertical and Horizontal values to Centered.



Manager dialog; the Create New

Select Text alignment > Horizontal.

Dimension Style dialog appears.


In the Create New Dimension Style dialog,
enter Mechanical in the New Style Name.



Select ISO-25 from the Start With dropdown and click Continue.

Study the other options in the Text tab. These


options let you to change the appearance of the

In the New Dimension Style dialog, click

dimension text.

the Primary Units tab.


Ensure that the Unit Format is set to
Decimal.



Set Precision to 0.



Select Decimal separator > ‘.’(Period).



Click the Lines tab on the dialog.



In this tab, notice the two options in the
Extension lines section: Extend beyond dim
lines and Offset from origin.



Set Extend beyond dim lines and Offset from
origin to 1.25.



Set the Baseline spacing in the Dimension lines
section to 5.

Study the different options in this tab. The options in

Study the other options in the Primary Units tab.

this tab are used to change the appearance and

Most of them are self-explanatory.


Click the Text tab.



Ensure that the Text height is set 2.5.

behaviour of the dimension lines and extension
lines.
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Select the circles from the drawing to apply
the center mark to them.



Click the Symbols and Arrows tab and set


Arrow size to 3 and Center Marks to 3.


Select the Line option in the Center marks

On the ribbon, click Annotate >
Dimensions > Dimension



section.

.

Make sure that the Object Snap icon is
turned on the status bar.



Select the lower right corner of the drawing.



Select the endpoint of the center mark of the
small circle; the dimension is attached to the
pointer.



Move the pointer vertical downwards and
position the dimension, as shown below.

Notice the different options in this tab. The options
in this tab are used to change the appearance of the
arrows and symbols. Also, you can set the
appearance of the center marks and centrelines of
circles and arcs.


Click OK to accept the settings.



Click Set Current on the Dimension Style
Manager dialog; the Mechanical dimension


style will be set as current.

command line.



Click Close to close the dialog.



On the Annotate tab of the ribbon, click
Centerlines > Center Mark

Select the Baseline option from the

.
140

Part 1: AutoCAD Basics




Select the right extension line of the linear

Save and close the drawing.

dimension; a dimension is attached to the
pointer.


Select the endpoint of the center mark of the
large circle; another dimension is attached to
the pointer.



Select the lower left corner of the drawing.



Press ENTER twice.

Adding Leaders
A leader is a thin solid line terminating with an
arrowhead at one end and a dimension, note, or
symbol at the other end. In the following example,
you will learn to create a leader style, and then


create a leader.

Select the Angular option from the
command line.





Example 1:

Select the two angled lines of the drawing
and position the angle dimension.



Draw a square of 24 mm side length.

Select the large circle and position the



Create a circle of 10.11 mm diameter at
center of the square.

diameter dimension.


Likewise, select the small circle and position
the dimension.



Select the fillet located at the top left corner;
the radial dimension is attached to the
pointer.



Select Mtext from the command line and


type 2X and press SPACEBAR.






Click Home > Draw > Arc > Center, Start,
Angle on the ribbon.

Click in the graphics window to update the
dimension text.



Select the center point of the circle.

Next, position the radial dimension



Move the pointer horizontally toward right.

approximately at 45 degrees.



Type 6 as the radius and press ENTER.

Likewise, apply the other dimensions, as



Type 270 as the included angle and press
ENTER.

shown.
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On the Home tab of the ribbon, expand

Click Continue; the Modify Multileader
Style dialog appears.

Annotation panel and click Multileader



Style icon; the Multileader Style Manager

Click the Leader Format tab and set the
Arrowhead Size to 2.5.

appears.

Also, notice the other options in this tab. They are
used to set the appearance of the multileader lines
and the arrow head.



Click the Leader Structure tab and set the
Landing distance to 5.

In the Multileader Style Manager dialog,
click the New button; the Create New
Multileader Style dialog appears.


Click the Content tab and set the Text
height to 2.5.

The other options in this tab are used to define the
appearance of the text or block that will be attached
at the end of the leader line.




In the Create New Multileader Style dialog,

Click OK on the Modify Multileader Style
dialog.

enter Hole callout in the New style name



box and select Standard from the Start with

Click Set Current on the Multileader Style
Manager dialog.

drop-down.



Click Close to close the dialog.



Click Annotate > Leaders > Multileader on
the ribbon.
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Click the down arrow next to the Polar
tracking button on the status bar and select
45 from the menu.



Activate the Polar tracking

button on the

status bar.


Select a point in the first quadrant of the arc.



Click Select and Copy buttons.



Move the pointer in the top right direction



Close the Character Map dialog.

and click to create the leader.



Right-click and select Paste; the depth
symbol is pasted in the text editor.



Adjust the spacing so that the complete text
is in one line.





Click in the graphics window.

Type M12x1.75 – 6H 16 in the text editor.
Next, you must insert the depth symbol
before 16.



Position the pointer before 16 and click the
Symbol button on the Insert panel of the

Adding Dimensional Tolerances

Text Editor ribbon; a menu appears.

During the manufacturing process, the accuracy of a
part is an important factor. However, it is impossible
to manufacture a part with the exact dimensions.


Click Other on the menu; the Character

Therefore, while applying dimensions to a drawing

Map dialog appears.

we provide some dimensional tolerances, which lie
within acceptable limits. The following example
shows you to add dimension tolerances in



AutoCAD.

In the Character Map dialog, select GDT
from the Font drop-down.



Example:

Select the Depth symbol from the fonts



table.
143

Create the drawing, as shown below. Do not
add dimensions to it.

Part 1: AutoCAD Basics


Click OK on New Dimension Styles dialog.



Click Set Current and Close on the
Dimension Style Manager dialog.





Apply dimensions to the drawing.

Create a new dimension style with the name
Tolerances.



In the New Dimension Styles dialog, click
the Tolerances tab.



In the Tolerances tab, set the Method as

Geometric Dimensioning and

Deviation.


Set Precision as 0.00.

Tolerancing



Set the Upper Value and Lower Value to

Earlier, you have learned how to apply tolerances to

0.05.

the size (dimensions) of a component. However, the



Set the Vertical position as Middle.

dimensional tolerances are not sufficient for



Specify the following settings in the Primary

manufacturing a component. You must give

Units, Text, and Symbols and Arrows tab:

tolerance values to its shape, orientation and
position as well. The following figure shows a note

Primary Units tab:

which is used to explain the tolerance value given to

Unit format: Decimal

the shape of the object.

Precision: 0.00
Decimal Separator: ‘.’Period
Text tab:
Text Height: 2.5
Text placement:
Vertical:Centered
Horizontal:Centered
Text alignment: Horizontal
Symbols and Arrows tab:

Providing a note in a drawing may be confusing. To

Arrow Size: 2.5

avoid this, we use Geometric Dimensioning and

Center Marks: Line

Tolerancing (GD&T) symbols to specify the
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tolerance values to shape, orientation and position of
a component. The following figure shows the same
example represented by using the GD&T symbols.
In this figure, the vertical face to which the tolerance
frame is connected, must be within two parallel
planes 0.08 apart and perpendicular to the datum
reference (horizontal plane).

The Geometric Tolerancing symbols that can be used to interpret the geometric conditions are given in the table
below.

Purpose

Symbol
Straightness

Flatness

Cylindricity
To represent the shape of a single
feature.
Circularity

Profile of a surface

Profile of a line
Parallelism
To represent the orientation of a
feature with respect to another

Perpendicularity

feature.
Angularity
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Position

Cocentricity and
coaxiality
To represent the position of a
feature with respect to another
feature.

Run-out

Total Run-out

Symmetry

Example 1:
In this example, you will apply geometric tolerances
to the drawing shown below.



In the Geometric Tolerance dialog, click the
upper box of the Sym group. The Symbol
dialog appears.



Create the drawing as shown below.



In the Symbol dialog, click the
Perpendicularity symbol. The symbol



Click Annotate > Dimensions > Tolerance
on the ribbon; the Geometric Tolerance
dialog appears.

appears in the Sym group.
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Click in the top left box in the Tolerance 1
group. The diameter symbol appears in the

leader points to 2.


box.


Enter .05 in the box next to the diameter

Click the Content tab and select Multileader
type > Block.

symbol.



On the Leader Structure tab, set Maximum



Select Source block > Box.



Set the Scale value to 0.75.



Click OK, Set Current, and Close.



On the Home ribbon tab, click Annotation >
Multileader

Enter A in the upper box of the Datum 1



group.

.

Specify the first and second points of the
datum reference as shown.



On the Edit Attributes dialog, set type A in
the Enter tag number box.




Click OK.

Click OK and position the Feature Control
frame as shown below.

Editing Dimensions by Stretching
In AutoCAD, the dimensions are associative to the

Next, you must add the datum reference.

drawing. If you modify a drawing, the dimensions


On the Home ribbon tab, expand the

will be modified, automatically. In the following

Annotation panel and click Multileader

example, you will stretch the drawing to modify the

Style

dimensions.

.



Click the New button.



On the Create New Multileader Style

Example:


dialog, type Tolerance in the New Style

apply dimensions to it.

name box, and click Continue.


Click the Leader Format tab and select
Arrowhead > Symbol > Datum triangle
filled.



Create the drawing as shown below and

Set the Size to 2.5.
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Modifying Dimensions by Trimming




Click Home > Modify > Stretch on the

and Extending

ribbon.

In earlier chapters, you have learned to modify

Drag a window and select the right-side

drawings by trimming and extending objects. In the

circles and the horizontal lines.

same way, you can modify dimensions by trimming
and extending. The following example shows you to
modify dimensions by this method.

Example:


Create a drawing as shown below and add
dimensions to it.



Right-click and select the center point of the

Move the pointer to stretch the drawing;
you will notice that the horizontal
dimension also changes.



Click Home > Modify > Trim on the ribbon.



Select the horizontal edge as shown in figure
and right-click to accept.

right-side circles.




Type 30 and press ENTER; the horizontal
dimension is updated to 80.
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Select the vertical dimension with the value
18. This trims the dimension up to the
selected edge.

Using the DIMEDIT command
The DIMEDIT command can be used to modify


Press ESC.



Click Home > Modify > Trim > Extend on

dimension. Using this command, you can add text to
a dimension, rotate the dimension text and extension

the ribbon.


lines or reset the position of the dimension text.

Select the vertical edge as the boundary, as
shown below. Next, right-click to accept.

Example 1: (Adding Text to the
dimension)


Type DED in the command line and press
ENTER.



Select the New option from the command
line; a text box appears.




Enter TYP in the text box and press the
SPACEBAR.

Select the horizontal dimension with the
value 10. This will extend the dimension up
to the selected boundary.





Press Esc.

Left-click and select the dimension with
value 10.
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Press ENTER; the dimension text will be
changed.

Type D in the command line and press
ENTER; the Dimension Style Manager
dialog appears.



In the Dimension Style Manager dialog,
select Standard from the Styles list and click
Modify.



In the Modify Dimension Style dialog, click
the Text tab, and then set the Text height to
2.5.



Example 2: (Rotating the dimension text)


Click the Text Style button; the Text Style
dialog appears.

Enter DED in the command line and select
the Rotate option; the message, “Specify
angle for dimension text” appears in the
command line.



Type 30 and press ENTER.



Select the dimension with the value 50 and



In the Text Style dialog, change the Font
Style to Italic.

right-click. The angle of the dimension text
is changed to 30 degrees. Note that the angle



Click Apply and close the Text Style dialog.

is measured from the horizontal axis (X-



Click OK on the Modify Dimension Style
dialog.

axis).


Click Close on the Dimension Style
Manager dialog.



In the Dimensions panel, set the dimension
style to Standard.

Using the Update tool
The Update tool is used to update a dimension with
the currently active dimension style. For example, if



you have created a new dimension style, you can

Click the Update button on the Dimensions
panel.

apply it to an already existing dimension using the
Update tool. The following example shows you to
update a dimension.
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Select the horizontal dimension with the
value 30. Next, right-click; the dimension
will be updated with the current the
dimension style.



Type-in DS in the command line, and then
press Enter.



On the Drafting Settings dialog, click the
Snap and Grid tab.



In the Drafting Settings dialog, set Snap
type to Isometric snap and click OK.

Using the Oblique tool
The Oblique tool is used to incline the extension
lines of a dimension. This tool is very useful while



dimensioning the isometric drawings. It can also be

Turn on the Snap Mode and the Ortho
Mode. Also, turn on the Dynamic Input.

used in 2D drawings when the dimensions overlap
with each other.



Click Zoom All on the Navigation Bar.



Type L in the command line and press
ENTER.

Example:



In this example, you will create an isometric
drawing and add dimensions to it. Next, you will
use the Oblique tool to change the angle of the
dimension lines.

Click at a random point and move the
pointer vertically.



Type 40 in the command line and press
ENTER; a vertical line will be created.



Move the pointer toward right; you will
notice that an inclined line is attached to the
pointer.

151

Part 1: AutoCAD Basics


Right-click and select Copy-Selection from
the shortcut menu.





Select the lower left corner point as the base
point.



Move the pointer toward right and click

Type 30 and press ENTER; an inclined line
is drawn.



Move the pointer toward downward and
click when the tooltip shows 20<270.

when the tooltip shows 40 < 30.





Right-click and select Enter.



Use the Line tool and connect the endpoints

Move the pointer toward right and click
when the tooltip displays 30 < 330.



Move downward and click when the tooltip
shows 20 < 270.



Move the pointer toward left and click on

of the two sketches.

the start point of the sketch.


Right-click select Enter.



Turn off the Ortho Mode.



Create a selection window and select all the



Deactivate the ISODRAFT

and the

Snap Mode icons on the Status bar.

objects of the sketch.
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Use the dimensioning tools and apply
dimensions to the sketch.

Type 150 as the oblique angle and press
ENTER; the dimensions are oblique as
shown below.



Expand the Dimensions panel on the
Annotate ribbon tab and click the Oblique



button.

Again, click the Oblique tool on the
Dimensions panel and select the aligned
dimensions. Next, right-click to accept.



Select the vertical dimensions and right-click
to accept; the message, “Enter obliquing
angle” appears in the command line.



Type 90 as the oblique angle and press
ENTER; the dimensions will be oblique as
shown below.
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Editing Dimensions using Grips



In Chapter 4, you have learned to edit objects using

You can also stretch angular or radial
dimensions.

grips. In the same way, you can edit dimensions
using grips. The editing operations using grips are
discussed next.

Example 1: (Stretching the Dimension)


Select the dimension to display grips on it.



Select the endpoint grip of the dimension.



Next, move the pointer and select a new
point; the dimension value will be updated,
automatically.

Example 2: (Moving the Dimension)


To move a linear dimension, select the
middle grip and move the pointer.

154

Part 1: AutoCAD Basics
endpoint of the dimension line and select
the required option from the menu.



Likewise, you can move the angular and
radial dimensions.

Modifying Dimensions using the
Properties palette
Using the Properties palette, you can modify the
dimensional properties such as text, arrow size,
precision, linetype, lineweight, and so on. The

Example 3: (Modifying the Dimension
text)


Properties palette comes in handy when you want
to modify the properties of a particular dimension

Select the dimension and position the
pointer on the middle grip; a shortcut menu
appears as shown below.

only.

Example:


Create the drawing shown in figure and
apply dimensions to it.

The options in the menu are self-explanatory. You
can perform the required operation by selecting the
corresponding option.


Likewise, position the pointer on the



Select the vertical dimension and right-click.



Select Properties from the shortcut menu;
the Properties palette appears.
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In the Properties palette, under the Lines &
Arrows section, set the Arrow size to 2.

Close the Properties palette; you will notice
that the properties of the dimension are
updated as per the changes made.



Under the General section, set Color to
Blue.

Matching Properties of Dimensions
or Objects
In the previous section, you have learned to change
the properties of a dimension. Now, you can apply
these properties to other dimensions by using the
Match Properties tool.


Click Home > Properties > Match
Properties on the ribbon or type MA and
press ENTER; the message, “Select source
object” appears in the command line.



Set the Ext line offset value to 1.25.



Scroll down to the Text section and set Text
height to 2.

156

Part 1: AutoCAD Basics




Select the vertical dimension from the

Select the other dimensions from the

drawing; the message, “Select destination

drawing; the properties of the source

object(s) or [Settings]:” appears in the

dimension are applied to other dimensions.

command line.




Select the Settings option from the

Right-click and select Enter.

command line; the Property Settings dialog

Exercise 1

appears.

Create the drawing shown below and create hole
callouts for different types of holes. Assume missing
dimensions.

In this dialog, you can select the settings that can be

Exercise 2

applied to the destination dimensions or objects. By

Create the following drawings and apply

default, all the options are selected in this dialog.

dimensions and annotations. The Grid Spacing X=


10 and Grid Spacing Y=10.

Click OK on the Property Settings dialog.
Next, you must select the destination
objects.
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Method: Limits
Precision: 0.00
Upper Value: 0.05
Lower Value: 0.05

Exercise 3
Create the drawing shown below. The Grid spacing
is 10 mm. After creating the drawing, apply
dimensional tolerances to it. The tolerance
specifications are given below.
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Chapter 7: Parametric Tools
In this chapter, you will learn to do the following:


Apply Geometric and Dimensional Constraints



Create Equations using the Parameter Manager



Create Inferred Constraints

Parametric Tools
Parametric tools are one of the main advancements in CAD/CAM/CAE. Using the parametric tools, you can
define the shape and size of a drawing by applying relations and dimensions between the objects. You can also
use equations in place of dimensions. Changing one parameter of an equation would change the entire shape and
size of the drawing. This makes it easy to modify the design.

The parametric tools can be accessed from the Ribbon, Command line, and Menu Bar.

Geometric Constraints
Geometric Constraints are used to control the shape of a drawing by applying geometric relationships between
the objects. For example, you can apply the Tangent constraint to make a line tangent to a circle. You can use the
Equal constraint to make two lines equal in length.
The following table shows various geometric constraints and their functions.
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Constraint

Function
It is used to constraint a point to lie on another point or an object.

Coincident

Collinear



Click Parametric > Geometric > Coincident on the ribbon.



Select a point on a line or arc.



Select a point on another object; the two points will coincide with each other.

It is used to constraint a line along another line. The lines are not required to touch each
other.

Concentric



Click Parametric > Geometric > Collinear on the ribbon.



Select the first line and the second line; the second line will be made collinear with
the first line.

It is used to make the center points of arcs, circles or ellipses coincident.



Click Parametric > Geometric > Concentric on the ribbon.



Select a circle or arc from the drawing.



Select another circle or arc; the second circle will be concentric with the first circle.
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Equal

It is used to make two objects equal. For example, if you select two circles, the diameter of the
two circles will become equal. If you select two lines, the length of the two lines will be equal.



Click Parametric > Geometric > Equal on the ribbon.



Select two objects from the drawing; the second object will be made equal to the first
object.

Horizontal

It is used to make a line horizontal. You can also make two points lie along the horizontal
axis.



Click Parametric > Geometric > Horizontal on the ribbon.



Select a line to make it horizontal.



If you want to make points horizontal, select the 2Points option from the command
line and select the two points.

Vertical

Fix

It is used to make a line vertical. You can also make two points vertical.


Click Parametric > Geometric > Vertical on the ribbon.



Select a line to make it vertical.



You can also use the 2Points option to make two points vertical.

It is used to fix a point or an object at a particular location.


Click Parametric > Geometric > Fix on the ribbon.
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Select a point to make it fixed at its location.



You can also use the Objects option to select objects from the drawing.

It is used to make two lines perpendicular to each other.
Perpendicular



Click Parametric > Geometric > Perpendicular on the ribbon.



Select two lines from the drawing; the second line is made perpendicular to the first
line.

Smooth

It is used to make a spline continuous with another spline or arc.



Click Parametric > Geometric > Smooth on the ribbon.



Select a spline curve.
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Select another spline or arc; the first curve will become continuous with the second
curve.

Parallel

Symmetric

It is used to make two lines parallel to each other.



Click Parametric > Geometric > Parallel on the ribbon.



Select two lines from the drawing; the second line is made parallel to the first line.

It is used to make two objects symmetric about a line. The objects will have same size,
position and orientation about a line.

Tangent



Click Parametric > Geometric > Symmetric on the ribbon.



Select two objects from the drawing.



Select the symmetry line; the objects will be made symmetric about the selected line.



You can also use the 2Points option to make two points symmetric about a line.

It is used to make an arc, circle, or line tangent to another arc or circle.
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Click Parametric > Geometric > Tangent on the ribbon.



Select a circle, arc, or line.



Select another circle, arc, or line; the second object will be tangent to the first object.

The Auto Constrain tool is used to apply constraints to the objects, automatically.
Auto
Constrain



Click Parametric > Geometric > Auto Constrain on the ribbon.



Select the Settings option from the command line; the Constraint Settings dialog
appears.



In this dialog, select the constraints that you want to apply. You can also select the
Tangent objects must share an intersection point and Perpendicular objects must
share an intersection point options.



Click OK.



Select multiple objects by clicking on them or by dragging a selection window.
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Right-click and select Enter; geometric constraints are applied to the objects based on
their geometric condition.

Example:

the center points of the two circles will be

In this example, you will create the following

horizontal.

drawing by using the drawing and parametric tools.



Open a new AutoCAD file.



Create two circles and a line as shown in



Create four lines as shown below.



Click the Coincident

figure.
button on the

Geometric panel and select the two
endpoints of the lines as shown below; the
endpoints will be made coincident.



Click Parametric > Geometric > Horizontal
on the ribbon.



Select the line to make it horizontal.



Press the SPACEBAR and select the 2Points
option from the command line.



Select the large circle and the small circle;
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Click the Auto Constrain button on the
Geometric panel and select the four lines as
shown below.


Use the Parallel

tool and make the two

lines parallel, as shown below.



Right-click and select Enter; constraints are
applied to the selected objects,
automatically.



Click the Vertical

button on the

Geometric panel and select the line as
shown below; the line will become vertical.


Use the Perpendicular

tool and make the

two lines perpendicular, as shown below.
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Click the Coincident

button on the

Geometric panel.


Select the Object option from the command
line and select the large circle.



Select the endpoint of the lower horizontal
line to make it coincident with the circle.



Use the Tangent

tool and make the two

horizontal lines tangent to the large circle, as
shown below.



Likewise, apply the Coincident constraint
between the large circle and the upper
horizontal line.



Use the Trim tool and trim the unwanted
portion of the circle.
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Also, you will notice that the Tangent and
Coincident constraints have been deleted.
These constraints were the properties of the

Dimensional Constraints

trimmed portion of the circle. As a result,

Dimensional constraints are applied to a drawing

constraints are also deleted along with the

after applying the Geometric constraints. They are

trimmed portion.

used to control the size and position of the objects in




Click the Auto Constrain button on the

a drawing. You can apply the dimensional

Geometric panel.

constraints using the tools available in the

Drag a window around the arc and

Dimensional panel of the Parametric ribbon.

horizontal lines.




Right-click and select Enter; the Tangent

Click the inclined arrow on the

and Coincident constraints are applied

Dimensional panel; the Constraint Settings

between the arc and the horizontal lines.

dialog appears.


On the Constraints Settings dialog, set
Dimension name format to Name.
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Click the OK button.



Click Parametric > Dimensional > Linear
on the ribbon.



You will notice that when you try to apply

Select the two endpoints of the lower

dimensional constraint to the horizontal line

horizontal line; the dimensional constraint is

connected to the arc, the Dimensional Constraints

attached to the pointer.

message box appears. It shows that the dimension
will over-constrain the geometry. In an overconstrained geometry, there are conflicting
dimensions or relations or both. Click the Cancel
button on the Dimensional Constraints message
box.



Place the dimension constraint and left click.



Similarly, apply linear dimensions to other
lines as shown below.



Click the Diameter button on the
Dimensional panel and apply the diameter
dimension to the circle located on the left
side.
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Click the Parameters Manager button on the
Manage panel; the Parameters Manager
palette appears.



Click the Radius button on the Dimensional
panel and apply the radial dimension to the
arc.


Double-click in the box next to the dia1 and
enter 50.



Likewise, change the values of the other
dimensions as shown below.

Creating equations using the
Parameters Manager
Equations are relations between the dimensional
constraints. Look at the drawing given below. In this
drawing, all the dimensions are controlled by the
diameter of the hole. In AutoCAD, you can create
this type of relations between dimensions very
You will notice that the circle is placed outside the

easily using the Parameter Manager palette.

loop.


Click Zoom All on the Navigation Bar to
view the circle.
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Creating Inferred Constraints



Click the Concentric

button on the

Geometric panel.

The Infer Constraints button helps you to create


constraints automatically. With this button active on

Select the circle located outside the loop and
the fillet; they both will be concentric.

the status bar, you can automatically create
constraints while drawing a sketch.


On the status bar, click the Customization
button and select Infer Constraints from the
flyout. This adds the Infer Constraints
button to the status bar.



Activate the Infer Constraints button on the
status bar.


Use the Radius tool from the Dimensional
panel and apply the radius dimensional



constraint to the fillet.

Click the Fillet button on the Modify panel



of the Home ribbon.


Open the Parameters Manager palette and
modify the rad2 value to 3/2*dia1.

Select the Radius option from the command
line and enter 50 as the radius.



Create a fillet at the lower left corner of the
sketch.



To hide all the Geometric Constraints, click
the Hide All

button on the Geometric

panel.


Similarly, click Hide All

on the

Dimensional panel to hide all the
dimensional constraints.
You will notice that Tangent and Coincident
constraints are applied, automatically.
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Exercise 2
In this exercise, you need create the drawing as
shown below and apply geometric and dimensional
constraints to it. Also, create relations between
dimensions in the Parameter Manager.



To modify the size of the drawing, change
the value of dia1 in the Parameters Manager
window; you will notice that all the values
will be changed, automatically.



Save and close the file.

Exercise 1
In this exercise, you need to create the drawing
shown in figure and apply geometric and
dimensional constraints to it.
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Chapter 8: Section
Views

Create four layers with the following
properties.

In this chapter, you will learn to:


Create Section Views



Set Hatch Properties



Use Island Detection tools



Create text in Hatching



Edit Hatching



Create the drawing as shown below. Do not
apply dimensions.

Section Views
In this chapter, you will learn to create section
views. You can create section views to display the
interior portion of a component that cannot be
shown clearly by means of hidden lines. This can be
done by cutting the component using an imaginary
plane. In a section view, section lines, or cross-hatch
lines are added to indicate the surfaces that are cut
by the imaginary cutting plane. In AutoCAD, you
can add these section lines or cross-hatch lines using
the Hatch tool.


The Hatch tool

Select the Hatch lines layer from the Layer
drop-down.

The Hatch tool is used to generate hatch lines by
clicking inside a closed area. When you click inside a
closed area, a temporary closed boundary will be
created using the PLINE command. The closed
boundary will be filled with hatch lines, and then it
will be deleted.

Example 1:


In this example, you will apply hatch lines to the

or enter H in the command line; the Hatch

drawing as shown in figure below.


Click Home > Draw > Hatch on the ribbon,

Creation tab appears in the ribbon.

Open a new AutoCAD file.
173

Part 1: AutoCAD Basics

Example 2:
In this example, you will create the front and section
views of a crank.




Select ANSI31 from the Pattern panel of the
Hatch Creation ribbon tab.

Create five layers with the following
settings:

Layer

Lineweight

Linetype

Construction

0.00 mm

Continuous

Object

0.30 mm

Continuous

Centerline

0.00 mm

CENTER

Hatch lines

0.00 mm

Continuous

Cutting
Plane

0.30 mm

PHANTOM



Activate the Construction layer and create
construction lines, as shown.



Click in the four regions of the drawing, as
shown below.



Set the Object layer as current and create
draw circles, as shown below.



Click the Close Hatch Creation button on
the ribbon.
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Switch to Construction layer and create

On your own, create the objects of the
section view, as shown below. (For any help,

construction lines as shown.

refer to the Multi view Drawings section of
Chapter 5)



Switch to Object layer and create two lines
as shown.



Set the Centerlines layer as current and
create center marks and centrelines.



On your own, create other objects on the


front view as shown.
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Click the Polyline button on the Draw panel
and pick a point below the front view, as
shown.




Create another arrow by changing the width
of the polyline. Deactivate the tool.

Select the Width option from the command
line.



Type 0 as the starting width and press
ENTER.



Type 10 as the ending width and press
ENTER.



Move the pointer horizontally toward right
and enter 20.



Again select the Width option from the
command line.



Set the starting and ending width to 0.



Move the pointer horizontally and click



Activate the Hatch lines layer.



Type H in the command line and press
ENTER.



Select the seTtings option from the
command line; the Hatch and Gradient

when trace lines are displayed, as shown

dialog appears.

below.



Click in the Swatch box under the Type and
pattern group; the Hatch Pattern Palette
dialog appears.



Move the pointer vertically up and click.



Move the pointer toward left and click when
trace lines are displayed from the endpoint
of the lower horizontal line.


Click the ANSI tab, select ANSI31 from the
dialog, and then click OK.
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Click the Add Pick Points button from the
Boundaries group and click in Region 1,
Region 2 and Region 3.

Example:


Create four layers with the following
settings.
Layer

Lineweight

Linetype

Construction

0.00 mm

Continuous

Object

0.30 mm

Continuous

Centerline

0.00 mm

CENTER2

Hatch lines

0.00 mm

Continuous



Create the following drawing in different
layers. Do not apply dimensions.



Press ENTER to create hatch lines.



Type H and press ENTER; the Hatch
Creation tab appears in the ribbon.





Save the drawing as Crank.dwg and close.

Select the Pattern option from the Hatch
Type drop-down in the Properties panel.

Setting the Properties of Hatch lines
You can set the properties of the hatch lines such as
angle, scale, transparency in the Properties panel of
the Hatch Creation ribbon.
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You can also select a different hatch type
such as Solid, Gradient, and User defined.


Select ANSI31 from the Pattern panel.



Select Blue from the Hatch Color dropdown.



Adjust the Hatch Pattern Scale to 1.5; you
will notice that the distance between the
hatch lines changes.



Expand the Properties panel and set the



Hatch Layer Override to Hatch lines.

Click Close Hatch Creation button on the
Close panel.



Press the SPACEBAR to activate the
HATCH command again.





Click the Pick Points button from the

Properties panel.

Boundaries panel.



Change the Hatch Angle value to 90 in the



Pick points in the outer areas of the drawing
as shown below.
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The Match Properties tools are used to create new

On zooming into the hatch lines, you may notice

hatch lines by using the properties of an existing

that they are not aligned properly. This is because

one. The Use source hatch origin tool will create a

the Use Current Origin button activated in the

new hatching using the origin of the source.

Origin panel. As a result, the origin of the drawing
will act as the origin of the hatch pattern. However,



you can change the origin of the hatch pattern.

Select the source hatching, as shown in
figure.



Pick a point in the empty area as shown
below.



Click Set Origin button on the Origin panel.



Set the origin point as shown below



Click Close Hatch Creation.



Activate the Hatch tool and click Match

New hatch lines are created using the properties and
origin of the source hatching.

.


Properties > Use source hatch origin on the

Save and close the file.

Island Detection tools

Options panel.

While creating hatch lines, the island detection tools
help you to detect the internal areas of a drawing.
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Example:


Create the drawing as shown below. Do not
apply dimensions.



Click Home > Draw > Hatch on the ribbon.



Select ANSI31 from the Pattern panel.



Expand the Options panel and select the
Normal Island Detection tool.



Press Enter.



Click Undo on the Quick Access Toolbar.



Activate the Hatch tool and select ANSI31
from the Pattern panel.



Expand the Options panel and select Outer
Island Detection option.



Pick a point in the area outside the large
circle and press ENTER; you will notice that



hatch lines are created only outside the large

Pick a point in the area outside the large

circle. The Outer Island Detection tool will

circle; you will notice that the area inside the

enable you to create hatch lines only in the

small circle is detected automatically. Also,

outermost level of the drawing.

hatch lines are created inside the small
circle.
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Repeat the process using the Ignore Island
Detection tool. You will notice that the
internal loops are ignored while creating the
hatch lines.



Select Arial from the Font drop-down of the
Formatting panel.

Text in Hatching
You can create hatching without passing through
the text and dimensions.




Create a drawing as shown in figure.



Ensure that Text Height is set to 2.5.



Type AutoCAD in the text editor. Left-click

Click Home > Annotation > Multiline Text

in the empty space of the graphics window.

on the ribbon.



Specify the first and second corner of the


text editor, as shown below.

Activate the Hatch tool and select the
Normal Island Detection option from the
Options panel.
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Pick a point in the area covered by the
outside boundary and press ENTER; hatch
lines are created.
You will notice that hatch lines do not pass
through the text and dimension.
The expanded dialog will display more
options as shown below. The options in this
dialog are same as that available in the
Hatch Creation tab.

Editing Hatch lines
You can edit a hatch by using the Edit Hatch tool or
simply selecting the hatch.


To edit a hatch using the Edit Hatch tool,
expand the Modify panel of the Home
ribbon and select the Edit Hatch tool.



Edit the options in the Hatch Edit dialog
and click the OK button; the hatch pattern



will be modified.

Select the hatch from the drawing, the Hatch
Edit dialog appears. The options in this
dialog are same as that available in the
Hatch Creation ribbon. Expand this dialog
by clicking the More Options button located
at the bottom right corner.

Exercise 1
Create the half section view of the object shown below.
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Exercise 2
In this exercise, the top, front, and right side views of an object are given. Replace the front view with a section
view. The section plane is given in the top view.
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Creating Blocks

Chapter 9: Blocks,
Attributes and Xrefs

To create a block, first you need to create shapes
using the drawing tools and use the BLOCK
command to convert all the objects into a single

In this chapter, you will learn to do the following:


Create and insert Blocks



Create Annotative Blocks



Explode and purge Blocks



Use the Divide tool



Use the DesignCenter and Tool Palettes to

object. The following example shows the procedure
to create a block.

Example 1


apply dimensions. Assume the missing
dimensions.

insert Blocks


Insert Multiple Blocks



Edit Blocks



Create Blocks using the Write Block tool



Define and insert Attributes



Work with Xrefs

Create the drawing as shown below. Do not

Introduction



Click Insert > Block Definition > Create

In this chapter, you will learn to create and insert

Block on the ribbon; the Block Definition

Blocks and Attributes in a drawing. You will also

dialog appears.

learn to attach external references to a drawing. The
first part of this chapter deals with Blocks. A Block is
a group of objects combined and saved together.
You can later insert it in drawings. The second part
of this chapter deals with Attributes. An Attribute is
an intelligent text attached to a block. It can be any
information related to the block such as description,
part name, and value and so on. The third part of the
chapter deals with the Xrefs (external references).
External references are drawing files, images, PDF
files attached to a drawing.
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Enter Target in the Name field.



Click the Select Objects button on the



created and saved in the database.

dialog. Drag a window and select all the



Click OK on the dialog; the block will be

objects of the drawing.

Inserting Blocks

Right-click to accept; the dialog appears

After creating a block, you can insert it at the desired

again.

location inside the drawing using the INSERT

You can choose to retain or delete the objects

command. The procedures to insert blocks are

after defining the block. The Retain option

explained in following examples.

under the Objects section retains the objects

Example 1

in the graphics window after defining the



block. The Convert to Block option deletes

Click Insert > Block > Insert > Target on the
ribbon.

the objects and displays the block in place of
them. The Delete option completely deletes
the objects from the graphics window.


Select the Delete option under the Objects
section.



Click the Pick point button on the dialog.



Select the midpoint of the left vertical line.
The selected point will be the insertion point
when you insert this block into a drawing.



Pick a point in the graphics window to place
the block.

Example 2 (Scaling the block)


On the ribbon, click Insert > Block > Insert
> More Options; the Insert dialog appears.

You can also add description to the block in the



Select Target from the Name drop-down.

Description box. In addition to that, you can set

You can use the options in the Scale section

the behaviour of the block such as scalability,

to scale the block. The Uniform Scale option

annotative and explode ability using the options

can be used to scale the block uniformly.

in the Behavior section. The options in the

You can uncheck this option to specify the

Settings area can be used to set the units of the

scale factor separately in the X, Y and Z

block and link a website or other files with the

boxes. If you check the Specify On-screen

block.

option, the block can be scaled dynamically



Uncheck the Scale uniformly option (for

in the graphics window.

this example).
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Check the Specify On-screen option and

dynamically rotate the block by selecting the

uncheck the Uniform Scale option in the

Specify On-screen option.


Scale section.


Rotation section.

Click OK; the block is attached to the


pointer.




Click OK and pick a point in the graphics

Pick a point in the graphics window; the

window; the message, “Specify rotation

message, “Enter X scale factor, specify

angle <0>:” appears in the command line.

opposite corner, or [Corner/XYZ]:” appears

As you rotate the pointer, the block also

in the command line. In addition, as you

rotates. You can dynamically rotate the

move the pointer, the block automatically

block and pick a point to orient the block at

scales.

an angle or type a value and press ENTER to

Type 3 and press ENTER; the message,

specify the angle.


“Enter Y scale factor <use X scale factor>:”

Type 45 and press ENTER; the block will be
rotated by 45 degrees.

appears.


Check the Specify On-screen option in the

Type 2 as the Y scale factor and press
ENTER; the block will be scaled, as shown
below.



Save and close the drawing file.

Creating Annotative Blocks
Annotative blocks possess the annotative properties.
They will be scaled automatically depending upon

Example 3 (Rotating the block)


the scale of the drawing sheet. The procedure to

Click Home > Block > Insert > More

create and insert annotative blocks is explained in

Options on the ribbon; the Insert dialog

the following example.

appears.


Select Target from the Name drop-down.



Uncheck the Specify On-screen option in

Example:


the Scale section and check the Uniform

Create the drawing a shown in figure.
Assume the missing dimensions.

scale option.
The options in the Rotation section are used
to rotate the block. You can enter the
rotation angle in the Angle box. You can
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Set the Annotation Scale to 1:10.



Click Insert > Block > Insert > More
Options.



Uncheck the Specify On Screen option
under the Rotation section.





Click Insert > Block Definition > Create

dialog.

Block on the ribbon; the Block Definition
dialog appears.


Enter Turbine Driver in the Name field.



Click the Select Objects button on the



Click OK.



Pick a point in the graphics window; the
block will be inserted with the scale factor
1:10.

dialog. Create a window and select all the



objects of the drawing. Right-click to accept



Select the Delete option under the Objects

Change the Annotation Scale to 1:2; you
will notice that the block is automatically

section.


Click Zoom All on the Navigation Bar to
view the block.

the selection.


Click Name > Turbine Driver on the Insert

scaled to 1:2.

Click the Pick Point button and select the
midpoint of the left vertical line.

Exploding Blocks
When you insert a block into a drawing, it
will be considered as a single object even
though it consists of numerous individual objects. At
many times, you may require to break a block into
its individual parts. Use the Explode tool to break a



block into its individual objects.

Check the Annotative option under the
Behavior section. Click the OK button on





To explode a block, click Home > Modify >

the dialog.

Explode on the ribbon or type EXPLODE in

Activate the Automatically Add Scale to

the command line and press ENTER.

Annotative Objects button located at the



right-side of the Status Bar.

Select the block and press ENTER; the block
will be broken into individual objects. You
can select the individual objects by clicking
on them. (Refer to the Explode Tool section
of Chapter 4).
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Using the Purge tool
You can remove the unused blocks and other
unwanted drawing data from the database using the
Purge tool.


To delete the unused data, click Application
Menu > Drawing Utilities > Purge; the
Purge dialog appears.



Click the Purge button on the dialog; the
Purge – Confirm Purge message box
appears.



Click Purge this item to delete the item from
the database.



To remove unwanted blocks from the



database, expand the Blocks tree and select
the blocks.

Click Close on the Purge dialog.

Using the Divide tool
The Divide tool is used to place number of instances
of an object equally spaced on a line segment. You
can also place blocks on a line segment. The
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following example shows you to divide a line using

will be divided into five segments and four

the Divide tool.

instances of blocks will be placed.

Example:


Create the object, as shown in figure.



Create a block with the name Diode. Specify



the midpoint of the left vertical line as the

Trim the unwanted portions, as shown
below.

base point.


Create a line of 50 mm length and 45
degrees inclination.



Expand the Draw panel in the Home tab
and click the Divide button.

Renaming Blocks
You can rename blocks at any time. The procedure


Select the line segment; the message, “Enter

to rename blocks is discussed next.

the number of segments or [Block]:”


appears.




down arrow located at the right side.

Select the Block option from the command
line; the message, “Enter name of block to



Select Show Menu Bar from the drop-down.

insert” appears.



On Menu bar, click Format > Rename or

Type Diode and press ENTER; the message,

type RENAME in the command line and

“Align block with object? [Yes/No] <Y>:”

press ENTER; the Rename dialog appears.


appears.


In the Rename dialog, select Blocks from
the Named Objects list.

Select the Yes option; the message, “Enter
the number of segments:” appears.



On the Quick Access Toolbar, click the

Type 5 and press ENTER; the line segment
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Select the block to be named from the Items
list and enter a new name in the Rename To

On the Insert table dialog, specify the
values, as shown below.

box.



Click OK and define the insertion point of
the table.




Click OK; the block will be renamed.

Type-in values in the table cells, as shown
below.

Inserting Blocks in a Table
You can insert blocks in a table and fit inside the
table cells. Note that you cannot insert Annotative
blocks in a table. The following example shows you
to insert a block in a table.

Example:


Create three blocks as shown below. You
can also download them from the



companion website.

Select the first cell in the Symbol row and
right-click.



Select Insert > Block from the shortcut
menu; the Insert a Block in a Table Cell
dialog appears.



On the ribbon, click Annotate > Tables >
Table.
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In the Insert a Block in a Table Cell dialog,

effective way. Using the DesignCenter, you can

select INT from the Name drop-down.

insert blocks created in one drawing into another

Set Overall cell alignment to Middle

drawing. You can display the DesignCenter by
clicking View > Palettes > DesignCenter on the

Center.

ribbon (or) entering DC in the command line. The
following example shows you to insert blocks using
the DesignCenter.



Click OK; the INT symbol will be placed in
the selected cell.

Example:


Open a new drawing file.



Create the following symbols and convert
them into blocks. You can also download
them from the companion website.



Likewise, insert the other symbols in the
corresponding cells.

Using the DesignCenter
DesignCenter is one of the additional means by
which you can insert blocks and drawings in an
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You can also insert blocks by activating the Insert
dialog.



Save the file as Electronic Symbols.dwg.
Close the file.



Open a new drawing file.



Set the maximum limit of the drawing to
100,100. Click Zoom All on the Navigation
Bar.



Click View > Palettes > DesignCenter on
the ribbon; the DesignCenter palette


appears.


Use the Move and Rotate tools and arrange
the blocks, as shown below.

In the DesignCenter palette, browse to the
location of the Electronic Symbols.dwg file
using the Folder List. Select the file and
double-click on the Blocks icon; all the
blocks present in the file will be displayed.



Drag and place the blocks in the graphics
window.
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Close the DesignCenter palette.



Use the Line tool and complete the drawing,
as shown below.
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Using Tool Palettes

There are many blocks available in the

You can arrange blocks, dimensions, hatch patterns

Architectural, Mechanical, Electrical, Civil, and

and other frequently used tools in Tool Palettes.

Structural palettes. You can drag and place blocks

Similar to the DesignCenter palette, you can drag

from these palettes. You can also right-click on a

and place various features from Tool Palettes into

block and perform various operations using the

the drawing. You can display the Tool Palettes by

shortcut menu displayed as shown in figure.

clicking View > Palettes > Tool Palettes on the
ribbon or entering TOOLPALETTES in the

Creating a New Tool Palette

command line.



Right-click on the Tool Palette and select
New Palette from the shortcut menu; a new
palette is added to Tool Palettes.



Enter Electronic Symbols as the name.

You can also create a new tool palette using the
Customize dialog.

There are many palettes arranged in the Tool
Palettes window. You can display more palettes by



clicking the lower left corner of the Tool Palettes and

Right-click on Tool Palettes and select
Customize Palettes; the Customize dialog

selecting the required palettes.

appears.

194

Part 1: AutoCAD Basics




In the Customize dialog, right-click in the
Palettes list and select New Palette.

In the DesignCenter palette, select the
Electronic symbols.dwg file from Folder
List.



Right-click and select Create Tool Palette; a
new palette will be created from the
drawing file.



Enter the name of the palette and click the
Close button.

Adding Blocks to a Tool Palette


Open the DesignCenter palette and select
the Electronic Symbols.dwg file from the
Folders list; the blocks available in the
selected file appear.



Drag the blocks from the DesignCenter and
place them in the Tool Palette.

In the Tool Palette, you can group blocks depending
on their function.
You can also create a new tool palette from a



drawing consisting of blocks.

Right-click on the Tool Palette and select
Add Separator; a separator will be added.



Right-click and select Add Text. Enter the
name of the group.
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Enter 4 as the column value; the message,
“Specify distance between columns (|||):”
appears.



Type 60 and press ENTER; the pumps will
be inserted as shown below.



Likewise, insert the reservoirs and create

Inserting Multiple Blocks
You can insert multiple instances of a block at a time
by using the MINSERT command. This command is

lines as shown below.

similar to the ARRAY command. The following
example explains the procedure to insert multiple
blocks at a time.

Example:


Create a two blocks as shown below.

Editing Blocks
During the design process, you may need to edit
blocks. You can easily edit a block using the Block
Editor window. As you edit a block, all the instances


Type MINSERT in the command line and

of it will be automatically updated. The procedure to

press ENTER; the message, “Enter block

edit a block is discussed next.

name or [?]:” appears.




Type Pump and press ENTER; the Pump is

Click Insert > Block Definition > Block

attached to the pointer.

Editor on the ribbon; the Edit Block



Pick a point in the graphics window.

Definition dialog appears.



Enter 1 as the scale factor.



Enter 0 as the rotation angle; the message,
“Enter number of rows (---) <1>:”appears.



Enter 1 as the row value; the message,
“Enter number of columns (|||) <1>:”



appears.

In the Edit Block Definition dialog, select
Pump from the list and click OK; the Block
Editor window appears.
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Using the Write Block tool
Using the Write Block tool, you can create a
drawing file from a block or objects. You can later


insert this drawing file as a block into another

Click Home > Draw > Polyline on the

drawing. The procedure to create a drawing file

ribbon and draw a polyline, as shown

using blocks is discussed in the following example.

below.

Example:



Click Close Block Editor on the Close panel.



In the Block – Changes Not Saved dialog,
click Save the changes to Pump.



Start a new drawing file and create two
blocks, as shown below. You can also
download them from the companion
website.



Insert the blocks and create the drawing, as
shown below.

All the instances of the block will be updated
automatically.
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Expand the Block Definition panel and
select the Set Base point button.



Select the endpoint of the lower horizontal
line as shown.

In the Write Block dialog, you can select three
different types of sources (Block, entire drawing, or
objects) to create a block. If you select the Block
option, you can select blocks present in the drawing


Click Insert > Block Definition > Write

from the drop-down.

Block on the ribbon; the Write Block dialog
appears.



Select the Entire drawing option.



Specify the location of the file and name it as
Tap-in line.



Click the OK button.



Close the drawing file.



Open a new drawing file, and then type I in
the command line and press ENTER; the
Insert dialog appears.



Click the Browse button and go to the
location of the Tap-in Line file.



Select Tap-in line from the Name dropdown and click OK.



Pick a point in the graphics window to
insert the block.
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Press Enter to accept 0 as the angle of
rotation.

Defining Attributes


An attribute is a line of text attached to a block. It

Click Insert > Block Definition > Define

may contain any type of information related to a

Attributes on the ribbon; the Attribute

block. For example, the following image shows a

Definition dialog appears.

Compressor symbol with an equipment tag. The
procedure to create an attribute is discussed in the
following example.

Example 1:


Open a new drawing file.



Create the symbols, as shown below.

The options in the Mode group of the Attribute
Definition dialog define the display mode of the
attribute. If you check the Invisible option, the
attribute will be invisible. The Constant option
makes the value of the attribute constant. You
cannot change the value. The Verify option prompts
you to verify after you enter a value. The Preset
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option can be used to set a predefined value for the

Click the Create Block button on the Block

attribute. The Lock position option fixes the position

Definition panel; the Block Definition

of the attribute to a selected point. The Multiple

dialog appears.

lines option allows typing the attribute value in a



single or multiple lines.


On the dialog, click the Select objects
button.


Ensure that the Lock position option is

Drag a window, select the control valve
symbol, and attribute. Press ENTER.

selected.



Select the Delete option from the Objects
group.

The options in the Attribute group define the values



of the attribute. The Tag box is used to enter the

Click the Pick Point button under the Base
point group and select the point, as shown

label of the attribute. For example, if you want to

below.

create an attribute called RESISTANCE, you must
type Resistance in the Tag box. The Prompt box
defines the prompt message that appears after
placing the block. The Default box defines the
default value of the attribute.


In the Attribute Definition dialog, enter
Valvetag in the Tag box.


The Text Settings options define the display

click OK.

properties of the text such as style, height and so on.



Observe the other options in this dialog. Most of

Enter 5 in the Text Height box.



Set the Justification to Middle and click

Likewise, create Equipmenttag attribute
and place inside the tank symbol.

them are self-explanatory.


Enter Control Valve in the Name box and



Create a block and name it as Tank.



Also, create a block of the nozzle symbol

OK.


Specify the location of the attribute as
shown below.

and name it Nozzle.
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Inserting Attributed Blocks
You can use the INSERT command to insert the
attributed blocks into a drawing. The procedure to
insert attributed blocks is discussed next.





Place the nozzles on the tank, as shown
below.

On the ribbon, click Insert > Block > Insert
> Tank.



Click in the graphics window to define the
insertion point. The Edit Attributes dialog
appears.



Enter TK-001 in the EQUIPMENTTAG field
and click OK; the block will be placed along
with the attribute.



Use the Polyline tool and connect the
control valves and tank.



Likewise, place control valves, as shown

Working with External references

below.

In AutoCAD, you can attach a drawing file,
image or pdf file to another drawing. These
attachments are called External References (Xrefs).
They are dynamic in nature and update
automatically when changes are made to them. In
the following example, you will learn to attach
drawing files to a drawing.
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Example 1:


Create the drawing shown below.



Type BASE in the command line and press
ENTER.





Save the drawing as Nut.dwg and close it.



Open the Crank.dwg file created in Chapter
8.

Select the midpoint of the vertical line as the



base point.

Click Insert > Reference > Attach on the
ribbon; the Select Reference file dialog
appears.



Save the drawing as Crank pin.dwg



Create another drawing as shown below



Browse to the location of the Crankpin.dwg
and double-click on it; the Attach External
Reference dialog appears.

(For help, refer to the Multi View Drawings
section in Chapter 5).

Some of the options available in this dialog are
similar to that in the Insert dialog, such as the
insertion point, scale, and rotation angle of the
external reference.


Accept the default settings in this dialog and
click OK; the crank pin will be attached to
the pointer.





Use the Set Base Point tool and specify the
base point, as shown below.
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Browse to the location of the Nut.dwg and
double-click on it; the Attach External
Reference dialog appears.



In the Attach External Reference dialog,
enter 90 in the Angle box under the
Rotation group and click OK.



Select the insertion point on the section view
as shown below.



On the ribbon, click View tab > Palettes
panel > External References Palette.

Fading an Xref
You can change the fading of Xref by using the Xref
fading slider available in the expanded Reference
panel.



Expand the Reference panel of the Insert
ribbon and use the Xref fading slider to
adjust the fading.



In the External References palette, open the
Attach drop-down and select the Attach
DWG option; the Select References file
dialog appears.

Clipping External References
You can hide the unwanted portion of an external
reference by using the Clip tool.



Click Insert > Reference > Clip on the
ribbon; the message, “Select Object to clip”
appears in the command line.
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Select the Nut.dwg from the graphics
window.



Select the New boundary option from the
command line.



Select the Rectangular option from the
command line.



Draw a rectangle as shown below; only the



front view of the nut is visible and the top

Use the Clip tool and clip the Xref.

view is hidden. Also, the clipping frame is
visible.



To hide the clipping frame, type

Editing the External References

XCLIPFRAME in the command line


Type 0 and press ENTER.



You can also hide the frame by clicking

AutoCAD allows you to edit the external references
in the file to which they are attached. You can also
edit them by opening their drawing file. The

Modify > Object > External reference >

procedure to edit an external reference is discussed

Frame on the Menu Bar.

next.



Attach another instance of the Nut.dwg file.



Use the Rotate and Move tools to position

To edit an external reference, expand the
Reference panel and click the Edit
Reference button.

the top view as shown below.
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In the Create New Multileader Style dialog,
enter Balloon Callout in the New Style
name box and click Continue.



Select Nut from the drawing; the Reference
Edit dialog appears



Click OK to get into the reference editing
mode.





In the drawing, you will notice that the

click the Content tab and set the

centerlines of the nut are overlapping on the

Multileader type to Block.

centerlines of the crank. Delete the



centerlines and center marks of the nut.


In the Modify Multileader Style dialog,

Under Block Options, set the Source block
to Circle.

Click Save changes on the Edit Reference



Set the Scale to 3.



Click Leader Format tab and set the

panel; the AutoCAD message box appears.

Arrowhead Size to 8.



Click OK.


Adding Balloons


as current.

Click Annotate > Leader > Multileader



Click Close.

Style Manager (inclined arrow) button on



Click Annotate > Leader > Multileader on

the ribbon; the Multileader Style Manager

the ribbon.

dialog appears.


Click OK and set the Balloon Callout style



Click the New button on the dialog.

Click the down arrow next to the Polar
Tracking icon on the status bar and select 45
from the menu. Activate the Polar Tracking.
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Creating Part List

Select a point on the section view of the
crank.





Move the pointer along the polar trace lines

Click Annotate > Table > Table Style on the
ribbon; the Table Style dialog appears.

and click; the Edit Attributes dialog
appears.



In the Table Style dialog, click the New
button; the Create New Table Style dialog
appears.



In the Create New Table Style dialog, enter
Part List in the Name box. Click Continue;



In the Edit Attributes dialog, enter 1 in the
Enter tag number field.

the New Table Style dialog appears.


Click the Text tab and set the Text height to
10.



Click OK; the balloon will be created.



Select the Header option from the Cell
Styles drop-down and set the Text height to
10.



Likewise, create other balloons.



Click OK.



In the Table Style dialog, select the Part List
style and click Set current.



Close the dialog.



Click the Table button on the Tables panel;
the Insert table dialog appears.
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Click on anyone of the edges of the table;
you will notice that grips are displayed on it.
You can edit the table using these grips.



Ensure that the Table style is set to Part
List.


Click and drag the square grip below the
MATERIAL cell; the width of the cell will be
changed.



Under the Set cell Styles group, set the First
row cell style to Header.



Set the Second row cell style and All other



row cell styles to Data.

Click and drag the triangular grip located at
the bottom left corner of the table; the height
of the rows will be increased uniformly.



Set the number of Columns to 4 and
Column width to 65.



Set the Data rows and Row height to 2 and



1, respectively.


the Table Cell ribbon appears. You can use

Click OK and place the table at the lower

this ribbon to modify the properties of the

right corner of the graphics window.


Click in the second cell of the first column;

table cell.

Enter PART No., NAME, MATERIAL, QTY



in the first row of the Part list table. Use the

Click the Insert Below button on the Rows
panel; a new row will be added to the cell.

TAB key to navigate between the cells.



Click in the top left corner cell of the table.



Press and hold the SHIFT key and click in
the lower right corner of the table; all the



Click Close Text Editor button on the

cells in the table will be selected.

ribbon.
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Double-click in the cell below the PART
No.; the text editor will be activated.



Enter the following data in the cells. Use the
TAB to navigate between the cells.



In the Table Cell ribbon, click Cell Styles >
Alignment drop-down > Middle Center;
the data in all the cells will appear in the
middle center of the cells.

Exercise

208

Part 1: AutoCAD Basics

209

Part 1: AutoCAD Basics

210

Part 1: AutoCAD Basics

Working with Layouts

Chapter 10: Layouts
& Annotative
Objects

Layouts represent the conventional drawing sheet.
They are created to plot a drawing on a paper or in
electronic form. A drawing can have multiple layouts
to print in different sheet formats. By default, there
are two layouts available: Layout 1 and Layout 2. You
can also create new layouts by clicking the plus (+)

In this chapter, you will learn to do the following:


Create Layouts



Specify the Paper space settings



Create Viewports in Paper space



Change Layer properties in Viewports



Create Title Block on the layout



Use Annotative objects in Viewports

symbol next to the layout. Next, select New layout
from the shortcut menu. In the following example,
you will create two layouts, one representing the ISO
A1 (841 X 594) sheet and another representing the ISO
A4 (210 X 297) sheet.

Drawing Layouts
There are two workspaces in AutoCAD: The Model

Example:

space and the Paper space. In the Model space, you
create 2D drawings and 3D models. You can even



Open a new drawing file.

plot drawings from the model space. However, it is



Create layers with the following settings:

difficult to plot drawings at a scale or if a drawing

Layer

Linetype

Lineweight

scales. For this purpose, we use Layouts or paper

Construction

Continuous

Default

space. In Layouts or paper space, you can work on

Object Lines

Continuous

0.6mm

Hidden Lines

Hidden

0.3 mm

Center Lines

CENTER

Default

Dimensions

Continuous

Default

Title Block

Continuous

1.2mm

Viewport

Continuous

Default

consists of multiple views arranged at different

notes and annotations and perform the plotting or
publishing operations. In Layouts, you can arrange a
single view or multiple views of a drawing or
multiple drawings by using Viewports. These
viewports display drawings at specific scales on
layouts. They are mainly rectangular in shape but
you can also create circular and polygonal
viewports. In this chapter, you will learn about
viewports and various annotative objects.



Create the drawing, as shown next. Do not
add dimensions.
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Click the Layout 1 tab at the bottom of the
graphics window.

You will notice that a white paper is displayed with
the viewport created, automatically. The
components of a layout are shown in figure below.



In the Page Setup dialog, select DWG to
PDF.pc3 from the Name drop-down under
the Printer/Plotter group.



Set the Plot Style table to acad.stb.



Set the Paper size to ISO A1 (841.00 x 594.00
MM). Set the Plot scale to 1:1.



Click Output > Plot > Page Setup Manager
on the ribbon; the Page Setup Manager
dialog appears.



In the Page Setup Manager dialog, click the



Modify button; the Page Setup –Layout1

Click OK, and then click Close on the Page
Setup Manager dialog.

dialog appears.
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Rectangular on the ribbon.

Click the Layout2 tab below the graphics
window.



Double-click on the Layout1 tab and enter
ISO A1; the Layout1 is renamed.



Similarly, rename the Layout2 to ISO A4.



Click Layout > Layout > Page Setup on the



Create the rectangular viewport by picking

ribbon; the Page Setup Manager dialog

the first and second corner points, as shown

appears.

in figure.



Select ISO A4 from the list.



Click the Modify button on the dialog.



In the Page Setup dialog, select the DWG to
PDF.pc3 plotter and select acad.stb from the
Plot style table drop-down.



Set the Paper size to ISO A4 (210 x 297 MM)
and Scale to1:1.



Set Drawing Orientation as Portrait and
click OK; you will notice that the size of the
Layout is changed to A4 size.



Close the Page Setup Manager dialog.

Creating Viewports in the Paper


space

Click the PAPER button on the status bar;
the model space inside the viewport will be

The viewports that exist in the paper space are

activated. In addition, the viewport frame

called floating viewports. This is because you can

will become thicker when you are in model

position them anywhere in the layout and modify

space.

their shape size with respect to the layout.

Creating a Viewport in the ISO A4 layout


Open the ISO A4 layout, if not already


open.




Select the default viewport that exists in the

1:2 from the menu; the drawing will be

ISO A4 layout.

zoomed out.

Press the DELETE key; the viewport will be
deleted.



Click the Viewport Scale button and select

Click Layout > Layout Viewports >
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Use the Pan tool and position the drawing
in the center of the viewport.



After fitting the drawing inside the
viewport, you can lock the position by
clicking the Lock/Unlock Viewport button
on the status bar.



After locking the viewport, you cannot change the

to the model space.

scale or position of the drawing.


Double-click inside the viewport to switch



Click the MODEL button on the status bar

Use the Zoom and Pan tools and drag the
drawing to the center of the viewport.

to switch back to paper space.



Click the Viewport Scale button and select
the 2:1 from the menu.



Use the Pan tool and position the drawing,
as shown in figure.



Click the Lock/Unlock Viewport button on
the status bar.



Double-click outside the viewport to switch
to the paper space.



Use the Circle tool and create a 180 mm
diameter circle on the layout, as shown
below.

Creating Viewports in the ISO A1 layout


Click the ISO A1 tab below the graphics
window.



Select the viewport frame and modify the
viewport using the grips, as shown below.
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Click Layout > Layout Viewports >
Viewport drop-down > Object on the
ribbon.



Select the circular viewport and press
ENTER; the drawing inside the viewport
will be locked. Now, you cannot zoom or
pan the drawing.



Select the circle from the layout; it will be
converted into a viewport.



Click Output > Plot > Preview on the
ribbon; the plot preview will be displayed.





Double-click in the circular viewport to

You will notice that the viewport frames are

switch to the model space.

also displayed in the preview.

Click the Viewport Scale button on the
status bar and select 4:1 from the menu; the
drawing will be zoomed in to its center.



Use the Pan tool and adjust the drawing, as
shown below.



Press ESC to close the preview window.

To hide viewport frames while plotting a drawing,
follow the steps given below.





Click the Lock button on the Layout

Type LA in the command line to open the
Layer Properties Manager.

Viewports panel.



In the Layer Properties Manager, create a
new layer called Hide Viewports and make
it current.
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Deactivate the plotter symbol

under the


Plot column of the Hide Viewports layer;

activate the model space.

the object on this layer will not be plotted.


Close the Layer Properties Manager.



Click the Home tab on the ribbon and



Type LA in the command line to open the
Layer Properties Manager.



expand the Layers panel.


Double-click inside the larger viewport to

In the Layer Properties Manager, click the

Click the Change to Current Layer button

icon in the VP Freeze

on the Layers panel.

Hidden layer; the hidden lines will

column of the

disappear in the viewport, as shown below.



Select the viewports in the ISO A1 layout
and press ENTER; the viewport frames will
become unplottable. To check this, click the
Preview button on the Plot panel; the plot
preview will be displayed as shown below.



Double-click outside the viewport to switch
to paper space.



Click the Model tab below the graphics
window; you will notice that the hidden
lines are retained in the model space.



Close the preview window.

Changing the Layer Properties in
Viewports
The layer properties in viewports are not related to
the layer properties in model space. You can change
the layer properties in viewports without any effect
in the model space.
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Creating the Title Block on the
Layout
You can draw objects on layouts to create a title
block, borders and viewports. However, it is not
recommended to draw the actual drawing on
layouts. You can also create dimensions on layouts.

Example1:


Click the ISO A1 layout tab.



Set the Title Block layer as current.



Click the Rectangle button on the Draw



a block.


Use the Insert tool and insert it at the lower
right corner of the layout.

panel.


Use the Create Block tool and convert it into



Pick a point at the lower right corner of the

Save the drawing file as ViewportsExample.dwg.

layout.








Select the Dimensions option from the

Working with Annotative

command line.

Dimensions

Specify the length of the rectangle as 820

In AutoCAD, you create drawings at their actual

and width as 550.

size. However, when you scale a drawing to fit

Click in the upper area of the layout; a

inside a viewport, the size of the dimensions will not

rectangular border will be created.

be scaled properly. For example, in the following

Create a title block at the lower right corner,

figure, the first viewport is scaled to 1:2 and the

as shown below.

second viewport is scaled to 1:1. The dimensions in
the first viewport appear much smaller.



Create attributes and place them inside the
You can fix this problem by applying the Annotative

title, as shown below.

property to dimensions.
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Primary Units tab: Units Format – Decimal,
Precision – 0, Decimal separator – ‘.’period


In the Fit tab, ensure that the Annotative
check box is selected.



Open the Viewports-Example.dwg, if not



Click OK on the New Dimension Style

already opened.

dialog; you will notice that the Dim_Anno



Set the Dimensions layer as current.

style is listed in the Dimension Style



Type D in the command line and press

Manager. Also, the annotation symbol is

ENTER.

displayed next to it. This indicates that all

In the Dimension Style Manager, click the

dimensions created using this style will

New button.

have annotative property. Click on the

In the Create New Dimension Style dialog,

Close button.





enter New style name as Dim_Anno and
select the Annotative check box. Click
Continue.



Activate the Dimension tool and set the
Annotation Scale to 1:1. Click OK.





Create a linear dimension as shown below.



Activate Automatically add scales to

Set the following settings in the New
Dimension Style dialog.
Lines tab: Offset from origin-1.25
Symbols and Arrows tab: Arrow size -2.5,
Center Marks-Line.
Text tab: Text height – 2.5, Text placement -

annotative objects when the annotation

Vertical-Centered, Text alignment -

scale changes on the status bar.

Horizontal
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Set the Annotation Scale to 1:2; the size of
the dimension will automatically increase by
two times.



Click the ISO A1 layout; you will notice that
the dimensions are not displayed in the 2:1
viewport. To display dimensions in the 2:1
viewport, you need to add 2:1 scale to

Example 2:


dimensions.

Ensure that the Annotation Scale is set to
1:2 and create another linear dimension as
shown in figure.



Click the ISO A4 layout in which the



viewport scale is set to 1:2; you will notice

Click the Model tab below the graphics
window to switch to the model space.

that the dimensions are scaled with respect



to the viewport.

Click Annotate > Annotation Scaling >
Add/Delete Scales on the ribbon.



Select the dimensions from the graphics
window and right-click; the Annotation
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Object Scale dialog appears. In this dialog,
the Object Scale list shows the scales
applied to the selected dimensions. You
need to add 2:1 scale to the dimensions so
that they will be visible in the 2:1 viewport.



Similarly, create other dimensions as shown
below. Add 2:1 and 1:2 scales to dimensions
and check the drawing in two different
layouts.



To add a new scale to the dimensions, click
the Add button; the Add Scales to Object
dialog appears.



Select the 2:1 scale from the list and click
OK; the scale will be added to Object Scale





list.

Scaling Hatches relative to Viewports

Click OK on the Annotation Object Scale

While working in layouts, you may also need to

dialog.

scale the hatch with respect to the viewport scale.

Click the ISO A1 layout; the dimensions are

The following figure shows a drawing in two

displayed in both 2:1 and 1:2 viewports.

different viewports 1:2 and 1:1. The hatch in the left
viewport is smaller than that in right side viewport.
You can correct this problem by using the Relative
to Paper Space option.
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Double-click inside a viewport; the model
space will be activated.



Select the hatch patterns from the drawing;
the Hatch Editor tab appears.



In the Hatch Editor tab, expand the
Properties panel and select the Relative to
Paper Space button.

Working with Annotative Text
Annotative property can also be assigned to text.
The annotative text will be scaled with respect to the
viewport scale.




Click the Close Hatch Editor button; you

Open the Viewports-Example.dwg, if not
already opened.

will notice that the hatch will be scaled with



respect to the viewport scale. Double-click

Click Annotate > Text > Text Style on the
ribbon; the Text Style dialog appears.

outside the viewport to switch to the paper
space.



Click the New button on the Text Style
dialog; the New Text Style dialog appears.



Enter Text_Anno as the Style name and
click OK.



Select the Text_Anno style from the Styles
list.



Set Font Name to Arial and select the
Annotative check box.
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Set Paper Text Height to 2.5 and Width

Move the text and place at the bottom left

Factor to 1.

corner of the drawing as shown below. You



Click Apply and Close.

can also add a frame to the text. Right-click



Select 1:1 from the Viewport Scale menus at

on it and select Properties. On the

the status bar.

Properties palette, under the Text section,

Click Annotate > Text > Multiline Text on

set Text Frame to Yes.



the ribbon.


Specify the first corner of the text editor by
picking an arbitrary point.



Select the Justify option from the command
line; the command line displays:



Select the MC option from the command
line.





Move the pointer toward right and specify

will notice that the text is not displayed.

the second corner of the text editor.


View the drawing in the ISO A4 layout; you

This is because the text is set to 1:1 scale.

Type All dimensions are in mm and click



the Close Text Editor button on the Close

On the status bar, click the Show annotation
objects

panel.

button.

The text is visible in the ISO A4 layout.


Save the drawing as Layout Example.dwg
and close.

Exercise 1
Create the drawing, as shown below. After create the drawing, perform the following tasks:


Create a layout of A3 size and then create a viewport.



Set the viewport scale to 1:2.



Set the scale of the dimensions and hatch lines with respect to the viewport.
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wizard. The following example explains the

Chapter 11:
Templates and
Plotting

procedure to connect a plotter to AutoCAD.

Example:


Start AutoCAD 2018.



Click Application Menu > Print > Manage
Plotters or type PLOTTERMANAGER in the

In this chapter, you will learn to do the following:

command line; the Plotters folder will be


Configure Plotters

opened, as shown below. All the configured



Create Plot Style Tables

plotters are displayed in this folder.



Use Plot styles



Create Templates



Plot/Print the drawing

Plotting Drawings
Plotting is the process of producing a physical copy
of the drawing using a printer or plotter. The printer
may be directly connected to an AutoCAD



workstation or on the network of workstations.

In the Plotters folder, double-click on the
Add-A-Plotter Wizard icon; the Add Plotter

Although the process of plotting is very simple, it is

– Introduction page appears.

important to know how to establish communication



between AutoCAD and the plotter. In this chapter,

Click the Next button; the Add Plotter –
Begin page appears. In this page, there are

you will learn to connect a plotter with AutoCAD,

three options that allow you to setup a

define plotting style, and produce professional

plotter: My Computer, Network Plotter

prints of drawings. You will also learn to print and

Server, and System Printer. These options

publish drawings in digital format.

are explained on the dialog itself, as shown
below.

Configuring Plotters
It is assumed that you have connected plotter to
your workstation and installed the drivers related to
it. Even after doing so, you need to set a connection
between the plotter and AutoCAD. You can
establish this connection by using the Add-plotter
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Select the System Printer option and click

If you click the Edit Plotter Configuration button,

Next; the System Printer page appears. A

the Plotter Configuration Editor dialog appears. In

list of printers installed on your workstation

this dialog, you can modify the default settings of

is displayed.

the plotter. The Calibrate Plotter button is used to
test the plotter.


Click the Finish button; a new plotter will
be added to the Plotters folder.

Creating Plot Style Tables
Plot styles determine the final look of the plotted
drawing. They are used to override the layer
properties such as color, linetype, lineweight and so






From the list, select the required printer and

on when the drawing is printed. After configuring a

click Next; the Import page appears.

plotter, you need to create a plot style. There are two

Click the Next button; the Plotter Name

types of the plot styles: Color-dependent and

page appears.

Named plot style. Color-dependent plot styles are

Type name of the plotter in the Plotter

assigned based on the object color, whereas the

Name box and click Next; the Finish page

Named plot styles are assigned based on layer or by

appears. You can edit the configuration of

object.

the plotter by using the Edit Plotter


Configuration button.

On the Application Menu, click Print >
Manage Plot styles or type
STYLESMANAGER in the command line;
the Plot Styles folder appears.

226

Part 1: AutoCAD Basics



Double-click on the Add-A-Plot Style Table
Wizard icon; the Add Plot Style Table
dialog appears. Read the information on this


dialog and click Next.


Editor dialog.

Select the Start from Scratch option and


click Next.


Click Finish to close the Add Plot Style
Table dialog; the Sample plot style will be

Select the Named Plot Style Table option

added to the Plot Style folder.

and click Next.


Click Save & Close on the Plot Style Table

Enter Sample in the File name box and click
Next; the Finish page appears.



Click the Plot Style Table Editor button; the
Plot Style Table Editor dialog appears.



Click the Add Style button available at the
bottom left of the dialog; a new style named
Style 1 is added.



Enter PS1 in the Name box.



Select Black from the Color drop-down.

Using Plot Styles



Set the Screening value to 70. The screening

In AutoCAD, the Color-Dependent Plot style is used

factor will fade objects in the printed output.

by default. In order to use the newly created plot

A 20% screening factor will result in more

style, you need to specify a setting in the Options

fading of objects than a 50% screening

dialog.

factor.


Right-click in the graphics window and
select Options; the Options dialog appears.



Select the Plot and Publish tab in the
Options dialog and click the Plot Style
Table Settings button; the Plots Style Table
settings dialog appears.
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Toolbar; the Select Template dialog
appears.


Select Open > Open with no Template –
Metric from the bottom right corner of the
dialog; a drawing file will be opened.



Select the Use named plot styles option
from the dialog.







Select Sample.stb from the Default plot

create the layers contained in the table

style table drop-down.

below:

Select PS1 from the Default plot style for
layer 0 drop-down.



Open the Layers Properties Manager and

Set the Default plot style for objects to
ByLayer.

Linetype

Lineweight

Construction

Continuous

Default

PS1

Object

Continuous

0.7 mm

PS1

Hidden

0.3 mm

PS1

Center Lines

CENTER

0.25 mm

PS1

Dimensions

Continuous

0.25 mm

PS1

Continuous

0.5 mm

PS1

Phantom

0.6mm

PS1

Title Block

Continuous

1mm

PS1

Viewport

Continuous

0.25 mm

PS1

Text

Continuous

Default

PS1

Continuous

Default

PS1

Hidden
Lines

Section
Lines
Cutting
Plane



Click OK twice to close both the dialogs.



Close the drawing file by clicking the Close
button located at the top-right corner.

Title block
text




Click NO on the AutoCAD alert message.



Click the New button on the Quick Access

Plot

Layer

Style

Click the Layout 1 tab to activate the paper
space.
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Creating Templates

on the ribbon; the Page Setup Manager
dialog appears.


After specifying the required settings in a drawing

Click Modify on the Page Setup Manager;

file, you can save those settings for the future use.

the Page Setup dialog appears.


You can do so by creating a template. Template files

Under the Printer/plotter group, select the

have settings such as units, limits, and layers already

plotter that you have configured to your

created, which will increase your productivity. In

workstation.

previous sections, you have configured various

Set the Paper Size to A3 and Drawing

settings, such as layers, colors, linetypes and

orientation to Landscape.

plotting settings. Now, you will create a template



Click OK and Close to exit both the dialogs.

file containing all of these settings and the title block



Draw a title block in the paper space, as

that you have created.



shown below.


On the Quick Access toolbar, click the Save
button; the Save Drawing As dialog
appears.



In the Save Drawing As dialog, set Files of
type to AutoCAD Drawing Template
(*.dwt).



Enter ISOA3 in the File name box and click
Save.



In the Template Options dialog, enter ISOA3 Horizontal layout with title block in the



Create a viewport inside the title block (refer

Description box.


to the Creating Viewports in the Paper

Click OK to close the dialog and save the
template file.

space section discussed earlier in this

Plotting/Printing the drawing

chapter).



Click the New button.



Select ISOA3. A new drawing will be
started with the selected template.



Open the Layer Properties Manager; you
will notice that the layers saved in the
template file are loaded automatically.
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also download the drawing from the
companion website.

Click the Preview button located at the
bottom left corner; the preview window
appears.



Click the Zoom Original button to fit the
drawing to the window.



Examine print preview for the desired
output and click the Plot button; the
drawing will be plotted.



Click the Layout 1 tab to activate the paper
space.



Double-click inside the viewport to activate
the model space.



Set the Viewport Scale to 1:1 on the status
bar.



Use the Pan tool and position the drawing
in the center of the view port.



Double-click outside the viewport to
activate the paper space.



Hide the viewport frame by freezing the
Viewport layer.



Save and close the drawing file.

Exporting to PDF


A PDF and DWF files are one of the commonly used

Click the Plot button on the Quick Access

file formats to exchange drawings between

Toolbar; the Plot dialog appears.

designers and clients. AutoCAD makes it easy to
export the drawing to the PDF or DWF formats.



Make sure that the options in this dialog are
same as that you specified while creating the
template.
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DWF/PDF > Export to PDF Options


Importing to PDF

On the ribbon, click Output > Export to

AutoCAD allows you to import a PDF into a

.

drawing file.

On the Export to PDF Options dialog, set
the Vector quality, Raster image quality, line



merge control, and Data options.

On the ribbon, click Insert > Import > PDF
Import



.

On the Select PDF File dialog, browse to the
location of the PDF file.



Select the PDF file and a preview appears in
the Preview area of the Select PDF File
dialog.



Click Open; the Import PDF dialog appears.



On the Import PDF dialog, specify the Scale
factor.

The options in the Data section help you to include



layer information, hyperlinks, and create

the TrueType text option.

bookmarks. Also, you can capture fonts used in the



drawing.

Click OK.



On the ribbon, click Output > Export



Under the Layers section, check the Use
PDF Layers option.



DWF/PDF > Export > PDF

Under the PDF data to import section, check

.

On the Save As PDF dialog, select a PDF
Preset to specify the PDF quality.



Examine the options in the Output Controls
section, Export, and Page Setup.



Specify the location of the PDF file and click



Click OK to insert the PDF into the drawing.

Save. A bubble appears on the status bar
after exporting the PDF file.


Combining Text of the Imported PDF

Open the PDF file in a PDF viewer and

After importing the PDF into an AutoCAD drawing,

notice the layers, bookmarks, hyperlinks in

the text of the PDF is converted into single line text

the drawing. Also, you can find any text in

objects. However, you can combine them into a

the drawing using the text search option in

multi-line text using the Combine Text command.

the PDF viewer.
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Combine Text


The Autodesk Sign In dialog appears, if have not

On the ribbon, click Insert > Import >

signed into your Autodesk account.

.


Select the fragments of the text to combine

Enter your Autodesk ID and password, and
then click Sign in.

them.

The DesignShare – Publish Options dialog appears.


Select the appropriate option from the
DesignShare – Publish Options dialog.



Click on the text and notice that the text is
converted into a multi-line text.

Publishing a 2D Drawing to a
Browser
AutoCAD 2018 allows you to publish a drawing to a

The drawing will be published and opened in the

web browser so that you can view it without any

A360 Viewer. You can sign into A360 using you

application installed on your device. To publish

Autodesk ID and share the link of the drawing.

drawing to a web browser, follow the steps given
next:


Click Application Menu > Publish >
Design Views.
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Exercise
Create and plot the drawing as shown in figure.
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Chapter 12: 3D Modeling Basics
In this chapter, you will learn to do the following:


Create boxes, cylinders, wedges, cones, pyramids, spheres, and torus



Create User Coordinate Systems



Work with Dynamic UCS



Change the View Style of objects



Create Viewports in model space



Create walls using the Polysolid tool



Change the view orientation



Create extruded, revolved, swept, lofted, and press-pulled objects



Perform Boolean operations



Align objects



Create spiral and helical curves

Introduction
In AutoCAD, you can create three types of 3D models: surfaces, solids, and meshes. Solids are used to create 3D
models of engineering components and assemblies, surfaces are used to create complex shapes such as plastic
parts, and meshes are used for games and movies. Solids are three-dimensional models of actual objects that
possess physical properties such as mass properties, center of gravity, surface area, moments of inertia, and so on.
Surfaces are construction features without any thickness. They do not possess any physical properties. Meshes are
similar to solids without mass and volume properties. In this chapter, you will learn the basics of 3D modeling
such as creating, navigating and visualizing solid models.

3D Modeling Workspaces in AutoCAD
In AutoCAD, there are separate workspaces created to work on 3D models. In these workspaces, the tools are
organized into ribbon tabs, menus, toolbars, and palettes to perform a specific task in 3D modeling. You can
activate these workspaces by using the Workspace drop-down located on the Quick Access Toolbar, or by using
the Workspace Switching menu on the status bar. You can also start an AutoCAD session directly in the 3D
Modeling workspace using the acad3D.dwt, acadiso3D.dwt, acad -Named Plot Styles3D, or acadISO-Named
Plot Styles3D templates.
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Tip: If the Workspace drop-down is not displayed at the top left corner, then click the down arrow next to Quick Access
Toolbar. Next, select Workspace from the drop-down; the Workspace drop-down will be visible on the Quick Access Toolbar.

There are two workspaces of 3D modeling: 3D Basics and 3D Modeling. The 3D Basics workspace has
commonly used tools, whereas the 3D Modeling workspace includes all the tools required for creating 3D
models.

The 3D Modeling Workspace
Activating the 3D Modeling workspace either by using the template or from the Workspace drop-down displays
the screen as shown below. It contains the ribbon and tools related to 3D modeling. By default, the Home tab is
activated in the ribbon. From this tab, you can access the tools for creating and editing solids and meshes,
modifying the model display, working with coordinate systems, sectioning 3D models and so on.
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There are some additional tabs such as Solid, Surface, Mesh, and Render. The Solid tab contains tools to create
solid models; the Surface and Mesh tabs are used to create surface models and complex shapes; the Visualize

tab is used for creating realistic images of solid and surface models.

The ViewCube can be used to modify the view of the model quickly and easily. It is located at the top right
corner of the graphics window. Using the ViewCube, you can switch between the standard and isometric views,
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rotate the model, switch to the Home view of the model, and create a new user coordinate system. You can also
change the way the ViewCube functions by using the ViewCube Settings dialog. Right-click on the ViewCube,
and then select the ViewCube Settings option; the ViewCube Settings dialog will be opened.

You can also modify the model view by using the In-canvas controls. In addition to that, you also change the view
style of the model and control the display of other tools in the graphics window using the In-canvas controls.
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Now, you will create 3D models using the tools available in AutoCAD.

The Box tool

and press ENTER; the box will be created as
shown.

The Box tool is used to create boxes having six


rectangular or square faces. It is most commonly

Bar.

used tool as many 3D objects are made of boxes.



On the In-canvas controls, click View Style
Controls > Shades of Grey.

Click the AutoCAD 2018 icon on your


desktop.


Click Zoom > Zoom All on the Navigation

Right click on the Home icon above the
ViewCube and select Parallel.

On the Quick Access Toolbar, click the New
icon.



On the Select Template dialog, click
acadiso3D, and then click Open. A new file
will be started in the 3D Modeling
workspace.



Click Home > Modeling > Box on the
ribbon or type BOX in the command line;
the message, “Specify the first corner”

Creating the User Coordinate System

appears in the command line.

User Coordinate Systems assist you while creating
3D models. They are used to create construction
planes on which you can add additional features to
the model. Various methods to create User
coordinate systems are discussed next.


Pick an arbitrary point in the graphics

Example1:

window; the message, “Specify the other



corner” appears in the command line.


button and select Dynamic UCS from the

Ensure that the Dynamic Input icon is

menu. Also, select 3D Object Snap from the

active on the status bar. You will notice the

menu.

two value boxes to specify the length and



width of the box.


later in this chapter.

TAB key.
Type 70 in the width box and press ENTER.



Move the pointer upward, type 60 as height

Deactivate the Dynamic UCS icon on the
status bar. You will learn about this option

Type 100 in the length box and press the



On the status bar, click the Customization
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Click Home > Coordinates > UCS on the
ribbon; the UCS is attached to the pointer
and the message, “Specify the origin of

Creating a Wedge

UCS” appears.

When you slice a box diagonally, it results in a
wedge. A wedge has five faces, three rectangular
and two triangular.




Click Home > Modeling > Primitives drop-

Activate the 3D Object Snap on the status

down > Wedge on the ribbon or type WE in

bar.

the command line and press ENTER; the
message, “Specify first corner or [Center]”
appears in the command line.




Select the endpoint of the top face of the box
as shown in figure; the message, “Specify

Select the vertex point on the top left corner

other corner or [Cube Length]:” appears in

of the box as shown below; the message,

the command line.

“Specify point X-axis or <accept>:”appears


in the command line.

On the Status bar, click the down arrow next
to the 3D Object Snap icon, and select
Midpoint on edge.



Select the midpoint of the front edge of the
box as shown below.



Press ENTER to accept the orientation of the
UCS as shown below.
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Move the pointer toward right and select the
other endpoint of the bottom edge of the

Move the pointer upward and enter 40 as

wedge, as shown in figure.

the height; the wedge will be created, as
shown below.



Move the pointer along the diagonal edge of
the wedge and select the endpoint on the

Example2: (Creating UCS by selecting 3-

top edge as shown below; the UCS will be

points)

created and aligned to the inclined face of
the wedge.

You can create a UCS by selecting three
points. The first point will be the origin of the UCS,
the second point will define the X axis, and the third
point defines the Y-axis.


Click Home > Coordinates > 3 Point on the
ribbon; the UCS is attached to the pointer
and the message, “Specify new origin point
<0,0,0>:” appears.



Select the lower endpoint of the wedge as

Creating a Cylinder

shown in figure.

Cylinders are commonly used features after boxes.
In AutoCAD, you can create cylinders easily by
using the Cylinder tool. You can create a circular or
elliptical cylinder by using this tool.
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down > Wireframe on the ribbon; the view
style of the model will be changed to
wireframe.

Example 3: (Returning to previous
position of the UCS)


Click Home > Coordinates > UCS, Previous
on the ribbon; the UCS will return to its
previous position.



On the Status bar, click the down arrow next
to the 3D Object Snap and select the Center
of face option, if not already selected.



Click Home > Modeling > Primitives dropdown > Cylinder on the ribbon or type CYL
in the command line.



Example 4: (Creating a UCS by specifying

Specify the center point of the cylinder on

its origin)

the inclined face of the wedge.



Click Home > Coordinates > Origin

on

the ribbon; the UCS will be attached to the
pointer.


Select the lower left corner point of the box;
the UCS will be placed at that point. Note
that the orientation will not change.



Type 20 as the base radius and press
ENTER.



Move the pointer upward; you will notice
that the pointer moves along the Z-axis of

Example 5: (Rotating the UCS about X, Y,

the UCS.


and Z axes)

Type 25 as height and press ENTER; the

You can rotate a UCS about X, Y, or Z axes by using

cylinder will be created as shown below.
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the drop-down available in the Coordinates panel,

on the ribbon.

as shown below.



Select the bottom right endpoint as the
origin; the message, “Specify point on
positive portion of Z-axis:” appears in the
command line. Also, a rubber band line
originating from the Z-axis is attached to the
pointer. Now, as you move the pointer, you
will notice that the Z-axis also moves.



Click the X option from the drop-down



Move the pointer and select the left

shown in the above figure; the message,

endpoint of the bottom edge as shown

“Specify rotation angle about X axis

below; the Z-axis will be aligned to the

<90>:”appears in the command line. Also, a

bottom edge.

rubber band line originating from the Y axis
is attached to the pointer.


Rotate the pointer and pick a point to
specify the rotation angle. You can also
type-in the rotation angle in the dynamic
input or command line.



Similarly, you can rotate the UCS about the
Y and Z axes using the respective options
from the drop-down.

Example 7: (Creating UCS parallel to the
Example 6: (Creating the UCS by

screen)

specifying the Z-axis)

Using the View tool in the Coordinates panel, you

Using the Z-Axis Vector tool, you can create a UCS

can create a UCS which is parallel to the screen.

by specifying its Z-axis.




Click Home > Coordinates > View

on

the ribbon; the XY plane of the UCS will

Click Home > Coordinates > Z-Axis Vector
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become parallel to the screen. The UCS

surface, or mesh:” appears in the command

origin will not change. This option is useful

line.


if you want to use the current view and add
a title block, or any other annotation.

Move the pointer over the faces of the
model; you will notice that the UCS is
displayed on the faces.

Example 8: (Creating UCS aligned to an
object)



Select the top face of the box; the message,

You can create a UCS aligned to an object. The origin

“Enter an option [Next/Xflip/Yflip]

of the UCS will be aligned to the nearest endpoint of

<accept>:” appears in the command line.

the object.

If you select the Next option, the adjacent



Click Home > Coordinates > View > Object

face will be highlighted. The Xflip option is
used to rotate the UCS 180 degrees about the

on the ribbon; the message, “Select

X axis. The Yflip option is used to rotate the

object to align UCS:” appears in the

UCS 180 degrees about the Y axis.

command line.




Select the cylindrical object from the model;

Press ENTER to accept; the UCS will be
aligned to the selected face.

the UCS will be aligned to it.

Using Dynamic User Coordinate
System
In the previous section, you have learned to create
various types of static user coordinate systems. They
are active until you define another user coordinate
system. You can also create dynamic user coordinate
systems. A Dynamic User Coordinate System is a

Example 9: (Creating UCS aligned to face)

temporary UCS that appears automatically when

You can align a UCS to a planar or curved face of a

you place your pointer over the face of a 3D solid

model using the Face tool.


Click Home > Coordinates >Face

object. Note that the Dynamic User Coordinate
appears only when you use tools which create

on

objects directly (For example, drawing tools and

the ribbon; the message, “Select face of solid,

primitive tools). In order to create a Dynamic UCS,
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Model Space Viewports for 3D

you need to activate the Dynamic UCS option on
the status bar.

Modeling
While creating 3D models, it is useful
to have a look at your model from
several different orientations at the









Click the Cylinder button on the Modeling

same time. For this purpose, you need to create

panel.

different viewports in model space. You can create

Ensure that the Dynamic UCS button is

multiple viewports in model space using the

active on the status bar.

Viewport Configuration drop-down available in the

Move the pointer over the faces of the

Model Viewports panel of the View tab. This can

model; they will be highlighted.

also be done by using the Viewports dialog. To load

Click on the front face of the box and create

this dialog, click Visualize > Model Viewports >

the cylinder as shown below.

Named; the Viewports dialog appears. In the dialog,
select the New Viewports tab and then select Four:
Equal from the Standard viewports list. Next, select
3D from the Setup drop-down. Click the OK button;
four tiled view-ports are displayed in the screen.
You can notice that each viewport has a different
view and a different UCS. Click inside any viewport
to activate it and perform any operation. To return
to single viewport, click the Restore Viewports
button on the Model Viewports panel; the currently
active viewport will fill the screen area.
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Example 2:

Creating Other Primitive Shapes



In AutoCAD, there are set of tools to create basic

Type CONE in the command line and press
ENTER.

geometric shapes. In earlier sections, you have


learned to create boxes, wedges, and cylinders.

Select the Elliptical option from the command
line; the message, “Specify endpoint of first axis

Now, you will learn to create other primitive shapes.

or [Center]:” appears in the command line.


Creating Cones

Pick a point to specify the end point of the first
axis.

Creating a cone is similar to creating a cylinder. It



has a similar shape compared to a cylinder; but it is

Move the pointer and click specify the other end
point of the first axis. You can also type-in the

tapered on one side.

length of the first axis and press ENTER; the
message, “Specify endpoint of second axis:”

Example 1:


appears.

To create a cone, click Home > Modeling >
Primitives drop-down > Cone



specify the second axis.

on the


ribbon; the message, “Specify center point of



Pick a point or type-in the radius value to

Move the pointer upward and pick a point to

base or [3P/2P/Ttr/Elliptical]:” appears in the

specify the height. You can also enter the value

command line.

of height in the command line or Dynamic

Pick an arbitrary point from the graphics

Input box.

window; the message, “Specify base radius or
[Diameter]:” appears.


Type a radius value in the command line and
press ENTER. You can also select the Diameter
option to specify the diameter of the base.



Move the pointer in vertical direction and pick a
point to specify the height of the cone. You can

Example 3:

also type-in the height value in the command



line and press ENTER; the cone will be created.

Click Solid > Primitive > Primitive drop-down
> Cone on the ribbon.
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radius as 20; the message, “Specify height or

down >Torus

[2Point/Axis endpoint/Top radius]” appears in

TOR in the command line and press

the command line.


ENTER.

Select the Top radius option from the command
line; the message, “Specify top radius:” appears.



Type 10 as the top radius value and press



Specify the center point of the torus.



Move the pointer outward and enter the
radius of the torus. You can also select the

ENTER.


on the ribbon or type

Diameter option to specify the diameter of

Move the pointer upward and enter 40 as the

the torus.

height.



Type the tube radius and press ENTER; the
torus will be created.

Creating a Sphere


Creating a Pyramid

Click Home > Modeling > Primitives dropdown > Sphere

Pyramids are similar to cones except that the base of

on the ribbon.



Specify the center point of the sphere.



Move the pointer outward and enter the radius

the pyramid is not circular in shape.


To create a pyramid, click Home > Modeling >

value. You can also select the Diameter option

Primitives drop-down > Pyramid

to specify the diameter of the sphere.

ribbon or type PYR in the command line and

on the

press ENTER.


Specify the center point of the base. The base of
pyramid is a polygon. The method to create a
polygon is already discussed in Chapter 2.



vertical direction and pick a point to specify the

Creating a Torus

height of the pyramid. You can also type the

Torus is a donut shaped solid primitive. To create a

value of the height and press ENTER; the

torus, you need to specify center of the torus, radius

pyramid will be created.

or diameter of torus, and radius or diameter of the
tube.


After creating the base, move the pointer in

Click Home > Modeling > Primitives drop-
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Move the pointer in the Y-direction and
enter 150 as the wall length.



Move the pointer in –X-direction and enter
100 as the wall length.



Select the Close option from the command
line; the wall will be closed.

The other options displayed in the command
line while creating the pyramid are same as in
the Cone tool.

Using the Polysolid tool
The Polysolid tool is used to create a 3D wall. It can
also be used to convert a line, polyline, arc, or a
circle to a wall. The Polysolid tool is similar to
Polyline tool except that you create a rectangular

Using the Extrude tool

shaped wall that has a pre-defined height and

The Extrude tool is used to add a third

width.

dimension (height) to an existing 2D shape.


Click Home > Modeling > Polysolid

If you extrude a closed shape such as circle and

on the ribbon; the message, “Specify start

closed polylines, a solid is created. If you extrude an

point or [Object/Height/Width/Justify]

open sketch such as lines and arcs, a surface is

<Object>:” appears in the command line.

created.



Activate the Ortho Mode on the status bar.



Pick an arbitrary point in the graphics

Example 1:

window and move the pointer in the X-



direction.




workspace.

Type 200 in the command line and press



Front on the ribbon; the front view will

Select the Arc option from the command

become parallel to the screen.

Type 100 as the arc diameter and press
ENTER.



Select the Line option from the command
line and move the pointer in the –Xdirection.



Click Home > View > 3D Navigation >

ENTER; a 3D wall of 200 length is created.

line and move the pointer in the Y-direction.


Start a new AutoCAD file in 3D Modeling

Type 100 and press ENTER.
248

Part 1: AutoCAD Basics




Click Home > Draw > Polyline on the

Click Home > View > 3D Navigation > Top

ribbon and create the sketch as shown

on the ribbon; the view will become parallel

below.

to the screen.



Click Home > Draw > Line on the ribbon and
create the sketch as shown below.



Select SE Isometric from the In-canvas
controls; the view orientation will be
changed South east Isometric.



Click Home > View > 3D Navigation >SE
Isometric on the ribbon; the view orientation
will be changed to south east Isometric.



Click Home > Modeling > Extrude.



Select the polyline sketch and press Enter.



Move the pointer toward right.



Type 100 in the command line or Dynamic



Expand the Draw panel of the Home tab and
click the Region button.

Input box and press ENTER; the polyline
sketch will be extruded.



Press and drag a window and select all the
objects of the sketch.



Press ENTER; the sketch will be converted
into a region. Now, you can extrude the
region to create a solid. If you try to extrude
the lines without creating a region, it will
result in a surface.

Example 2:


Open a new AutoCAD file in 3D Modeling
Workspace.

249

Part 1: AutoCAD Basics



Click Solid > Solid > Extrude on the ribbon.



Select the region created from the sketch,

Using the Revolve tool
The Revolve tool is used to revolve an open or
closed 2D sketch about a selected axis. If you revolve

and then press ENTER; the message,

a closed profile such as a polyline sketch, polygon,

“Specify height of extrusion or

circle, or a sketch region, a solid object is created. An

[Direction/Path/Taper angle/Expression]:”

open profile results in a surface. The sketch is

appears in the command line.


deleted after revolving it. If you want to retain the

Select the Taper angle option from the

sketch, you need set the DELOBJ system variable to

command line.

0.



Type 5 as the taper angle and press ENTER.



Move the pointer upward, type 40 in the



Open a new file in 3D Modeling workspace.

command line and press ENTER; the



Set the view orientation to front and create

extruded solid will be created with a taper.

the sketch using the Line tool.

Example 3:


Type EXT in the command line and press
ENTER.



Press and hold the CTRL key on and select


the top face of the model.


Press ENTER and move the pointer upward.



Type 25 as the extrusion height and press

Convert the sketch into region using the
Region tool.

ENTER; the extruded solid will be created.
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Click Solid > Solid > Revolve on the ribbon

Using the Sweep tool

or type REV in the command line.




Select the sketch region and press ENTER;

The Sweep tool is used to create a new solid

the message, “Specify axis start point or

or surface by sweeping a closed or open

define axis by [Object/X/Y/Z] <Object>:”

planar profile along an open or closed 2D or 3D

appears in the command line.

path. The procedure to create a solid by using the

Select the Object option from the command

Sweep tool is discussed next.

line and select the vertical line created at an
offset; the message, “Specify angle of

Example:

revolution or [STart



Open a new file in 3D Modeling workspace.

angle/Reverse/EXpression] <360>:”



Set the view orientation to Front and create

appears.

the sketch using the Polyline tool.



Use the Fillet tool and apply fillets of 25 mm
radius.



Press ENTER to specify 360 as the
revolution angle.
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Change the view orientation to SE Isometric.

The Alignment option aligns the profile



Click Home > Coordinates > Z-Axis Vector

perpendicular to the direction of the sweep path.

on the ribbon.

By default, the profile is aligned to the path.



Select the endpoint of the top vertical line as

The Base point specifies the base point of the profile.

the UCS origin and align the Z-axis to it.

By, default, the center of the profile is used as the
base point. You can select any other point on the
profile to define the base point.
The Scale option scales the profile along the path.

The Twist option twists the profile as it is swept
along the length of the path.


Click the Circle button on the Draw panel.



Select the end point of the vertical line to
specify the center point of the circle. Specify
5 mm as radius of the circle.



Click the UCS, World button on the
Coordinates panel; the User Coordinate


System will be set to World Coordinate

object.

System (0,0,0).


Select the path to create the swept solid

Click Home > Modeling > Solids dropdown > Sweep on the ribbon.

Using the Loft tool


Select the circle as the profile and press

Using the Loft tool, you can create a solid or surface

ENTER; the message, “Select sweep path or

by selecting a series of cross sections. The selected

[Alignment/Base point/Scale/Twist]:”

cross sections will define the shape of the lofted

appears in the command line.

solid.

Example 1:
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diameters and center point locations are

appears. In this dialog, the Smooth Fit

given in the table.

option creates a smooth connection between
the cross-sections. If you select the Ruled

Circle Center points

Circle Diameters

option, the lofted solid or surface has sharp

(Absolute

edges.

Coordinates)
0,0,0

∅50

0,0,70

∅100

0,0,140

∅50
The Normal to option creates a solid or surface
normal to the cross-section. You can select the loft
solid or surface to be normal to All cross sections, or
Start Cross Section or End Cross Section or Start
and End Cross Sections.



Click Home > Modeling > Solids dropdown > Loft on the ribbon or type LOFT in
the command line and press ENTER.

The Draft angles option defines the draft angle and
magnitude at start and end cross sections. The draft
angle is the beginning direction of the loft surface. If
you set the draft angle to 90 degrees, the loft surface




Select the cross-sections one by one; the

starts vertically from the cross section and the 0-

preview of the lofted solid appears.

draft angle starts loft surface horizontally. The

Press ENTER to accept the selection; the

Magnitude is the relative distance up to which the

message, “Enter an option

loft surface will follow the draft angle before it

[Guides/Path/Cross sections only/Settings]

bends.

<Cross sections only>:”appears in the
command line.


Select the Settings option from the
command line; the Loft Settings dialog
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Make the Sketch layer as current.


Set the view orientation to Right and draw
the sketch as shown below.

The Close surface or solid option connects the start
and end section of the lofted object.





Change the view orientation to SE Isometric.



Ensure that the Dynamic Input is activate



Set the Solid layer are current.



Click Home > Modeling > Presspull on the

Select the Normal to option and select All

ribbon.

cross sections. Click OK; the loft solid will



be created as shown below.

Click inside the bottom region of the sketch
and move the pointer backwards. Type 60 in
the Dynamic input box and press ENTER;
the extruded feature will be created.

Using the Presspull tool


The Presspull tool is used to create and

Click in the region enclosed by the larger
circle and extrude it up to 64 mm distance.

modify solid models with a greater ease and
speed. It can be used to accomplish two types of
operations: extruding closed 2D shapes and add or
remove material from a solid object based on
whether you “pull” or “push” the extrusion.


Start a new file.



Create two layers called Sketch and Solid.



Press and hold the CTRL key and select the
front face of the cylindrical object. Move the
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pointer forward. Type 4 in the dynamic



Click the Circle button on the Draw panel.

input box and press ENTER.



Press and hold the SHIFT key. Right-click
and select the Center option from the
shortcut menu.



Select the center point of the slot end cap
and create a circle of 4 mm radius.



Click in the curved slot region and move the
pointer backward; the message, “Specify
extrusion height or [Multiple]:” appears in
the command line.



Select the Multiple option from the



command line and click in the region

Click Home > Modify > Array drop-down >
Path Array on the ribbon.

enclosed by the two vertical lines.



Select the circle created in the previous step
and press ENTER.



Select the arc as the path curve; the preview
of the path array is displayed.



Right-click and move the pointer
backwards. Type 12 in the dynamic input
box and press ENTER.



In the Array Creation tab, set the Between
value to 25 in the Items panel; the item
count is automatically adjusted.



Click the Close Array button on the ribbon;
the polar array is created.



Press and hold the CTRL key and select the
front face of the slot and move the pointer
forward. Type 4 in the dynamic input box
and press ENTER.



Set the Sketch layer as current.
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Activate the Presspull command.



Click in any one of the circles and select the





The Union tool

Multiple option from the command line.

The Union tool joins two or more solids together

Click inside rest of the circles of the polar

into a single solid. For example, when you try to

array. Right-click to accept.

select the complete model, its individual objects are
selected. But, after performing the Union operation,

Move the pointer backward and click; holes

all the solid objects are combined together and act as

will be created as shown in figure.


one object.

Turn Off the Sketch layer; the sketches will
be hidden.





Click the Orbit button on the Navigation

> Boolean > Union on the ribbon.

Bar.


To perform the Union operation, click Solid

Press and drag the left mouse button to
rotate the model.



Click the left mouse button and create a
selection window across the model; all the
objects of the model will be selected.



Press ENTER; all the solid objects of the
model will be combined.

Performing Boolean Operations

Now, when you select an individual object,

Boolean operations are performed to add two or

the complete model will be selected.

more solids together, subtract a single solid or group
of solids from another, or form a common portion
when two solids are combined. You must have at
least two solids in order to perform a Boolean
operation. There are three tools available to perform
Boolean Operations- Union, Subtract, and Intersect.
These tools are discussed next.
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The Subtract tool

first destination point:” appears in the

The Subtract tool is used to subtract one or more

command line.


solid objects from another object.


Press and hold the SHIFT key. Right-click
and select the Quadrant option.

Create two concentric circles of 240 and 100


mm diameter.

Select the quadrant point of the outer circle
on the top face of the hollow cylinder.



Use the Presspull tool and extrude up to 250
mm distance.



Set the view orientation to Right and create
a cylinder of 100 mm diameter and 250 mm
length.



Change the view orientation to SE



Isometric.


Press ENTER; the horizontal cylinder will be
aligned with hollow cylinder.

Expand the Modify panel and click the
Align button.








Click Solid > Boolean > Subtract on the

Select the horizontal cylinder and press

ribbon; the message, “Select solids, surfaces,

ENTER; the message, “Specify first source

and regions to subtract from” appears above

point:” appears in the command line.

the command line.


Press and hold the SHIFT key. Right-click

Select the hollow cylinder and press ENTER;

and select the Center option.

the message, “Select solids, surfaces, and

Select the center point of the front face of the

regions to subtract” appears above the

horizontal cylinder; the message, “Specify

command line.
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Select the horizontal cylinder and press
ENTER; it will be subtracted from the
hollow cylinder as shown below.



The Intersect tool

Use the Presspull tool and extrude the view
up to 200 mm height as shown below.

The Intersect tool is used to create a composite solid
by finding common volume shared by the selected
objects.



Start a new file.



Set the view orientation to Front and create
the sketch as shown below.



Change the View style to Wireframe.



Deactivate the 3D Object Snap option on
the status bar.




Type DS in the command line and press

Use the Presspull tool and extrude the

ENTER; the Drafting Settings dialog

sketch up to 150 mm distance.

appears.


Click the Object Snap tab and Clear All the
Object Snap modes.



Now, select the Quadrant and Midpoint
options and click OK.



Set the view orientation to Top and create
the sketch as shown below.
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“Specify third source point or <continue>:”
appears.



Press ENTER to continue; the message,
“Scale objects based on alignment points?
[Yes/No] <N>:” appears.




aligned.

Type AL in the command line and press
ENTER.



Select the NO option; the two objects will be



Change the View style to Shade of Gray.



Click Solid > Boolean > Intersect on the

Select the second extrusion and press
ENTER; the message, “Specify first source
point:” appears.



Select the point on the source object as
shown below; the message, “Specify first
destination point:” appears.



Select the point on the destination object as
shown below; the message, “Specify second
source point:” appears.

ribbon.






Select another point on the source object, as

Select the two objects and press ENTER; the

shown below; the message, “Specify second

intersection object will created as shown

destination point:” appears.

below.

Select another point on the destination
object, as shown below; the message,

259

Part 1: AutoCAD Basics


Type 8 as number of turns and press
ENTER; the message, “Specify helix height
or [Axis endpoint/Turns/turn
Height/tWist] <1.0000>:” appears.



Type 0 as the height and press ENTER; the
spiral curve will be created as shown in
figure.

Using the Helix tool
The Helix tool is used to create a spiral or helix
object. You can use this helix object as a path for a
swept solid object.

Example 1:


Start a new file.



Expand the Draw panel in the Home tab

Example 2:


Start a new file.



Type HELIX in the command line and press

and click the Helix button.



Type 0,0 as the center point of the helix and
press ENTER; the message, “Specify base
radius or [Diameter]:” appears in the
command line.



ENTER.

Type 50 and press ENTER; the message,



Type 0, 0 as the center point of the helix.

“Specify top radius or [Diameter]



Type 50 as the base radius and press

<50.0000>:” appears.


ENTER.

Type 0 and press ENTER; the message,



Press ENTER to accept 50 as the top radius.

“Specify helix height or [Axis



Select the turn Height option from the

endpoint/Turns/turn Height/tWist]

command line.

<1.0000>:” appears.




Select the Turns option from the command

Type 20 as the turn height (pitch) and press
ENTER.

line.


260

Type 200 as the total height of the helix and

Part 1: AutoCAD Basics
press ENTER; the helix will be created as
shown in figure.

Exercises
Create 3D models using the drawing views and
dimensions.
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Example:

Chapter 13: Solid
Editing & generating
2D views



Start a new file in the 3D Modeling
workspace.



Select Front from the 3D Navigation dropdown of the View panel.



In this chapter, you will learn to do the following:

Create the sketch on the front view and
presspull it up to 100 mm distance.



Move objects



Create 3D Arrays



Mirror objects in 3D space



Fillet edges



Taper faces of the solid object



Offset faces



Rotate objects



Create 3D Polylines



Shell objects



Chamfer edges



Create Live sections



Generate 2D views of a 3D model



Create section and detailed views


Create a cylinder of 20 mm diameter and 20
mm height.

Introduction
In the previous chapter, you have learnt to create
simple solid objects. Now, you will learn to use solid
editing tools to create complex models. You will also
learn to generate orthographic views of 3D models.

Using the Move tool


The Move tool that you used in 2D drawings can
also be used in 3D modeling. You can change the

Type M in the command line and press
ENTER; the Move tool is activated.

position of an object using the Move tool. The



Select the cylinder and press ENTER.

application of this tool in 3D modeling is discussed



Select the center point of the cylinder to

next.

define the base point.
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be moved as shown below.



Select the end point of the base object; the

Using the Array tool

cylinder will be aligned to it.

The Array tool is used to create Rectangular, path
and polar arrays. You can create a rectangular array
by specifying the item count and distance along the
X, Y and Z directions.

Using the 3D Move tool

Example 1 (Rectangular Array)


The 3D Move tool is similar to the Move tool. You

Type ARRAY in the command line and
press ENTER.

can use this tool to move objects in 3D space. By


default, the 3D Move tool is activated and the Move

Select the cylinder from the model and press

gizmo is displayed when you select an object. You

ENTER; the message, “Enter array type

can use the Move gizmo to move the object along a

[Rectangular/PAth/POlar] <Path>:”

particular axis.

appears in the command line.





Select the cylinder to display the Move

command line.

gizmo tool.




Select the Rectangular option from the



Select the X-axis (Red arrow) of the gizmo

On the Array Creation tab, type 2 in the

and move the pointer backwards.

Columns, Rows, and Levels boxes,

Type 20 and press ENTER; the cylinder will

respectively.


be moved through 20 mm distance along the

Type -40, 60, 80 in the Between boxes of the
Columns, Rows, and Levels panels,

X-axis.

respectively.


Click Close Array on the Array Creation
tab.



Select the Y-axis (Green arrow) of the gizmo
and move the pointer toward right.



Type 20 and press ENTER; the cylinder will
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Example 2:

Type SU in the command line and press
ENTER; the Subtract tool will be activated.



Start AutoCAD in 3D Modeling workspace.

Select the base object and press ENTER; the



Select Front from the 3D Navigation drop-

message, “Select solids, surfaces, and

down in the View panel. Create the solid

regions to subtract” appears.

object as shown below. The extrusion

All the cylinders and press ENTER; holes

distance is 40 mm.

will be created on the model.



Select Front from the 3D Navigation dropdown in the View panel. Draw the sketch as
shown below and extrude it up to 12 mm
using the Presspull tool.

Using the 3D Align tool
The 3D Align tool aligns one solid with another. It
translates and rotates the object to align with the
destination object. You need to select three points on


the source object and destination object to align

Deactivate the 3D Object Snap button on
the status bar.

them together. An example of 3D Align tool is given


next.

Type DS in the command line and press
ENTER; the Drafting Settings dialog
appears.
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Click the Object Snap tab and Clear All the
Object Snap modes.



Now, select the Endpoint option and click
OK.



Select three end points on the destination
object as shown below; a copy of the source
object will be aligned to the destination



object.

Click Home > Modify > 3D Align on the
ribbon.



Select the second solid object from the
graphics window and press ENTER; the
message, “Specify base point or [Copy]:”
appears in the command line.



Activate the Ortho Mode button on the
status bar.





Select the Copy option from the command

press ENTER.

line.


Type 3DALIGN in the command line and



Select three end points on the source object

Select the second solid object. Press ENTER
to accept the selection.

as shown below.
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Select the base point on the object as shown
in figure; the message, “Specify second
point or [Continue] <C>:” appears in the
command line.

Using the 3D Mirror tool
The 3D Mirror tool is similar to the Mirror tool.




Select the Continue option from the

Using the Mirror tool, you can create mirrored

command line; the message, “Specify first

replica of an object in a 2D drawing. The objects are

destination point:” appears in the command

mirrored about an axis lying on a plane. But, with

line.

the 3D Mirror tool, you need to define a plane about

Select the endpoint on the destination object

which the object will be mirrored. The 3D Mirror

as shown below.

tool provides many options to define the mirror
plane.


Click Home > Modify > 3D Mirror on the
ribbon.



Move the pointer along the X-direction and
select the endpoint as shown in figure; the



message, “Specify third destination point or

Select the object to be mirrored from the
model and press ENTER; the message,

[eXit] <X>:” appears in the command line.

“Specify first point of mirror plane (3
points)” appears above the command line.



Select the eXit option from the command

The 3points option is selected by default to

line; the source object will be aligned as

create the mirror plane. You need to specify

shown below.
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three points to create the mirror plane. The
mirror plane will pass through the selected
points.


Select the first and second point of the
mirror plane as shown below.



Click the down arrow next to the Object
Snap icon on the status bar and select
Center.




press ENTER.

Click the Orbit button on the Navigation



Bar and rotate the model as shown below.



Select the object to be mirror from the model
and press ENTER.

Right-click and select Exit from the shortcut


menu.


Type 3DMIRROR in the command line and

Select the XY option from the command line;

Select the third point to define the mirror

the message, “Specify point on XY plane

plane; the message, “Delete source objects?

<0,0,0>:” appears in the command line.

[Yes/No] <N>:” appears in the command

The XY option creates plane parallel to the

line.

XY plane. You need to specify a point at
which the plane parallel to the XY plane will
be created.


Select the center point of the horizontal hole
to define the mirror plane; the message,
“Delete source objects? [Yes/No] <N>:”
appears in the command line.



Select the No option from the command
line; the object will be mirrored.
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Boolean operation is performed to subtract or add it
to the solid object.



Click Solid > Solid Editing > Fillet Edge on the
ribbon (or) type FILLETEDGE in the command
line and press ENTER; the message, “Select an
edge or [Chain/Loop/Radius]:”



Select the No option; the object will be
mirrored, as shown below.



Select the Chain option from the command line;
the message, “Select an edge chain or
[Edge/Radius]:” appears.



Select the edges from the model, as shown
below; you will notice that a chain of edges is



Click the Union button on the Solid Editing

selected.

panel and select all the object of the model.


Press ENTER; the objects will be combined
into a single object.



Change the view to SE Isometric.



Select the Radius option from the command
line; the message, “Enter fillet radius or
[Expression] <1.0000>:” appears.

Using the Fillet Edge tool



Type 2 in the command line and press ENTER.



Press ENTER; the message, “Press Enter to
accept the fillet or [Radius]:”appears. Also, a

The Fillet Edge tool is used to create rounds (convex

grip displayed on the fillets. You can use this

corners) or fillets (concave corners) on solid objects,

grip to dynamically change the fillet radius.

just as in 2D drawings. When you create a fillet or
round, a cylinder is created automatically and the
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Press ENTER to create rounds as shown in
figure.


Likewise, select the round edge as shown in
figure and select the Next option from the
command line; the edges on the bottom face of
the model will be highlighted.



Click the Orbit button on the Navigation Bar
and rotate the model.




fillets on the bottom face.

Click the Fillet Edge button on the Solid



Editing panel.




Press ENTER twice to create rounds as shown in
figure.

figure; the edges on the front face of the model
are highlighted. Also the message, “Enter an
option [Accept/Next] <Accept>:” appears in the
command line.

Select the Next option from the command line;
the edges on the side face will be highlighted.



Select the Radius option and type 2. Press
ENTER to accept.

Select the Loop option from the command line
and select the edge from the model, as shown in



Select the Accept option to view rounds and

Select the Accept button; rounds and fillets are
displayed on the side face.
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Similarly, create fillets on remaining edges by
using the Chain option.



Select the outer cylindrical face of the polysolid
and press ENTER to accept; the message,
“Specify the base point:” appears in the
command line.



Press and hold the SHIFT key and right-click to
display the shortcut menu. Select the Center



option from the shortcut menu.

Save and close the file.


Using the Taper Faces tool

front face; the center point of the circular edge
will be highlighted.

The Taper Faces tool is used to taper faces. You can
use this tool to change the angle of planar or curved
faces.



Select the center point of the circular edge.



Move the pointer along the Z-direction and click
to specify the axis of the taper; the message,

Example 3:

“Specify the taper angle:” appears in the

In this example, you will create a polysolid and

command line.

taper the outer face.


Start a new AutoCAD file.



Select Front from the 3D Navigation drop-down

Move the pointer over the circular edge on the

on the Views panel.


Create a hollow cylinder with inner and outer
diameter as 140 and 150, respectively. The


cylinder height is 50.

Type 10 as the taper angle and press ENTER; the
outer cylindrical face of the polysolid will be
tapered as shown in figure.



Click Solid > Solid Editing > Taper Faces on
the ribbon.
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Using the Offset Faces tool
The Offset Faces tool is used to make parallel copy
of faces of a 3D object.



On the ribbon, click Solid > Selection >



Press Esc.

Selection Filter drop-down > Face.



On the ribbon, click Solid > Selection >
Selection Filter drop-down > No Filter.



Create a cylinder of 40 mm diameter and 30 mm
length at the center of the polysolid.



Click Solid > Solid Editing > Faces drop-down
> Offset Faces on the ribbon.


Create a truncated cone with the following
dimensions.
Base radius: 8 mm
Top radius: 5 mm
Height: 65mm



Select the front face of the model and press
ENTER; the message, “Specify the offset
distance:” appears in the command line.

Note: By mistake, if you have selected the side faces,

Using the 3D Rotate tool

then click the Remove option in the command line.

The 3D Rotate tool is used to rotate objects

Next, click on the side faces, and then press ENTER

about an axis. You can define the axis of

to remove them from the selection.


rotation by using the Rotate Gizmo tool. The Rotate

Type -20 in the command line and press ENTER;

Gizmo tool will be displayed when you activate the

the face will be offset.

3D Rotate tool and select an object.


Click Home > Modify > 3D Rotate on the
ribbon.
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Select the truncated cone and press ENTER; the
Rotate Gizmo tool will be displayed.



Select the center point of the front face as the
base point; the Rotate Gizmo tool will be moved
to the selected point.



Select the cone; the Move Gizmo tool will be
displayed on it.




Select the Z axis (Blue ring) of the Rotate

Gizmo tool and move the pointer toward right.

Gizmo; an axis line is displayed along the Z-



axis.


Select the Y-axis (Green arrow) of the Move

Type 22 in the command line and press ENTER;
the cone will be moved through 22 mm.

Type 270 as the rotation angle and press ENTER;
the cone will be rotated by 270 degrees.

Using the 3D Polyline tool


The 3D Polyline tool is similar to the

On the status bar, click the down arrow next to

Polyline tool, except that you can create a

the Object Snap icon, and then select the

polyline by specifying coordinate points in three

Quadrant option, if not already selected.


dimensions. Also, you can only create straight lines

Click the Move button on the Modify panel and

using this tool.

select the cone. Press ENTER to accept.


Select the base point and the destination point as



shown below; the cone will be placed at the

Change the Visual Style of the model to
Wireframe.

destination point.



Click Home > Draw > 3D Polyline on the
ribbon.
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Select the Polar option from the command line;
the message, “Enter the number of items in the
array:” appears.






Type 6 in the command line and press ENTER;

Select the center point on the front face on the

the message, “Specify the angle to fill (+=ccw, -

cylindrical object.

=cw) <360>:” appears in the command line.

Move the pointer toward right and select the

Type + and press ENTER to create the polar

center point on the back face of the cylindrical

array in counter clockwise direction and

object.

type – to create it in the clockwise direction.


Press ENTER to accept 360 as the fill angle; the
message, “Rotate arrayed objects? [Yes/No]
<Y>:” appears in the command line.



Select the Yes option from the command line;
the message, “Specify center point of array:”
appears.




Press ENTER; the 3D polyline will be created.

Select the first and second points of the axis as
shown in figure; the polar will be created.

Creating a 3D Polar Array
You can create a 3D polar array by using the Polar
option of the 3DARRAY command. This option is
similar to the 2D Polar Array tool. The only
difference between these two tools is that you need
to specify an axis of rotation in 3D polar array,
whereas in 2D Polar array you need to specify an



Change the Visual Style to the Shades of Grey.

axis point. The axis of rotation in 3D polar array can



Perform the Union operation to combine all the
objects.

be specified by selecting two points. This allows you
to create a 3D polar array about any axis in the 3D
workspace.



Type 3A in the command line and press ENTER.



Select the truncated cone from the model and
press ENTER.
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Using the Shell tool
The Shell tool converts a solid object into a
thin walled hollow object. You need to first
select the object to be shelled, and then select the
faces to be removed and enter the thickness of the
walls.


Click Solid > Solid Editing > Shell on the

Using the Chamfer Edge tool

ribbon.


The Chamfer Edge tool is used to bevel

Select the solid model; the message, “Remove

sharp edges of a solid object. When you

faces or [Undo/Add/ALL]:” appears.


Select the front face of the cylindrical object.



Press and hold the SHIFT key, and then press

chamfer an edge, a wedge is created automatically
and the Boolean operation is performed to subtract it
from the solid object.

the middle mouse button on drag; the model
will be rotated.




Select the back face of the cylindrical object.

Click Solid > Solid Editing > Chamfer Edge
on the ribbon.



Select the outer circular edge of the
cylindrical object.



Select the Distance option from the
command line; the message, “Specify
Distance1 or [Expression] <1.0000>:”
appears.



Type 4 in the command line and press
ENTER; you will notice that preview of the



chamfer changes. Also, the message,

Press ENTER; the message, “Enter the shell

“Specify Distance2 or [Expression]

offset distance:” appears.


<1.0000>:” appears in the command line.

Type 10 in the command line and press ENTER;



the cylindrical object will be shelled.


Type 2 in the command line and press
ENTER.

Select the eXit option from the command line.
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Using the Live Section tool

Press ENTER twice to the chamfer, as shown
in figure.

The Live Section tool is used to make one side of the
section plane invisible or visible. When you create a
section plane by selecting plane, one side of the
section plane will be invisible automatically.
However, when you create a section plane by
selecting points, you need to use the Live Section
tool to make the one side invisible. Click Solid >
Section > Live Section on the ribbon. Next, select
the section plane; one side of the section plane will

Using the Section Plane tool

be hidden or unhidden as shown in figure.

The Section Plane tool is creates a translucent
cutting plane passing through a solid object to show
the inside portion of it. This tool is very useful when
the inside portion of the solid is not visible. You can
move this cutting plane dynamically to view the
inside portion at different locations of the solid.



To create a section plane, click Solid >


Section > Section Plane on the ribbon; the
message, “Select face or any point to locate

Creating Drawing Views

section line or [Draw

In Chapter 5, you have learned to create multi view

section/Orthographic]:” appears.


drawings using the standard projection techniques.

Select the Orthographic option from the

Now, you will learn to automatically generate views

command line.


Save the file as Example 3.

of a 3D model.

Select Right.

Setting the Drafting Standard
Before you start generating the drawing views of 3D
model, you need to specify the drafting standard.
This defines the way the views will be generated. To
specify the drafting standard, click Home > View >
Drafting Standard (inclined arrow) on the ribbon;
the Drafting Standard dialog appears.
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In the Drafting Standard dialog, set the
Projection type to Third angle.



Select the Entire model option from the
command line; the model in the model space
will be selected and the message, “Enter
new or existing layout name to make
current or [?] <Layout1>:” appears in the
command line.



Press ENTER to select Layout 1; the base
view will be attached to the pointer and the
message, “Specify location of base view or
[Type/sElect/Orientation/Hidden
lines/Scale/Visibility] <Type>:” appears in
the command line. Also, the Drawing View



Creation tab appears in the ribbon.

Examine the other options in the dialog, as



they are self-explanatory.


Specify the location of the view in the paper
space, as shown below.

Click the OK button.

Creating a Base View
Base view will be the first view of the drawing. It
can be any view (front, top, right, left, bottom, back)
of the model. But commonly, the front or top views
of the model are generated first.


Open the Example 3.dwg, if it is not already



opened.


In the Drawing View Creation tab, set the
Orientation to Front.

To generate the base view of the model,



click Home > View > Base > From Model

Select the Visible Lines option from the
Hidden Lines drop-down.

Space on the ribbon; the message, “Select
objects or [Entire model] <Entire model>:”
appears in the command line.
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Set the Scale in the Appearance panel to 1:4.



Click the OK button on the Create panel to

Move the pointer diagonally toward topright corner and place the isometric view as
shown below.

create the base view; a projected view will
be attached to the pointer and you will be
asked to specify its location. You will learn
to create projected views in the next section.


Press ENTER to exit the command.

Creating a Projected View
A projected view can be created from an existing
view. It can be an orthographic view or isometric


view generated by projecting from a base view or

line to exit the command.

any other existing view.




Select the eXit option from the command

To create a projected view, click Layout >

Creating Section Views

Create View > Projected on the ribbon, and

In Chapter 8, you have learned to create section

then select the base view from the Layout 1;

views manually. Now, you will learn to generate

the projected view will be attached to the

section views automatically from a 3D model. You

pointer.

can create different types of section views using the

Move the pointer downward and specify the

tools available in the Section drop-down in the

location of the projected view, as shown

Create Views panel.

below.

Creating the Section View Style
Section View Style defines the display of the section
view and the cutting plane. To create a section view
style, click Layout > Styles and Standards > Section
View Style
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Manager dialog appears. Click the New button in
the Section View Style Manager dialog; the Create
New Section View Style dialog appears. Type
Example in the New Style Name box and click
Continue; the New Section View Style dialog
appears. In this dialog, click the Cutting Plane tab
and select the Show cutting plane lines option.

Move the pointer toward right and click to specify
the location of the section view. Select the eXit
option to create the section view.

Click the Hatch tab and set the Hatch Scale to 0.5
and click OK. Click the Set current button on the
Section View Style Manager dialog and click Close.

Creating a Full Section View
To create a full section view, click Layout > Create
Views > Section > Full on the ribbon. Next, select
the base view from the layout. After selecting the
base view, you need to specify the start and end
points of the cutting plane. Select the start point of

Creating a Detailed View

the cutting plane by as shown below. Move the

A detailed view is created to enlarge and view small

pointer vertically upward and specify the end point

portions of a drawing.

of the cutting plane.



To create a detailed view, click Layout > Create
Views > Detail > Circular on the ribbon; the
message, “Select parent view” appears in the
command line.
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Select the section view from the layout; the


message, “Specify center point or [Hidden

corner of the layout.

lines/Scale/Visibility/Boundary/model


Edge/Annotation] <Boundary>:” appears in the


Next, place the detail view on the lower right

Select the Smooth with border button on the

command line.

Model Edge panel of the Detail View Creation

Select a point on the section view, as shown

tab.

below; the message, “Specify size of boundary
or [Rectangular/Undo]:” appears in the
command line.


Draw a circle similar to the one shown below.


Exercises
Create 3D models using the drawing views and dimensions.
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Chapter 14: Creating
Architectural
Drawings

Type UN in the command line and press
Enter.



On the Drawing Units dialog, select Type >
Architectural.

In this chapter, you will learn to do the following:



Select Precision > 0-01/16.



Set the Insertion Scale to Inches, and click
OK.



Type LIMITS in the command line and press



Defining Settings for Architectural Drawings



Creating Inner Walls



Creating Openings and Doors



Press Enter to accept 0, 0 as the lower limit.



Creating Kitchen Fixtures



Type 100’, 80’ in the command line and



Creating Bathroom Fixtures

press Enter. The program sets the upper



Adding Furniture using Blocks

limit of the drawing.



Adding Windows



Arranging Objects of the drawing in Layers



Creating Grid Lines



Adding Dimensions

Enter.



Turn OFF the grid.



Double-click the middle mouse button to

Introduction

zoom extents.

In this chapter, you will learn to create architectural



drawing shown below.

On the Status bar, turn ON the Ortho Mode
icon.

Creating Outer Walls


Start AutoCAD 2018 and click Get Started >
Templates > acad.dwt.





Set the Workspace to Drafting &

On the ribbon, click Home > Draw > Line,
and then select an arbitrary point. This

Annotation.

defines the start point of the line.


Move the pointer horizontally and type-in
412 in the Dynamic Input box. Press Enter.



Move the pointer vertically and type-in 338
in the Dynamic Input box. Press Enter.



Move the pointer onto the starting point of
the drawing, and then move it upwards.
You will notice that a dotted line appears.
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On the Navigation Bar, click Zoom > Zoom
Window.

Click to create a horizontal line. You will
notice that the horizontal line is of same
length.



Click the right mouse button and select
Close.



Create a window on the top left corner of
the drawing. The corner portion will be
zoomed in.



On the ribbon, click Home > Modify >


Offset.


Type-in 6 as offset distance and press Enter.



Select the left vertical line of the drawing.



Move the pointer inside the drawing and

Fillet.


Select the Radius option on the command
line, and then type-in 0. Press Enter.



click to create an offset line.


On the ribbon, click Home > Modify >

Likewise, offset the other lines, as shown
below.
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Press Enter to activate the Fillet command,
again.



Select the inner offset line at the top right
corner.



Likewise, fillet the other corners.



Select the new offset line. You will notice
that three grips are displayed on the line.



Click the right mouse button and select
Copy Selection.



Save the drawing. Make sure that you save
the drawing after each section.

Creating Inner Walls


Activate the Offset command and type-in
130 in the command line, and then press
Enter.



Select the inner line of the right side wall



and click inside the drawing.


Select the endpoint of the selected line as
base point.

Press Esc.



Move the pointer toward left and type-in 4,
and then press Enter. A new line is created
and another line is attached to the pointer.
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118, and then press Enter.

On the ribbon, click Home > Modify >
Trim.



Press Enter to select all the elements of the
drawing as cutting elements.



Click on the lines at the locations shown
below.



Move the pointer toward left and type-in
122, and then press Enter.



Press Esc to come out of the Copy
command.





Likewise, create horizontal offset lines, as
shown below.
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Zoom to the top portion of the drawing by
rotating the mouse scroll in the forward
direction.



Select the portion of the horizontal line that



Trim the unwanted portions at the corners.



Press Esc to deactivate the Trim command.



Select the unwanted portion and press

lies between the lines of the inner wall. The
selected portions will be trimmed.



Press and hold the mouse scroll wheel and
drag downwards until the lower portion of
the drawing is visible.



Trim the unwanted portion, as shown
below.



Trim the unwanted portions, as shown
below.

Delete.
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Deactivate the Line command and select the
new line.



Select the middle point of the new line and
move pointer toward right.



Type-in 6 and press Enter.



Activate the Offset command, and specify
32 as the offset distance.



Select the new line and move rightwards,
and then click.

Creating Openings and Doors


Activate the Line command select the corner
of the inner wall, as shown below.



Move the pointer downward and select the
other corner point.



Activate the Trim command and trim the
unwanted portions.
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Select Dimensions from the command line.



Type-in 1 and press Enter. This defines the

Likewise, create other openings, as shown

length of the rectangle.

below (use the method described in the



earlier step).

Type-in 32 and press Enter. This defines the
width of the rectangle.



Move the pointer down and click to create
the door. Now, you need to create the door
swing.





On the ribbon, click Home > Draw >

drop-down > Start Center End.

Rectangle.


On the ribbon, click Home > Draw > Arc

Select the endpoint of the opening, as shown
below.



Select the start, center, and end of the arc in
the sequence shown below.
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Press Esc to deactivate the Copy command.



On the ribbon, click Home > Modify >
Mirror, and then select the door and swing
of the bathroom. Press Enter to accept the
selection.



Select the door and door swing.



Click the right mouse button and select
Copy Selection.



Select the corner point of the rectangle as
base point.


Define the mirror line by selecting the
points, as shown below.



Select Yes from the command line. This
deletes the original object.




On the ribbon, click Home > Modify >

Select the corner points of openings, as

Scale, and then select the door & swing at

shown below.

the main entrance. Press Enter.
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door & swing at the entrance. Press Enter to
accept the selection.


Define the mirror line by selecting the
points, as shown below.



Select the Reference option from the


command line.


keeps the original object.

Select the two endpoints, as shown below.


This defines the reference length of the

Copy the door & swing of the bathroom and
place at the opening, as shown below.

objects. Now, you need to define the length
up to which you want to scale the objects.


Select No from the command line. This



Press Esc.



On the ribbon, click Home > Modify >

Type-in 36 and press Enter. The objects will
be scaled.

Rotate, and then select the copied object.


Rotate the objects by selecting the base point
and typing 90 as the rotation angle.



Activate the Mirror command and select the
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base point. Move the pointer upward and
type-in 1 in the command line, and then
press Enter.




On the ribbon, click Home > Modify >

Create an opening on the rear side of the

Explode, and select the rectangle. Press

plan, as shown below.

Enter to explode the rectangle.


Activate the Offset command and specify 2
as the offset distance.



Offset the left and right vertical lines of the
rectangle.

Now, you will create sliding door in the
opening.




Activate the Rectangle command and select

Click the down arrow next to the Object
Snap icon on the status bar, and then select

the corner point of the opening, as shown

Midpoint from the flyout.

below.



Activate the Line command and select the
midpoints of the offset lines. This creates a
line connecting the offset lines. This creates
one part of the sliding door.



Select the Dimensions option from the
command line.



Specify 37 and 2 as length and width of the
rectangle, respectively.



Move the pointer upward and click to create



Press Esc to deactivate the line command.

the rectangle.



Type-in CO in the command line and press
Enter.



Drag a selection window covering all the
elements of the sliding door. Press Enter.



Type M in the command line and press
Enter. Select the rectangle, and then press
Enter.



Select its lower left corner point to define the
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Select the lower left corner of the sliding
door as base point.



Move the pointer and select the endpoint of
the offset line, as shown.



Press Esc to deactivate the Copy command.


Now, you need to draw thresholds on the door

Enter.

openings.


Type-in L in the command line and press



Zoom to the front door area using the Zoom

Press and hold Shift key and click the right
mouse button.

Window tool.



Select From from the shortcut menu and
click the endpoint of the door opening, as
shown below.



Move the point on the horizontal line and
type-in 3, and then press Enter. This defines
the start point of the line at 3 distance from
the endpoint.



On the status bar, click the down arrow next
to the Object Snap button and make sure
that Endpoint, Nearest and Perpendicular
options are selected.



Move the pointer up and type-in 2, and then
press Enter.
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Move the pointer toward right and type-in
78, and then press Enter.



Move the pointer downward and type-in 2,
and then press Enter.



Activate the Offset command, and specify
26 as the offset distance.



Press Esc to deactivate the Line command.



Likewise, create a threshold on the sliding



Offset the lines shown below.



Trim the unwanted portions.



Create another offset line at 54 distance, and

glass door.

Creating Kitchen Fixtures


Zoom to the kitchen area by using the Zoom
Window tool.

then trim the unwanted elements.
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Create another line, as shown below.

Use the Move command to move the
rectangle 2 rightwards and downwards.



Create the outline of the stove using the
Line command (refer to the Using Object

Now, you have finished drawing the

Snaps section of Chapter 3).

counters. You need to draw refrigerator,
stove, and sink.


Type-in REC in the command line and press
Enter. This activates the Rectangle
command.



Select the corner point of the counter.



Select the Dimensions option from the
command line.



Now, you need to create the sink.

Specify 28 as length and width of the



rectangle. Move the pointer toward right

Use the Offset command and create offset
lines, as shown below.

and click to create the rectangle.
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Activate the Circle command and hover the
pointer on the midpoints of the sink edges



and move, as shown below.

Trim the unwanted elements, as shown
below.



Create the circles at the intersection points
of the trace lines.



Fillet the corners, as shown below.
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On the ribbon, click Home > Draw > Ellipse
drop-down > Center.

Creating Bathroom Fixtures


Zoom into the bathroom area and create
offset lines, as shown below.


Hover the pointer on the midpoints of the
vertical and horizontal lines, as shown
below.



Move the pointer and click at the
intersection point of the trace lines.



Trim the unwanted elements, as shown
below.



Move the pointer toward right and type-in
10, and then press Enter. This defines the
major radius of the ellipse.




Move the pointer downward and type-in 5,
and then press Enter. This defines the minor

Fillet the corners, as shown below. The fillet

radius of the ellipse.

radius is 4.
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Likewise, create another ellipse of 11 major
radius and 7 minor radius.



Activate the Rectangle command and create
a 22 x 9 rectangle, as shown below.



Move the rectangle up to 19.5 rightwards
and 1 downwards.



On the ribbon, click Home > Draw > Ellipse
drop-down > Axis, End.



Select the outer ellipse, and then click on the
center point of the ellipse.



Move the pointer up and type-in 1, and then
press Enter. The outer ellipse moves up.



Select the midpoint of the lower horizontal
line of the rectangle.
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Move the pointer downward and type-in 18,
and then press Enter.



Type-in 6 as the minor radius and press
Enter.



Double-click the Blocks icon. This displays
all the blocks available in the selected
drawing file.

Adding Furniture using Blocks




Type DC and press Enter. This opens the

the graphics window.

Design Center palette.


Click and drag the highlighted blocks into

On the Design Center palette, click the
Home button. This opens the folder in
which all the samples are located.



In the Design Center palette, expand the
Sample folder and go to en-us > Design



Close the Design Center palette.

Center > Home –Space Planner.dwg.



Select the Dining set block, and then click on
the point located at its center.



Move the block and place it at the location
shown below.
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Offset the rectangle 47.5 inwards.



Delete the original rectangle.



Rotate the bed by 90 degrees.



Activate the Move command and select the

Activate the Rectangle command and select
the corner point of the bedroom.



Select the Dimensions option from the
command line, and then specify 90 and 27.5
as length and width of the rectangle,
respectively.



Move the pointer downward and click

bed. Press Enter to accept the selection.

create the rectangle.



Select the top left corner of the bed to define
the base point.



Select the top left corner of the offset
rectangle to define the destination point.



Create another rectangle by selecting the
corner points, as shown below.
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Press Enter.



Click the Pick point button and select the
lower left corner of the window.



On the dialog, check the Open in block
editor option and click OK. This creates the



block and opens it in the Block Editor.

Delete the offset rectangle.


In the Block Editor window, activate
Authoring Palettes, if inactive.



On Authoring Palettes, click the Parameters
tab and select the Linear command.

Adding Windows


In the empty space, create the window using
the Line command, as shown below.



Click the endpoints of the horizontal line to
define the linear parameter between them.



On the ribbon, click Insert > Block
Definition > Create Block.





On the Block Definition dialog, type-in

and select the Stretch command.

Window in the Name box.


On Authoring Palettes, click the Actions tab

Click the Select Objects button and select all
the elements of the window by dragging a
selection window.
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Select the block and click the arrow grip.
Drag the pointer to stretch the block.



Select the Distance1 parameter.



Select the right endpoint of the horizontal



On the ribbon, click the Close Test Block
button.



line. This defines the point that can be used

Click the Save Block button on the
Open/Save panel.

to stretch the block.


Click the Close Block Editor button on the
Close panel. This closes the Block Editor
window. Now, you need to place the
windows.




Create a window around the selected

On the ribbon, click Insert > Block > Insert
> Window.

endpoint.



Select the horizontal and right vertical line,
and then press Enter. This defines the
elements that can be stretched.


Press and hold the Shift key and right click.



Select From.



Select the lower right corner of the bedroom.



Move the pointer on the horizontal wall and
type-in 95, and then press Enter. The
Window block will be placed at the



specified location.

On the Block Editor ribbon tab, click
Open/Save > Test Block. The Test Block
Window appears.
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Likewise, place the window blocks, as
shown below.



Select the Window block and drag the
arrow grip.



Type-in 54 and press Enter. This changes the
window size to 54.



On the ribbon, click Insert > Block > Insert
> Window.



Select the Rotate option from the command
line.



Type-in 90 and press Enter.



Place the Window block on the kitchen wall,
as shown below.
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Arranging Objects of the drawing in
Layers


On the ribbon, click the Home > Layers > Layer
Properties. This displays the Layer Properties
Manager.



On the Layer Properties Manager, click the New
Layer button.



Type Wall in the layer Name box and press
Enter.



Create another layer, and then type-in Door.
Press Enter.



Likewise, create other layers and define the
layer properties, as shown below. Refer to
Chapter 3 to learn more about layers.



Press Esc to deselect the selected objects.



Likewise, transfer the other objects to their
respective layers.



Close the Layer Properties Manager.



Select the Dining set, cupboard, and bed.



On the ribbon, click Home > Layers > Layer
drop-down > Furniture. The selected objects
will be transferred to the Furniture layer.



Open the Layer Properties Manager and
click the bulb symbols associated to Door,
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Window, Fixtures Furniture, and Counter
layers. This will hide corresponding layers.




Create a selection window and select all the

the bulb symbols.

walls.


Now, turn ON the hidden layers by clicking

On the ribbon, click Home > Layers > Layer
drop-down > Wall. All the walls will be
transferred to the Wall layer.
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Creating Grid Lines


On the ribbon, click Home > Layers > Layer
drop-down > Grid. The Grid layer becomes
active.



Activate the Line command.



Press and hold the Shift key and right-click,

Select the line to display grips on it.



Click the lower end grip and drag the
pointer to increase the length of line.



Activate the Offset command and offset the
grid line up to 406.

and then select the Mid Between 2 Points
option.






Create other grid lines, as shown below.



Create a new layer called Grid Bubbles and

Select the endpoints of the wall, as shown
below.



Move the point upward and click to draw
vertical line of arbitrary length.

make it current.



Create a circle of 12 diameter.



On the ribbon, click Insert > Block
Definition > Define Attributes.
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On the Attribute Definition dialog, type-in
GRIDBUBBLE in the Tag box and select
Justification > Middle center.



Type-in 6ʺ in the Text height box and click
OK.



Select the center point of the circle. The



attribute text will be place at it center.

Select the top endpoint of the first vertical
grid line. The Edit Attributes dialog pops
up.



Type-in A in the GRIDBUBBLE box and
click OK.



On the ribbon, click Insert > Block
Definition > Create Block.



Type-in Grid bubble in the Name box and
click the Select objects button.



Draw a crossing window to select the circle
and attribute. Press Enter to accept the
selection.



Check the Pick point option under the Base
point section.



Select the lower quadrant point of the circle
to define the base point of the block.


Likewise, add other grid bubbles to the
vertical grid lines.



Uncheck the Open in block editor option
and click OK.





On the ribbon, click Insert > Block > Insert

Create another block with name Vertical
Grid bubble. Make sure that you select the

> Grid bubble.

right quadrant point of the circle as the base
point.
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Click the Symbol and Arrows tab.



Under the Arrowhead section, select First >
Architectural tick. The second arrowhead is



Insert the vertical grid bubbles, as shown

automatically changed to Architectural tick.

below.



Select Leader > Closed Filled and enter 1/4ʹ
in the Arrow Size box.



Click the Lines tab and set Extend beyond
dim lines and Offset from origin to 3ʺ.



Click the Text tab and Text height to 6ʺ.



In the Text placement section, set the
following settings.
Vertical-Centered
Horizontal-Centered
View Direction-Left-to-Right



In the Text alignment section, select the
Aligned with dimension line option.



arrows (best fit) option from the Fit

Adding Dimensions




Options section.

On the ribbon, click Home > Layers > Layer



Over dimension line, without Leader

current.

option.


Type D in the command line and press



On the Dimension Style Manager dialog,



Type-in Floor Plan in the New Style Name


Click the Primary Units tab and select Unit



Set Fraction format to Horizontal.



Under the Zero Suppression section,

Move the pointer and click to locate the
dimension.

format > Architectural.
Set Precision to 0ʹ-01/16ʺ.

Select the points on the vertical grid lines, as
shown below.

box and click Continue.



On the ribbon, click Annotate >
Dimensions > Dimension.

click the New button.



Click OK and click Set Current on the
Dimension Style Manager. Click Close.

select the Standard dimension style and



In the Text placement section, select the

drop-down > Dimensions to make it

Enter.


Click the Fit tab, and select Either text or

uncheck the 0 inches option.
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Likewise, move the pointer and click on the
next grid line.



Activate the Dimension command create
the overall horizontal dimension.



On the ribbon, click Annotate >
Dimensions > Continue. You will notice
that a dimension is attached to the pointer





Move the pointer and click on next grid line.

Likewise, add vertical dimensions to the
grid lines.



Complete adding dimensions to the drawing, as shown below.
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Save and close the drawing.
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Exercise
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Part 2: Autodesk Inventor Basics

Chapter 1: Getting Started with Autodesk
Inventor 2018
This tutorial book brings in the most commonly used features of the Autodesk Inventor.
In this chapter, you will:





Understand the Inventor terminology
Start a new file
Understand the User Interface
Understand different environments in Inventor

In this chapter, you will learn some of the most commonly used features of Autodesk Inventor. In addition, you
will learn about the user interface.
In Autodesk Inventor, you create 3D parts and use them to create 2D drawings and 3D assemblies.
Inventor is Feature Based. Features are shapes that are combined to build a part. You can modify these shapes
individually.

Most of the features are sketch-based. A sketch is a 2D profile and can be extruded, revolved, or swept along a path
to create features.
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Inventor is parametric in nature. You can specify standard parameters between the elements. Changing these
parameters changes the size and shape of the part. For example, see the design of the body of a flange before and
after modifying the parameters of its features.

Starting Autodesk Inventor








Click the Start button on the Windows taskbar.
Click All Programs.
Click Autodesk > Autodesk Inventor 2018 > Autodesk Inventor 2018.
On the ribbon, click Get Started > Launch > New.
On the Create New File dialog, click the Templates folder located at the top left corner. You can also select
the Metric folder to view various metric templates.
In the Part – Create 2D and 3D objects section, click the Standard.ipt icon.
Click Create to start a new part file.

Notice these important features of the Inventor window.
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User Interface
Various components of the user interface are discussed next.

Ribbon
Ribbon is located at the top of the window. It consists of various tabs. When you click on a tab, a set of tools
appear. These tools are arranged in panels. You can select the required tool from this panel. The following
sections explain the various tabs of the ribbon available in Autodesk Inventor.

The Get Started ribbon tab
This ribbon tab contains the tools such as New, Open, Projects and so on.

The 3D Model ribbon tab
This ribbon tab contains the tools to create 3D features, planes, surfaces, and so on.
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The View ribbon tab
This ribbon tab contains the tools to modify the display of the model and user interface.

The Inspect ribbon tab
This ribbon tab has tools to measure the objects. It also has analysis tools to analyze the draft, curvature, surface
and so on.

Sketch ribbon tab
This ribbon tab contains all the sketch tools.

Assemble ribbon tab
This ribbon tab contains the tools to create an assembly. It is available in an assembly file.

Presentation ribbon tab
This tab contains the tools to create the exploded views of an assembly. It also has the tools to create
presentations, assembly instructions, and animation of an assembly.

Drawing Environment ribbon tabs
In the Drawing Environment, you can create print-ready drawings of a 3D model. The ribbon tabs in this
environment contain tools to create 2D drawings.
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The Sheet Metal ribbon tab
The tools in this tab are used to create sheet metal components.

File Menu
This appears when you click on the File tab located at the top left corner. This menu contains the options to open,
print, export, manage, save, and close a file.
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Quick Access Toolbar
This is available at the top left of the window. It contains the tools such as New, Save, Open, and so on.

You can customize this toolbar by clicking the down arrow at the right side of this toolbar.

Browser window
This is located at the left side of the window. It contains the list of operations carried in an Autodesk Inventor file.
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Status bar
This is available below the Browser window. It displays the prompts and the actions taken while using the tools.

Navigation Bar
This is located at the right side of the window. It contains the tools to zoom, rotate, pan, or look at a face of the
model.

View Cube
It is located at the top right corner of the graphics window. It is used to set the view orientation of the model.

Shortcut Menus and Marking Menus
When you click the right mouse button, a shortcut menu along with a marking menu appears. A shortcut menu
contains a list of some important options. The marking menu contains important tools. It allows you to access the
tools quickly. You can customize the marking menu (add or remove tools).
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Dialogs
When you activate any tool in Autodesk Inventor, the dialog related to it appears. It consists of various options,
which help you to complete the operation. The following figure shows the components of the dialog.

-
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Mini toolbar
The min-toolbar appears along with the dialog boxes of Extrude, Revolve, Fillet, Shell, Face Draft, Chamfer, and
Joint commands. However, in Autodesk Inventor 2018, the mini toolbar does not appear by default. You need to
check the Mini Toolbar option available on the User Interface drop-down of the Windows panel of the View
ribbon tab to display the mini toolbar.

Customizing the Ribbon, Shortcut Keys, and Marking Menus
To customize the ribbon, shortcut keys, or marking menu, click Tools > Options > Customize on the ribbon. On
the Customize dialog, use the tabs to customize the ribbon or marking menu, or shortcut keys.

For example, to add a command to the ribbon, select the command from the list on the left side of the dialog and
click the Add

button. If you want to remove a command from the ribbon, then select it from the right-side

list and click the Remove

button. Click OK to make the changes to effect.
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To add or remove panels from the ribbon, click the Show Panels icon located at the right-side of the ribbon and
check/uncheck the options on the fly out.

Color Settings
To change the background color of the window, click Tools > Options > Application Options on the ribbon. On
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the Application Options dialog, click the Colors tab on the dialog. Set the Background value to 1 Color to change
the background to plain. Select the required color scheme from the Color Scheme group. Click OK.
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Chapter 2: Part Modeling Basics
This chapter takes you through the creation of your first Inventor model. You create simple parts:
In this chapter, you will:








Create Sketches
Create a base feature
Add another feature to it
Create revolved features
Create cylindrical features
Create box features
Apply draft

TUTORIAL 1
This tutorial takes you through the creation of your first Inventor model. You will create the Disc of an Old ham
coupling:

Creating a New Project
1.
2.

Start Autodesk Inventor 2018 by clicking the
Autodesk Inventor 2018 icon on your desktop.
To create a new project, click Get Started >
Launch > Projects on the ribbon.

3.
4.

5.
6.

7.
8.

Click the New button on the Projects dialog.
On the Inventor project wizard dialog, select
New Single User Project and click the Next
button.
Enter Oldham Coupling in the Name field.
Enter
C:\Users\Username\Documents\Inventor\Ol
dham Coupling\ in the Project(Workspace)
Folder box and click Next.
Click Finish.
Click OK on the Inventor Project Editor dialog.
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9.

Click Done.

Starting a New Part File
1.
2.
3.
4.

To start a new part file, click Get Started >
Launch > New on the ribbon.
On the Create New File dialog, click the
Templates folder located the top right corner.
Click the Standard.ipt icon located under the
Part – Create 2D and 3D Objects section.
Click the Create button on the Create New File
dialog.

4.
5.

Move the cursor to the sketch origin, and then
click on it.
Drag the cursor and click to create a circle.

6.

Press ESC to deactivate the tool.

A new model window appears.

Starting a Sketch
1.

2.

To start a new sketch, click 3D Model > Sketch >
Start 2D Sketch on the ribbon.

Adding Dimensions

Click on the XY Plane. The sketch starts.

In this section, you will specify the size of the
sketched circle by adding dimensions. As you add
dimensions, the sketch can attain any one of the
following states:
Fully Constrained sketch: In a fully constrained
sketch, the positions of all the entities are fully
described by dimensions, constraints, or both. In a
fully constrained sketch, all the entities are dark blue
color.
Under Constrained sketch: Additional dimensions,
constraints, or both are needed to completely specify
the geometry. In this state, you can drag under
constrained sketch entities to modify the sketch. An
under constrained sketch entity is in black color.

The first feature is an extruded feature from a
sketched circular profile. You will begin by
sketching the circle.
3.

On the ribbon click Sketch > Create > Circle >
Circle Center Point.

If you add any more dimensions to a fully
constrained sketch, a message box will appear
showing that dimension over constraints the sketch.
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In addition, it prompts you to convert the dimension
into a driven dimension. Click Accept to convert the
unwanted dimension into a driven dimension.

1.

On the ribbon, click Sketch > Constrain >
Dimension.

Creating the Base Feature
The first feature in any part is called a base feature.
You now create this feature by extruding the
sketched circle.

2.
3.
4.

On the ribbon, click 3D Model > Create >
Extrude.

2.

Type-in 0.4 in the Distance box available on the
Extrude dialog.

3.

Click the Direction 1

4.

dialog.
Click OK on the Extrude dialog to create the
extrusion.

Select the circle and click; the Edit Dimension
box appears.
Enter 4 in the Edit Dimension box and click the
green check.
Press Esc to deactivate the Dimension tool.

You can also create dimensions while creating the
sketch objects. To do this, enter the dimension
values in the boxes displayed while sketching.
5.

1.

To display the entire circle at full size and to
center it in the graphics area, use one of the
following methods:


Click Zoom All



Click View > Navigate > Zoom All on the
ribbon.

on the Navigate Bar.

6.

Click Finish Sketch on the Exit panel.

7.

Click Zoom All

on the Navigate Bar.
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Notice the new feature, Extrude 1, in the
Browser window.

To display the part in different modes, select the
options in the Visual Style drop-down on the
Appearance panel of the View tab.

To magnify a model in the graphics area, you
can use the zoom tools available on the Zoom
drop-down in the Navigate panel of the View
tab.

Realistic

Click Zoom All to display the part full size in the
current window.
Click Zoom Window, and then drag the pointer to
create a rectangle; the area in the rectangle zooms to
fill the window.

Shaded

Click Zoom, and then drag the pointer. Dragging up
zooms out; dragging down zooms in.
Click on a vertex, an edge, or a feature, and then
click Zoom Selected; the selected item zooms to fill
the window.
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Shaded With Edges

Wireframe with Visible Edges Only

Shaded with Hidden Edges

Monochrome

Wireframe

Watercolor

Wireframe with Hidden Edges
Sketch Illustration
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Technical Illustration

The default display mode for parts and assemblies is
Shaded with Edges. You may change the display
mode whenever you want.

8.

Draw another line below the previous line.

9.

On the ribbon, click Sketch > Constrain >

Adding an Extruded Feature
To create additional features on the part, you need to
draw sketches on the model faces or planes, and then
extrude them.
1.
2.
3.
4.

On the ribbon, click View > Appearance >
Visual Style > Wireframe.
On the ribbon, click 3D Model > Sketch > Start
2D Sketch.
Click on the front face of the part.
Click Line on the Create panel.

5.

Click on the circular edge to specify the first
point of the line.

6.
7.

Move the cursor towards right.
Click on the other side of the circular edge; a line
is drawn.

Horizontal Constraint

.

10. Select the two lines to make them horizontal.
11. On the ribbon, click Sketch > Constrain > Equal
.
12. Select the two horizontal lines to make them
equal.
13. Click Dimension on the Constrain panel of the
Sketch ribbon tab.
14. Select the two horizontal lines.
15. Move the cursor toward right and click to locate
the dimension; the Edit Dimension box appears.
16. Enter 0.472 in the Edit Dimension box and click
the green check.
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20. Enter 0.4 in the Distance1 box on the Extrude
dialog.
21. On the Extrude dialog, click the Direction 1 icon,
and then OK to create the extrusion.

17. Click Finish Sketch on the Exit panel.
18. Click on the sketch, and then click Create
Extrude on the Mini Toolbar; the Extrude
dialog appears.

By default, the ambient shadows are displayed on
the model. However, you can turn off the ambient
shadows by clicking View tab > Appearance panel >
Shadows drop-down, and then unchecking the
Ambient Shadows option. The Shadows dropdown has two more options, which you use based
on your requirement.

19. Click in the region bounded by the two
horizontal lines.

You can reuse the sketch of an already existing
feature. To do this, expand the feature in the Browser
Window, right click on the sketch, and select Share
Sketch from the shortcut menu. You will notice that
the sketch is visible in the graphics window. You can
also unshare the sketch by right clicking on it and
selecting Unshare.
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Adding another Extruded Feature
1.

Click Start 2D Sketch on the Sketch panel of the
3D Model ribbon tab.

2.

Use the Free Orbit

3.
4.
5.
6.

button from the Navigate

Bar to rotate the model such that the back face of
the part is visible.
Right click and select OK.
Click on the back face of the part.
Click Line
on the Create panel.
Draw two lines, as shown below (refer to the
Adding an Extruded Feature section to know
how to draw lines). Make sure that the
endpoints of the lines are coincident with the
circular edge. Follow the next two steps, if they
are not coincident.

Skip the above two steps if the endpoints of the
lines are coincident with the circular edge.
You can specify a point using various point snap
options. To do this, activate a sketching tool, right
click and select Point Snaps; a list of point snaps
appears. Now, you can select only the specified point
snap.

7.

On the ribbon, click Sketch > Constrain >
Coincident Constraint

. Next, select the

end point of the line and the circular edge.

9. On the ribbon, click Sketch > Constrain >
Vertical Constraint

.

10. Select the two lines to make them vertical.
11. On the ribbon, click Sketch > Constrain > Equal
.

8.

12. Select the two vertical lines to make them equal.
13. Create a dimension of 0.472in between the
vertical lines.

Likewise, make the other endpoints of the
lines coincident with the circular edge.
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18. On the ribbon, click View > Appearance >
Visual Style > Shaded with Edges.
19. On the ribbon, click View > Navigate >
Home View

14. Click Finish Sketch.
15. On the ribbon, click 3D Model > Create >
Extrude.
16. Click inside the region enclosed by two lines,
if they are not already selected.
17. Type 0.4 in the Distance1 box on the Extrude
dialog and click OK.
To move the part view, click Pan

.

Saving the Part
1.
2.

on

3.
4.

Navigate Bar, and then drag the part to
move it in the graphics area.

Click Save
on the Quick Access Toolbar.
On the Save As dialog, type-in Disc in the File
name box.
Click Save to save the file.
Click File Menu > Close.

Note:
*.ipt is the file extension for all the files that you create in the Part environment of Autodesk Inventor.

TUTORIAL 2
In this tutorial, you create a flange by performing the following:




Creating a revolved feature
Creating a cut features
Adding fillets
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Starting a New Part File
1.

4.

Create a sketch similar to that shown in figure.

5.

On the ribbon, click Sketch > Format >

To start a new part file, click the Part icon on the
Home screen.

Sketching a Revolve Profile
You create the base feature of the flange by
revolving a profile around a centerline.
1.
2.

Click 3D Model > Sketch > Start 2D Sketch on
the ribbon.
Select the YZ plane.

Centerline
6.
7.

3.

Click Line

on the Create panel.
336

.

Click Line
on the Create panel.
Create a centerline, as shown below.
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8.

Click Fix

You can display all the constraints by right clicking

on the Constrain panel.

and selecting Show All Constraints option. You
can hide all the constraints by right clicking and
selecting the Hide All Constraints option.

9. Select the Line 1.
10. Click Dimension on the Constrain panel.
11. Select the centerline and Line 2; a dimension
appears.
12. Move the pointer horizontally toward right and
click to place the dimension.
13. Place the dimension and enter 4 in the Edit
Dimension box.
14. Click the green check
on the Edit Dimension
dialog.
15. Select the centerline and Line 4; a dimension
appears.
16. Move the pointer horizontally toward left and
click to place the dimension.
17. Enter 2.4 in the Edit Dimension box.
18. Click the green check
on the Edit Dimension
dialog.
19. Select the centerline and Line 6; a dimension
appears.
20. Move the pointer horizontally toward left and
click to place the dimension.
21. Enter 1.2 in the Edit Dimension box.
22. Click the green check
on the Edit Dimension
dialog.
23. Create a dimension between the Line 1 and Line
3.
24. Set the dimension value to 0.8 inches.
25. Create a dimension between Line 1 and Line 5.
26. Set the dimension value to 2 inches.

27. Right-click and select Finish 2D Sketch.

Creating the Revolved Feature
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1.

On the ribbon, click 3D Model > Create >
Revolve (or) right-click and select Revolve from
the Marking menu.

2.

Set Extents to Full on the Revolve dialog.
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The Primitives panel is added to the ribbon.

3.

6.

On the ribbon, click 3D Model > Primitives >
Primitive drop-down > Box on the Primitives
panel.

7.

Click the back face of the part; the sketch starts.

8.
9.
10.
11.

Select the origin to define the center point.
Move the cursor diagonally toward right.
Enter 4.1 in the horizontal dimension box.
Press Tab key and enter 0.472 in the vertical
dimension box.

Click OK to create the revolved feature.

Creating the Cut feature
1.

2.
3.
4.
5.

On the Navigation pane, click the Orbit icon.

Press and hold the left mouse button and drag
the mouse; the model is rotated.
Rotate the model such that its back face is
visible.
Right click and select OK.
On the 3D Model tab of the ribbon, click the
Show Panels icon located at the right corner,
and then check the Primitives option from the
drop-down.
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12. Press the Enter key; the Extrude dialog appears.
13. Expand the Extrude dialog by clicking the down
arrow button.
14. Click the Cut

button on the Extrude dialog.

15. Enter 0.4 in the Distance box.
16. Click OK to create the cut feature.



Draw three lines and the circle, as shown in
figure.



Apply the Horizontal constraint to the
horizontal lines, if not applied already.
Apply the Equal constraint between the
horizontal lines.
Ensure that the endpoints of the horizontal line
coincide with the circle.
Apply dimension of 0.236 to the vertical line.
Apply dimension of 0.118 to horizontal line.

Creating another Cut feature
1.

Click the Home icon located at the tope left
corner of the ViewCube.


2.




Create a sketch on the front face of the base
feature.





On the ribbon, click 3D Model > Sketch > Start
2D Sketch.
Select the front face of the model.
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Apply dimension of the 1.2 diameter to the
circle.




On the ribbon, click Sketch > Modify > Trim
Click on the circle to trim it.

.

4.

Click Extrude

on the Create panel of the 3D

Model.

3.

5.

Click in the region enclosed by the three lines and
the arc.

6.

Select All from the Extents drop-down.

7.

Click the Cut

Finish the sketch.
You can hide or display the sketch dimensions. To do
this, go to View > Visibility > Object Visibility
and check the Sketch Dimensions option.
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button on the Extrude dialog.
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8.

Click OK to create the cut feature.

4.

Click File Menu > Close.

TUTORIAL 3
In this tutorial, you create the Shaft by performing
the following:



Creating a cylindrical feature
Creating a cut feature

Adding a Fillet
1.

On the ribbon, click 3D Model > Modify > Fillet
(or) right-click and select Fillet from the
Marking menu.

Starting a New Part File
1.

On the ribbon, click Get Started > Launch >
New

2.
3.

.

2.

On the Create New File dialog, select
Standard.ipt.

3.

Click Create.

Click on the inner circular edge and set Radius
as 0.2.
Click OK
to add the fillet.

Creating the Cylindrical Feature
1.

Saving the Part
1.
2.
3.

Click Save
on the Quick Access Toolbar.
On the Save As dialog, type-in Flange in the
File name box.
Click Save to save the file.
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On the ribbon, click Primitives > Primitive
drop-down > Cylinder.
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2.
3.
4.

Click on the XY plane to select it; the sketch
starts.
Click at the origin and move the cursor outward.
Enter 1.2 in the box attached to the circle.





5.
6.

7.

Apply the Coincident constraint between
the end points of the vertical lines and the
circular edge.
Add dimensions to the sketch.

Press Enter key; the Extrude dialog appears.
Enter 4 in the Distance box.

2.

Finish the sketch.

3.
4.
5.
6.
7.

Click Extrude on the Create panel.
Click in the region enclosed by the sketch.
Click the Cut button on the Extrude dialog.
Set Distance to 2.165.
Click OK to create the cut feature.

Click OK to create the cylinder.

Creating Cut feature
1.

Create a sketch on the front face of the base
feature.
 On the ribbon, click 3D Model > Sketch >
Start 2D Sketch.
 Select the front face of the cylinder.
 On the ribbon, click Sketch > Create > Line.
 Draw three lines, as shown.

Saving the Part
1.
2.
3.
4.
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Click Save
on the Quick Access Toolbar; the
Save As dialog appears.
Type-in Shaft in the File name box.
Click Save to save the file.
Click File Menu > Close.
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TUTORIAL 4
In this tutorial, you create a Key by performing the
following:



Creating an Extruded feature
Applying draft

Applying Draft

Start Extruded feature
1.
2.
3.
4.

5.
6.
7.

Start a new part file using the Standard.ipt
template.
On the ribbon, Primitives > Primitive dropdown > Box.
Select the XY plane.
Create the sketch, as shown in figure.

Press ENTER.
Enter 2 in the Distance box.
Click OK to create the extrusion.

1.

On the ribbon, click 3D Model > Modify >
Draft.

2.

Select the Fixed Plane option.

3.

Select front face as the fixed face.

4.

Select the top face as the face to be draft.

5.
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Set Draft Angle to 1.
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6.

Click the Flip pull direction button on the
Face Draft dialog.

7.

Click OK to create the draft.

Saving the Part
1.
2.
3.
4.
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Click Save on the Quick Access Toolbar; the
Save As dialog appears.
Type-in Key in the File name box.
Click Save to save the file.
Click File Menu > Close.
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Chapter 3: Assembly Basics
In this chapter, you will:






Add Components to assembly
Apply constraints between components
Check Degrees of Freedom
Check Interference
Create exploded view of the assembly

TUTORIAL 1
This tutorial takes you through the creation of your first assembly. You create the Oldham coupling assembly:
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There are two ways of creating any assembly model.
3.

Right-click and select Place Grounded at
Origin; the component is placed at the origin.

Starting a New Assembly File

4.

Right-click and select OK.

To start a new assembly file, click the Assembly icon
on the Home screen.

Adding the second component

•
•

Top-Down Approach
Bottom-Up Approach

Top-Down Approach
The assembly file is created first and components are
created in that file.

Bottom-Up Approach
The components are created first, and then added to
the assembly file. In this tutorial, you will create the
assembly using this approach.

1.

To insert the second component, right-click and
select Place Component; the Place Component
dialog appears.

2.

Browse to the project folder and double-click on
Shaft.ipt.
Click in the window to place the component.

Inserting the Base Component
1.

To insert the base component, click Assemble >
Component > Place on the ribbon.

3.

2.

Browse to the project folder and double-click on
Flange.ipt.
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4.

Right-click and select OK.

Applying Constraints
After adding the components to the assembly
environment, you need to apply constraints between
them. By applying constraints, you establish
relationships between components.
1.

To apply constraints, click Assemble >
Relationships > Constrain on the ribbon.
Note that if you set the Solution to Flush, the faces
will point in the same direction.

The Place Constraint dialog appears on the screen.

You can also align the centerlines of the cylindrical
faces.
Different assembly constraints that can be applied
using this dialog are given next.
Mate: Using this constraint, you can make two
planar faces coplanar to each other.
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Angle: Applies the angle constraint between two
components.

Tangent: This constraint is used to apply a tangent
relation between two faces.

348

Part 2: Autodesk Inventor Basics

Symmetry: This constraint is used to position the
two components symmetrically about a plane.

Insert: This constraint is used to make two
cylindrical faces coaxial. In addition, the planar faces
of the cylindrical components will be on the same
plane.

2.

On the Place Constraints dialog, under the Type
group, click the Mate
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3.

Click on the cylindrical face of the Shaft.

4.

Click on the inner cylindrical face of the Flange.
10. Click the Flush button on the Place Constraint
dialog.

11. Click Apply. The front face of the Shaft and the
slot face of the Flange are aligned.
5.

Click the Apply button.

6.

Ensure that the Mate
icon is selected in the
Type group.
Click on the front face of the shaft.

7.

12. Ensure that the Mate button is selected in the
Type group.
13. Expand Flange: 1 in the Browser window.
14. Select the XZ Plane of the Flange.
8.
9.

Rotate the model.
Click on the slot face of the flange, as shown in
figure.
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Adding the Third Component
15. Expand Shaft: 1 and select the YZ plane of the
Shaft.

1.

2.
3.
4.
5.
6.

To insert the third component, click Assemble >
Component > Place
on the ribbon.
Go to the project folder and double-click on
Key.ipt.
Click in the graphics window to place the key.
Right-click and click OK.
Right-click on Flange: 1 in the Browser window.
Click Visibility on the shortcut menu; the
Flange is hidden.

7.

Click Constrain

on the Relationships panel.

8.
9.

Click Mate
on the Place Constraint dialog.
Select Mate from the Solution group.

16. Click the Flush button on the Place Constraint
dialog.

10. Click the right mouse button on the side face of
the key and click Select Other on the shortcut
menu.
11. Select the bottom face of the Key from the flyout.

17. Click OK to assemble the components.

12. Select the flat face of the slot.
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13. Click the Apply button. The bottom face of the
key is aligned with the flat face of the slot.

17. Click Apply on the dialog; the mate is applied.
18. Close the dialog.
Now, you need to check whether the parts are
fully constrained or not.
19. Click View > Visibility > Degrees of Freedom
on the ribbon.

14. Click the Mate
icon on the Place Constraint
dialog.
15. Select Flush from the Solution group.

You will notice that an arrow appears pointing in
the upward (or downward) direction. This means
that the Key is not constrained in the Z-direction.

16. Select the front face of the Key and back face of
the Shaft, as shown.

You must apply one more constraint to constrain the
key.
20. Click Constrain
on the Relationships panel
of the Assemble ribbon tab.

352

Part 2: Autodesk Inventor Basics

21. Click the Mate
icon the dialog.
22. Select Flush from the Solution group.
23. Expand the Origin node of the Assembly in the
Browser window and select XZ Plane.

Checking the Interference
24. Expand the Key: 1 node in the Browser window
and select YZ Plane.

1.

Click Inspect > Interference > Analyze
Interference on the Ribbon. The Interference
Analysis dialog appears.

2.
3.
4.

Select the Flange and Shaft as Set #1.
Click the Define Set #2 button.
Select the Key as Set # 2.

25. Click OK. The mate is applied between the two
planes.

Now, you need to turn-on the display of the Flange.
26. Right-click on the Flange in the Browser
window and select Visibility; the Flange
appears.
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2.
3.
4.

Go to the project folder and double-click on
Flange_subassembly.iam.
Click in the window to place the flange sub
assembly.
Right-click and click OK.

Adding Constraints
5.
6.

1.

Click OK; the message box appears showing
that there are no interferences.
Click OK.

2.

Click Constrain
on the Relationships
panel of the Assemble ribbon.
Click the Insert button on the Place Constraint
dialog.

Saving the Assembly
1.
2.
3.
4.
5.

Click Save on the Quick Access Toolbar; the
Save As dialog appears.
Type-in Flange_subassembly in the File name
box.
Go to the project folder.
Click Save to save the file.
Click File Menu > Close.

3.

Select Opposed from the Solution group.

4.

Click on the circular edge of the Flange.

5.

Click on the circular edge of the Disc.

Starting the Main assembly
1.
2.

3.

On the ribbon, click Get Started > Launch >
New.
On the Create New File dialog, click the
Standard.iam icon.

Click Create to start a new assembly.

Adding Disc to the Assembly
1.
2.
3.
4.

Click Assemble > Component > Place
on
the ribbon.
Go to the project folder and double-click on
Disc.ipt.
Right-click and select Place Grounded at
Origin; the component is placed at the origin.
Right-click and select OK.

Placing the Sub-assembly
1.

To insert the sub-assembly, click the Place
button on the Component panel of the ribbon.
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14. Release the mouse button, right click, and select
OK.
15. Click on the face on the Flange, as shown in
figure.

6.

Click OK on the dialog.

Next, you have to move the subassembly away from
the Disc to apply other constraints.
7.

Click Free Move on the Position panel.

8.

Select the flange subassembly and move it.

16. Click on the face on the Disc as shown in figure.

17. Click OK on the dialog.

9.
10.
11.
12.
13.

Click the Constrain button on the Relationships
panel.
Click Mate on the Place Constraints dialog.
Select Mate from the Solution group.
Click the View > Navigate > Orbit on the
ribbon.
Press and hold the left mouse button and drag
the cursor toward left.
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Placing the second instance of the Subassembly
1.
2.

Insert another instance of the Flange
subassembly.
Apply the Insert and Mate constraints.

Starting a New Presentation File
1.

Saving the Assembly
1.
2.
3.
4.

Click Save on the Quick Access Toolbar; the
Save As dialog appears.
Type-in Oldham_coupling in the File name
box.
Click Save to save the file.
Click File Menu > Close.

On the Home screen, click the Presentation icon
(or) click Get Started > Launch > New, and then
select the Standard.ipn template from the
Create New File dialog.

The Insert dialog appears.
2.

Tutorial 2
In this tutorial, you create the exploded view of the
assembly:

On the Insert dialog, go to the project folder and
double-click on the Oldham Coupling.iam file.
The Presentation Environment appears, as
shown.
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Creating a Storyboard Animation
1.

2.

In the Model tree, double-click on Scene1 and
type Explosion.

Click in the Scratch Zone area and notice that
the play marker is displayed inside it.
Now, the changes made to the assembly in the
Scratch Zone will be the starting point of the
exploded animation. You can change the
orientation of the assembly, hide a component,
or change the opacity of the component. Use the
Capture Camera
tool on the Camera panel
to set the camera position for the animation.

Before creating an exploded view, you need to
take a look at the Storyboard displayed at the
bottom of the window. The Storyboard has the
Scratch Zone located at the left side of the
timeline. Also, notice that the play marker is
displayed at 0 seconds in the timeline.

3.

On the ribbon, click View tab > Windows panel
> User Interface drop-down, and then check the
Mini toolbar option. The Mini toolbar appears
whenever you activate a tool.

Part 2: Autodesk Inventor Basics

9.

4.

5.
6.

7.

Click the Tweak Components
button on
the Component panel of the Presentation
ribbon tab. The mini toolbar appears with
different options, as shown.

10. Type 4 in the Z box attached to the manipulator.

Notice that the default duration for a tweak is
2.500 s. You can type a new value in the
Duration box available on the Mini toolbar.
Select Component from the Selection Filter
drop-down of Mini toolbar.
Select the All Components from the Tracelines
drop-down. This will create tracelines of all
exploded components.
Select the Flange subassembly from the graphics
window. The manipulator appears on the
assembly.
Now, you must specify the direction along
which the sub-assembly will be exploded.

8.

Click the Z axis of the manipulator.

11. Click OK
on the Mini toolbar.
12. Right click in the graphics window and select
Tweak Components from the Marking menu.

On the Mini toolbar, select Local > World.
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20. On the Mini toolbar, select Local > World.

21. Click on the Z axis of the manipulator.
13. Select Component from the Selection filter dropdown on the Mini toolbar.
14. Select the other flange sub-assembly.
15. Click on the Z axis of the manipulator.
16. Type 4 in the Z box attached to the manipulator,
and click OK .

22. Type 4 in the box attached to the manipulator,
and then press Enter.
23. Click OK on the Mini Toolbar.
24. Activate the Tweak Components
command.
25. Zoom into the flange and click on the key, as
shown.

17. Click the Tweak Components
button on
the Component panel of the Presentation
ribbon tab.
18. On the Mini Toolbar, select Part from the dropdown, as shown.

19. Select the front cylinder.
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26. Click on the Z axis of the manipulator.
27. Type 3.15 in the box attached to the manipulator
and press Enter.
18. Likewise, explode the parts of the flange
subassembly in the opposite direction. The
explosion distances are same.

5.

You can also select Current Storyboard Range
and specify the start and end position of
storyboard.
6.

7.
8.
9.

Animating the Explosion
1.

On the Publish to Video dialog, select Current
Storyboard option from the Publish Scope
section.

On the Publish to Video dialog, click the folder
icon and specify the project folder as the File
Location.
Set the File Format to WMV File (*.wmv).
Check the Reverse option to reverse the
animation.
Leave the other default settings and click OK;
Publish Video Progress dialog appears.
A message box appears that the video has been
published.

To play animation of the explosion, click the
Play Current Storyboard button on the
Storyboard.

10. Click OK on the message box.

Taking the Snapshot of the Explosion
1.

2.

Click and drag the play marker on the timeline
to 15 seconds.

Click the Reverse Play Current Storyboard
button on the Storyboard.

2.

Workshop panel > New Snapshot View

You can publish the animation video using the
Video tool available on the Publish panel.
3.

Make sure that the play marker is at 0 secs on
the timeline.

4.

On the ribbon, click Presentation tab > Publish
panel > Video

You can capture the snapshot of the current
position of the assembly using the New
Snapshot View tool.
On the ribbon, click Presentation tab >
.

The snapshot appears in the Snapshot Views
window. Notice that playmarker on the snapshot. It
indicates that the snapshot is dependent on the
storyboard.

.
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For example, if you make changes to the assembly at
the position of the playmarker where the snapshot
was taken, the Update View symbol appears on the
snapshot view. You need to click on the Update
View symbol to update the snapshot.

3.
4.
5.
6.
7.
8.

Click Save
on the Quick Access Toolbar; the
Save As dialog appears.
Type-in Oldham_coupling in the File name
box.
Go to the project folder.
Click Save to save the file.
Click OK.
Click File Menu > Close.
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Chapter 4: Creating Drawings
In this chapter, you will generate 2D drawings of the parts and assemblies.
In this chapter, you will:









Insert standard views of a part model
Create centerlines and centermarks
Retrieve model dimensions
Add additional dimensions and annotations
Create Custom Sheet Formats and Templates
Insert exploded view of the assembly
Insert a bill of materials of the assembly
Apply balloons to the assembly

TUTORIAL 1
In this tutorial, you will create the drawing of Flange.ipt file created in the second chapter.

Starting a New Drawing File
1.

To start a new drawing, click the Drawing icon
on the Home screen.
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Editing the Drawing Sheet
1.

To edit the drawing sheet, right-click on Sheet:1
in the Browser window and select Edit Sheet
from the shortcut menu.

3.

2.

Click OK.

The drawing views in this tutorial are created in the
Third Angle Projection. If you want to change the
type of projection, then following the steps given
next:

On the Edit Sheet dialog, set Size to B.

4.
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Click Manage > Styles and Standards > Style
Editor on the ribbon.
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6.

5.

On the Style and Standard Editor dialog,
specify the settings shown in figure.

2.

On the Drawing View dialog, click Open

3.

existing file
.
On the Open dialog, browse to the project
folder.

Click Save and Close.

Generating the Base View
1.

To generate the base view, click Place views >
Create > Base on the ribbon.
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4.

Set Files of type to Inventor Files (*.ipt, *.iam,
*.ipn), and then double-click on Flange.ipt.

5.
6.
7.

Set the Style to Hidden Line
.
Set Scale to 1:1.
Click on the preview, drag, and place it at the
left side on the drawing sheet, as shown.
Click OK on the dialog.

8.

5.
6.

Click on the dotted line and move the cursor
vertically downwards.
Click outside the bottom portion of the view, as
shown.

Generating the Section View
1.

To create the section view, click Place Views >
Create > Section on the ribbon.

2.
3.

Select the base view.
Place the cursor on the top quadrant point of the
circular edge, as shown.

4.

Move the pointer upward and notice the dotted
line.
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7.

Right-click and select Continue.

8.

Move the cursor toward right and click to place
the section view.
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4.

Specify the center point and boundary point of
the detail view, as shown in figure.

5.

Place the detail view below the base view.

Creating the Detailed View
Now, you have to create the detailed view of the
keyway, which is displayed, in the front view.
1.

To create the detailed view, click Place Views >
Create > Detail on the ribbon.

2.
3.

Select the base view.
On the Detail View dialog, specify the settings,
as shown next.
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Creating Centermarks and Centerlines
1.

To create a center mark, click Annotate >
Symbols > Center Mark on the ribbon.

Retrieving Dimensions
Now, you will retrieve the dimensions that were
applied to the model while creating it.
1.

2.

To retrieve dimensions, click Annotate >
Retrieve > Retrieve on the ribbon.

Click on the outer circle of the base view.

The Retrieve Dimension dialog appears.

3.

To create a centerline, click Annotate > Symbols
> Centerline Bisector on the ribbon.

4.

Click on the inner horizontal edges of the section
view.

2.

Select the section view from the drawing sheet.

Now, you must select the dimensions to retrieve.
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3.

4.
5.

Drag a window on the section view to select all
the dimensions.

8.

Click the right-mouse button and select OK.

9.

Select the unwanted dimensions and press
Delete.

Click Select Features under the Select Source
group.
Click OK to retrieve feature dimensions.

6.

Click Annotate > Dimension > Arrange on the
ribbon.

7.

Drag a selection box and select all the
dimensions of the section view.
10. Click and drag the dimensions to arrange them
properly.
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Adding additional dimensions
1.

To add dimensions, click Annotate >
Dimension > Dimension on the ribbon.

2.

Select the center hole on the base view.

3.

4.

Place the dimension, as shown in figure. The
Edit Dimension dialog appears.

5.
6.

Click OK.
Create the dimensions on the detail view, as
shown in figure.

Right-click and select Dimension Type >
Diameter.

Populating the Title Block
1.
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To populate the title block, click File Menu >
iProperties.

Part 2: Autodesk Inventor Basics

2.
3.

5.

On the Flange iProperties dialog, click the tabs
one-by-one and type-in data in respective fields.
Click Apply and Close.

Under the Orientation section, you can change
the orientation of the title block as well as the
sheet orientation.

Saving the Drawing
1.
2.
3.
4.
5.

On the Edit Sheet dialog, set Size to B.

6.
7.

Click Save on the Quick Access Toolbar; the
Save As dialog appears.
Type-in Flange in the File Name box.
Go to the project folder.
Click Save to save the file.
Click File Menu > Close.

8.

Click OK.
In the Browser window, expand the Drawing
Resources > Sheet Formats folder to view
different sheet formats available. Now, you will
add a new sheet format to this folder.
Click the right mouse button on the Borders
folder and select Define New Border.

TUTORIAL 2
In this tutorial, you will create a custom template, and
then use it to create a new drawing.

Creating New Sheet Format
1.
2.

On the ribbon, click Get Started > Launch >
New.
On the Create New File dialog, click the
Standard.idw icon.
Now, you can create a new border using the
sketch tools available in the Sketch tab.

3.
4.

9.

Click Finish Sketch on the Sketch tab of the
ribbon.
10. On the Border dialog, click Discard.
11. In the Browser window, click the right mouse
button on the Borders folder and select Define
New Zone Border.

Click Create to start a new drawing file.
To edit the drawing sheet, right-click on Sheet:1
in the Browser window and select Edit Sheet
from the shortcut menu.
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12. On the Default Drawing Border Parameters
dialog, type-in 4 in the Vertical Zones box and
click OK.

18. Draw a rectangle in the Company cell of the title
block. This defines the image size and location.

13. Click Finish Sketch on the Sketch tab of the
ribbon.
14. On the Border dialog, type-in 4-Zone Border
and click Save.
19. Go to the location of your company logo or any
other image location. You must ensure that the
image is located inside the project folder.
20. Select the image file and click Open. This will
insert the image into the title block.

15. Expand the Title Blocks folder and click the
right mouse button on ANSI-Large.
16. Select Edit from shortcut menu.

21. Click Finish Sketch on the ribbon.
22. Click Save As on the Save Edits dialog.
23. Type-in ANSI-Logo in the Title Block dialog.

17. On the Sketch tab of the ribbon, click Insert >
Image.

24. Click Save.
25. In the Browser window, expand Sheet:1 and
click the right mouse button on Default Border.
26. Select Delete from the shortcut menu.
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27. Expand the Borders folder and click the right
mouse button on 4-Zone Border.
28. Select Insert from the shortcut menu.
34. Click the right mouse button on Sheet:1 and
select Create Sheet Format.

29. Click OK on the Edit Drawing Border
Parameters dialog.
30. Expand Sheet:1 and click the right mouse button
on ANSI-Large.
31. Select Delete from the shortcut menu.

35. Type-in Custom Format in the Create Sheet
Format dialog, and then click OK.

You will notice that the new sheet format is listed in
the Sheet Formats folder.

32. Expand the Title Blocks folder and click the
right mouse button on ANSI-Logo.
33. Select Insert from the shortcut menu to insert
the title block.
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3.

4.

In the Browser window, expand the Sheet
Formats folder and double-click on Custom
Format.
Click the right mouse button on Sheet: 2 and
select Delete Sheet from the shortcut menu.

Creating a Custom Template
1.

On the ribbon, click Tools > Options >
Document Settings.
5.
6.
7.

Click OK.
On the ribbon, click Manage > Styles and
Standards > Styles Editor.
On the Style and Standard Editor dialog, select
Dimension > Default (ANSI).

On Document Settings dialog, you can define the
standard, sheet color, drawing view settings, and
sketch settings.

8.

Click the New button located at the top of the
dialog.
9. Type-in Custom Standard in the New Local
Style dialog, and then click OK.
10. Click the Units tab and set Precision to 3.123.

2.

Leave the default settings on this dialog and
click Close.
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11. Click Save and Close.
12. On the File Menu, click Save As > Save Copy
As Template. This will take you to the templates
folder on your drive.
13. Type-in Custom Template in the File name box.
14. Click Save.
15. Close the drawing file without saving it.

5.
6.
7.
8.

Starting a Drawing using the Custom
template
1.
2.

3.

Set Scale to 1:1.
Click and drag the view to top-center of the
drawing sheet.
Move the cursor downwards and click to place
the projected view.
Right-click and select OK.

On the ribbon, click Get Started > Launch >
New.
On the Create New File dialog, click the Custom
Standard.idw icon.

Click Create and OK to start a new drawing file.

Generating the Drawing Views
1.

To generate views, click Place views > Create >

2.

Base
on the ribbon.
On the Drawing View dialog, click Open

3.
4.

Adding Dimensions
1.

existing file
.
Go to the project folder and double-click on
Disc.ipt.
Select Front from the ViewCube displayed on
the sheet.

2.
3.
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On the ribbon, click Annotate > Dimension >
Dimension.
Select the circular edge on the base view.
On the ribbon, click Annotate > Format > Select
Style > Custom Standard.
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4.
5.
6.

Right-click and select Dimension Type >
Diameter.
Click to place the dimension.
Click OK.
11. Right-click and select OK to deactivate the
Dimension tool.
12. Save and close the drawing file.

TUTORIAL 3
In this tutorial, you will create the drawing of
Oldham coupling assembly created in the previous
chapter.

Creating a New Drawing File
7.
8.
9.

1.

Select the horizontal edges on the base view.
Move the pointer toward right and click to place
the dimension.
Click OK on the Edit Dimension dialog.

2.

3.

On the ribbon, click Get Started > Launch >
New.
On the Create New File dialog, click the Custom
Standard.idw icon.

Click Create and OK to start a new drawing file.

Generating Base View
1.

To generate the base view, click Place views >
Create > Base
on the ribbon; the Drawing
View dialog appears.

10. Add other dimensions to drawing.

2.
3.
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Click Open existing file
on this dialog; the
Open dialog appears.
Go to the project folder and double-click on
Oldham_Coupling.iam.
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4.

Click the Home icon located above the
ViewCube.

7.

Right-click and select OK.

Configuring the Parts list settings
1.
5.
6.
7.

Set Scale to 1/2.
Click and drag the view at top left corner.
Right-click and select OK.

2.

Click Manage > Styles and Standards > Style
Editor on the ribbon; the Style and Standard
Editor dialog appears.
Expand the Parts List node and select Parts List
(ANSI).

3.

Click the Column Chooser button under the
Default Columns Settings group; the Parts List
Column Chooser dialog appears.

4.

On this dialog, select DESCRIPTION from the
Selected Properties list and click the Remove
button.
Select PART NUMBER from the Selected
Properties list and click Move Up.
Click OK.

Generating the Exploded View
1.

2.
3.
4.
5.
6.

To generate the base view, click Place views >
Create > Base on the ribbon; the Drawing View
dialog appears.
Click Open existing file on this dialog; the
Open dialog appears.
Go to the project folder and double-click on
Oldham_Coupling.ipn.
Click the Home icon located above the
ViewCube.
Set Scale to 1/2.
Click and drag the view to the center of the
drawing sheet.

5.
6.
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7.

Click Save and Close.

Creating the Parts list
1.

2.
3.

4.
5.

To create a parts list, click Annotate > Table >
Parts List on the ribbon; the Parts List dialog
appears.
2.
3.
4.
5.

Select the exploded view from the drawing sheet.
Select all the parts in the exploded view.
Select Horizontal from the Placement group.
Click the Select Placement button in the
Placement group.

6.
7.

Click above the exploded view.
Click OK to place the balloons.

Select the exploded view from the drawing sheet.
Select Parts Only from the BOM View dropdown under the BOM Settings and Properties
group.

Click OK twice.
Place the part list above the title block.

Saving the Drawing
1.

Creating Balloons
1.

To create balloons, click Annotate > Table >
Balloon > Auto Balloon on the ribbon; the
Auto-Balloon dialog appears.

2.
3.
4.
5.
6.
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Click Save on the Quick Access Toolbar; the
Save As dialog appears.
Type-in Oldham_Coupling in the File Name
box.
Go to the project folder.
Click Save to save the file.
Click OK.
Click File Menu > Close.
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Chapter 5: Additional
Modeling Tools

Creating the First Feature

In this chapter, you create models using additional
modeling tools. You will learn to:

2.



















Create slots
Create circular patterns
Create holes
Create chamfers
Create shells
Create rib features
Create coils
Create a loft feature
Create an emboss feature
Create a thread
Create a sweep feature
Create a grill feature
Create a replace faces
Create a face fillet
Create a variable fillet
Create a boss feature
Create a lip feature

TUTORIAL 1
In this tutorial, you create the model shown in
figure:

1.

3.

Create a new project with the name Autodesk
Inventor 2018 Basics Tutorial (See Chapter 2,
Tutorial 1, Creating New Project section to learn
how to create a new project).
Open a new Inventor part file using the
Standard.ipt template (See Chapter 2, Tutorial 3,
Starting a New Part File section).
Click the Start 2D sketch button on the ribbon,
and select the XY Plane.

4.

Click the Circle Center Point
button and
draw a circle (See Chapter 2, Tutorial 1, Starting
a Sketch section to learn how to create a new
project).

5.
6.
7.

Click the Line
button.
Specify a point at top left outside the circle.
Move the pointer horizontally and notice the
Horizontal constraint symbol.
Click outside the circle. Press Esc to deactivate
the Line tool.

8.

9. Click the Trim
button on the Modify panel.
10. Click on the portions of the sketch, as shown
below.
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16. Move the cursor outward from the arc and click.

11. Apply dimensions to the sketch (Radius=0.63,
vertical length=1.102). To apply the vertical
length dimension, activate the Dimension tool
and select the horizontal line. Move the pointer
downward and place the cursor on the bottom
quadrant point of the arc. Click when the
symbol appears. Move the pointer toward left
and click to place the dimension.

17. Click the Dimension button on the Constrain
panel.
18. Select the start point of the slot arc.
19. Select the center point of the slot arc.
20. Select the end point of the slot arc.

12. Click Rectangle > Slot Center Point Arc
on
the Create panel.
13. Select the origin as the center point.
14. Move the cursor outside and click in the first
quadrant of the circle to specify the start point of
the slot arc.
15. Move the cursor and click in the fourth quadrant
of the circle to specify the end point of the slot
arc.
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26. Click the Symmetric
button on the
Constrain panel.
27. Select the end caps of the slot.
28. Select the construction line; the slot is made
symmetric about the construction line.

21. Place the angular dimension of the slot; the Edit
Dimension box appears.
22. Enter 30 in the Edit Dimension box and click the
green check.

29. Apply other dimensions to the slot.
23. Click the Construction button on the Format
panel.

24. Click the Line
button on the Create panel.
25. Draw a horizontal line passing through the
origin.
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30. Click the Circular Pattern button on the Pattern
panel; the Circular Pattern dialog appears.

31. Select all the elements of the slot by creating a
selection window.
37. Click the Finish Sketch button on the ribbon.
38. Extrude the sketch up to 0.236 distance (See
Chapter 2, Tutorial 1, Creating the Base Feature
section to learn how to create a new project).

32. Click the cursor button located on the right-side
on the dialog.
33. Select the origin point of the sketch axis point.
34. Enter 4 in the Count box and 180 in the Angle
box.
35. Click the Flip button.

Adding the Second feature
1.

Create a sketch on the back face of the model
(use the Orbit tool available on the Navigate bar
to rotate the model).

2.

Extrude the sketch up to 0.078 distance.

The preview of the circular pattern appears.
36. Click OK to create the circular pattern.
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Now, you need to specify the concentric reference.
4.

Select the cylindrical face of the model; the hole
is made concentric to the model.

5.

Click OK on the dialog; the counterbore hole is
created.

Creating a Counterbore Hole
In this section, you will create a counterbore hole
concentric to the cylindrical face.
1.

Click the Hole button on the Modify panel; the
Hole dialog appears.

2.

Set the parameters in the Hole dialog, as shown
in figure.

Creating a Threaded hole
In this section, you will create a hole using a sketch
point.

1.

3.

Click on the front face of the model; the preview
of the hole appears.
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2.

Click the Start 2D Sketch
button and select
front face of the model.
Click the Point button on the Create panel.

3.

Place the point on the front face of the model.

Part 2: Autodesk Inventor Basics

4.
5.
6.

Click the Horizontal
button on the
Constrain panel.
Select the point and sketch origin; the point
becomes horizontal to the origin.
Create a horizontal dimension of 0.354 between
point and origin.

13. Select the Tapped Hole option.

14. Set the Thread Type to ANSI Unified Screw
Threads.

15. Set the Size to 0.073.

7.
8.
9.

Click Finish Sketch.
Click the Hole button on the Modify panel; the
Hole dialog appears.
On the Hole dialog, set Placement to From
Sketch.

16. Set the Designation to 1-64 UNC.

17. Select the Full Depth option.

18. Set the Direction to Right Hand.

10. Select the Counterbore option.
19. Click OK to create the hole.

11. Set the Counterbore Diameter to 0.118.
12. Set the Counterbore Depth to 0.039.
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Creating a Circular Pattern
1.

2.

Click the Circular Pattern button on the Pattern
panel; the Circular Pattern dialog appears.

3.

Select the threaded hole created in the previous
section.
Click the Rotation Axis button on the dialog.

4.

Select the outer cylindrical face of the model.

5.

Enter 6 in the Occurrence box and 360 in the
Angle box.
Click OK to create the circular pattern.

6.

3.

Select the cylindrical face of the counterbore
hole located at the center.

4.

Select the circular edge of the counterbore hole.

5.

Enter 0.039 in the Distance box and 30 in the
Angle box.

Creating Chamfers
1.
2.

Click the Chamfer
button on the Modify
panel.
Click the Distance and Angle button on the
dialog.
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6.
7.

Click OK to create the chamfer.
Save the model and close it.

5.

Click the Offset button on the Modify panel.

6.

Select the sketch and specify the offset position.

7.

Click the Line
button and draw lines closing
the offset sketch.

TUTORIAL 2
In this tutorial, you will create the model shown in
figure.

Creating the first feature
1.

2.

Open a new Inventor part file using the
Standard.ipt template (See Chapter 2, Tutorial 3,
Starting a New Part File section).
On the ribbon, click 3D Model > Sketch > Start

3.

2D Sketch
.
Select the YZ plane.

4.

Draw an L-shaped sketch using the Line
and dimension it.

tool
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Creating the Shell feature
8.

You can create a shell feature by removing a face of
the model and applying thickness to other faces.

Add the offset dimension to the sketch.

1.
2.

Click 3D Model > Modify > Shell
ribbon; the Shell dialog appears.
Set Thickness to 0.197.

on the

Now, you need to select the faces to remove.

9.

3.

Select the top face and the back face of the
model.

4.

Select the front face and the bottom face of the
model.

Click Finish Sketch.

10. Click 3D Model > Create > Extrude
on the
ribbon.
11. Select the Symmetric option from the Mini
toolbar.

12. Set the Distance to 1.575.
13. Click OK to create the first feature.
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5.

Click OK to shell the model.
2.
3.

Select the front face of the model.
Click Sketch > Create > Rectangle drop-down >
Slot Center to Center on the ribbon.

4.

Draw a slot by selecting the first, second, and
third points. Make sure that the second point is
coincident with the lower horizontal edge.

5.

Apply dimensions to the slot.

Creating the Third feature
1.

Click 3D Model > Sketch > Start 2D Sketch on
the ribbon.
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12. Click OK to create the feature.
6.
7.

Click Finish Sketch.
Click 3D Model > Create > Extrude on the
ribbon.
8. Select the sketch.
9. Select the To option from the Extents dropdown.
10. Select the back face of the model.

Creating a Cut Feature
1.

11. Click the Join button on the dialog.
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Create the sketch on the front face of the model,
as shown below.
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Creating the Rib Feature
2.
3.
4.
5.
6.

7.

In this section, you will create a rib feature at the
middle of the model. To do this, you must create a
mid-plane.

Finish the sketch.
Click 3D Model > Create > Extrude on the
ribbon.
Select the sketch.
Select the All option from the Extents dropdown.
Click the Cut button on the dialog.

Click OK to create the cut feature.
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1.

To create a mid-plane, click 3D Model > Work
Features > Plane > Midplane between Two
Parallel Planes on the ribbon.

2.
3.

Select the right face of the model.
Select the left face of the model; the midplane is
created.
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4.
5.
6.

Click 3D Model > Sketch > Start 2D Sketch on
the ribbon.
Select the mid plane.
Click the Slice Graphics button at the bottom of
the window.

9.

Finish the sketch.

10. Click 3D Model > Create > Rib
ribbon; the Rib dialog appears.
11. Select the sketch.
12. Click the Parallel to Sketch Plane
on the dialog.

7.

Click Sketch > Create > Project Geometry >
Project Cut Edges on the ribbon; the edges cut
by the sketch plane are projected.

13. Click the Direction 1
14. Set Thickness to 0.197.
15. Click the To Next

on the

button

button.

button.

16. Click the Symmetric
button below the
Thickness box.
17. Click OK to create the rib feature.

8.

Draw the sketch, as shown below.

18. To hide the midplane, select it and right-click.
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19. Click Visibility on the Marking Menu; the plane
will be hidden.

3.
4.
5.

20. Save the model and close it.

6.

TUTORIAL 3

Click the Circle Center Point
button.
Select a point on the left portion of the
horizontal axis
Move the cursor outward and click to create a
circle.
On the ribbon, click Sketch > Format >
Centerline

In this tutorial, you will create a helical spring using
the Coil tool.

7.
8.
9.
10.
11.
12.
13.

.

Click the Line
button.
Select the origin point of the sketch, move the
cursor upward, and click to create a centreline.
On the ribbon, click Sketch > Constrain >
Dimension.
Add the diameter dimension to the circle, as
shown.
Select the centreline and circle.
Move the pointer downward and click.
Type 1.575 and press Enter.

Creating the Coil
1.

2.

Open a new Inventor file using the Standard.ipt
template (See Chapter 2, Tutorial 3, Starting a
New Part File section).
Click the Start 2D sketch button on the ribbon,
and select the XY Plane.

14. Finish the sketch.
15. To create a coil, click 3D Model > Create > Coil
on the ribbon; the Coil dialog appears.
In addition, the profile is automatically selected.
Now, you need to select the axis of the coil.
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16. Select the centerline as the axis. Click the

21. Click OK to create the coil.

Reverse Axis
button on the Coil dialog, if
the coil preview is downwards.

17. Click the Coil Size tab on the dialog.
18. In the Coil Size tab, specify the settings as given
next.

22. Save the model as Coil.ipt and close the file.

TUTORIAL 4
In this tutorial, you create a shampoo bottle using
the Loft, Extrude, and Coil tools.

19. Click the Coil Ends tab on the dialog.
20. Specify the settings in the Coil Ends tab, as
given next.

Creating the First Section and Rails
To create a swept feature, you need to create
sections and guide curves.
1.
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Open a new Part file (See Chapter 2, Tutorial 3,
Starting a New Part File section).
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2.
3.

4.
5.

Click 3D Model > Sketch > Start 2D Sketch on
the ribbon.
Select the XZ plane.

Click Sketch > Create > Circle > Ellipse
the ribbon.
Draw the ellipse by selecting the points, as
shown.

11. Click Finish Sketch.
12. Click 3D Model > Sketch > Start 2D Sketch on
the ribbon.
13. Select the YZ plane from the graphics window.
14. Click Sketch > Create > Line> Spline
Interpolation on the ribbon.

on

6.

On the ribbon, click Sketch > Constrain >
Dimension.
7. Select the ellipse, move the cursor downward,
and click.
8. Type 1.968 and press Enter.
9. Select the ellipse, move the cursor toward left,
and click.
10. Type 0.984 and press Enter.

15. Select a point on the horizontal axis of the
sketch; a rubber band curve is attached to the
cursor

16. Move the cursor up and specify the second point
of the spline; a curve is attached to cursor.
17. Move the cursor up and specify the third point.
18. Likewise, specify the other points of the spline,
as shown.
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19. Click the right mouse button and select Create.
The spline will be similar to the one shown in
figure.

23. On the ribbon, click Sketch > Constrain >
Vertical .
24. Select the lower end points of the vertical
construction line and the spline.
20. Right click and select Create Line from the
Marking Menu.
21. On the ribbon, click Sketch > Format >
Construction .
22. Select the origin point of the sketch, move the
pointer vertically upward and click to create a
vertical construction line.

25. On the ribbon, click Sketch > Constrain >
Dimension.
26. Select the lower end points of the construction
line and spline.
27. Move the cursor downward and click.
28. Type the 1.968 in the Edit Dimension box and
press Enter.

395

Part 2: Autodesk Inventor Basics
34. Move the pointer toward right and click.
35. Type 8.858 in the Edit Dimension box and press
Enter.

29. Select the second point of the spline and the
construction line.
30. Move the cursor and click to place the
dimension.
31. Type 2.362 in the Edit Dimension box and press
Enter.

36. Likewise, create other dimensions, as shown.

32. Apply the other horizontal dimensions to the
spline, as shown in figure.

37. Click Sketch > Pattern > Mirror
on the
ribbon; the Mirror dialog appears.
38. Select the spline. Make sure that you select the
curve and not the points.
39. Click Mirror line on the Mirror dialog, and then
select the construction line.
40. Click Apply, and then click Done.

33. Select the origin point of the sketch and the top
end point of the spline.
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4.
5.

Click OK
.
On the ribbon, click the 3D Model > Sketch >
Start 2D Sketch.
6. Select the newly created datum plane.
7. Right click and select Center Point Circle from
the Marking Menu.
8. Select the origin point, move the cursor outside,
and click to create a circle.
9. Right click and select OK.
10. Right click and select General Dimension from
the Marking Menu.
11. Select the circle, move the cursor outward, and
click.
12. Type 1.574 and press Enter.

41. Click Finish Sketch.

Creating the second section
1.

Click 3D Model > Work Features > Plane >
Offset from Plane on the ribbon.

2.

Select the XZ plane from the Browser window.

13. Click Finish Sketch on the ribbon.

Creating the Loft feature

3.

Enter 8.858 in the Distance box.
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1.

To create a loft feature, click 3D Model > Create

2.

> Loft
on the ribbon; the Loft dialog appears.
Select the Rails option from the dialog.
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3.

Click Click to add in the Sections group and
select the circle.

Creating the Extruded feature
1.

Right click and select New Sketch from the
Marking Menu.
2. Select the plane locate at the top of the sweep
feature.
3. Right click and select Center Point Circle from
the Marking Menu.
4. Select the origin point, move the cursor outside,
and click to create a circle.
5. Right click and select OK.
6. Right click and select General Dimension from
the Marking Menu.
7. Select the circle, move the cursor outward, and
click.
8. Type 1.574 and press Enter.
9. Click Finish Sketch on the ribbon.
10. Click the Extrude button on the Create panel.
11. Extrude the circle up to 1 in.
4.
5.
6.
7.
8.

Select the ellipse.
Click Click to add in the Rails group.
Select the first rail.
Select the second rail.
Click OK to create the loft feature.
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4.

Creating the Emboss feature
1.
2.

5.

Click 3D Model > Work Features > Plane >
Offset from Plane on the ribbon.
Select the YZ plane from the Browser window.

6.
7.

3.

Enter 2 in the Distance box and click OK

.
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Click 3D Model > Sketch > Start 2D Sketch on
the ribbon.
Select the newly created datum plane
Click Sketch > Create > Circle > Ellipse
the ribbon.
Draw the ellipse by selecting the points, as
shown.

on
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8.
9.
10.
11.
12.
13.
14.
15.
16.
17.
18.
19.

20.

21. Click 3D Model > Create > Emboss
on the
ribbon; the Emboss dialog appears.
22. Select the sketch, if not already selected.

On the ribbon, click Sketch > Constrain >
Dimension.
Select the ellipse, move the cursor downward,
and click
Type 2 and press Enter.
Select the ellipse, move the cursor toward left,
and click.
Type 1.35 and press Enter.
Select the origin point of the sketch and the
center point of the ellipse.
Move the cursor toward left and click to place
the dimension between the selected point.
Type 2.55 and press Enter.
Right click and select Line from the Marking
Menu.
Right click and select Construction from the
Marking Menu.
Select the origin point of the sketch and the
center point of the ellipse.
Right click and select OK; a construction line is
created between the sketch origin and the
ellipse. Also, the sketch is fully-constrained.
Click Finish Sketch.

23. Click the Engrave from Face
button on
the dialog.
24. Set the Depth to 0.125.
25. Click OK to create the embossed feature.

Mirroring the Emboss feature
1.

Click 3D Model > Pattern > Mirror on the
ribbon.

2.

Select the emboss feature from the model
geometry.
On the Mirror dialog, click the Mirror Plane
button, and then select the YZ Plane from the
Browser window.
Click OK to mirror the emboss feature.

3.

4.
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Creating Fillets
1.

3.

Click 3D Model > Modify > Fillet on the ribbon;
the Fillet dialog appears.
Click on the bottom and top edges of the swept
feature.
Set Radius to 0.2.

4.
5.

Click Click to add on the Fillet dialog.
Set Radius to 0.04.

2.

Shelling the Model
1.
2.
3.

6.

Select the edges of the emboss features, and click
OK.
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Click 3D Model > Modify > Shell
on the
ribbon; the Shell dialog appears.
Set Thickness to 0.03.
Select the top face of the cylindrical feature.
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4.

2.

Click the Slice Graphics icon located at the
bottom of the window.

3.
4.

On the ribbon, click Sketch > Create > Line.
Right click and select Centerline from the
Marking Menu.
Select the origin point of the sketch, move the
cursor vertically upward and click to create a
vertical centreline. Press Esc.
Deactivate the Centerline icon on the Format
panel.
Right click and select Create Line from the
Marking Menu.
Right click and select Construction from the
Marking Menu.
Create a horizontal construction line, as shown.

Click OK to create the shell.

5.

6.
7.
8.
9.

Adding Threads
1.

Select the YZ Plane, and then click Create
Sketch.
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10. Deactivate the Construction icon on the Format
panel of the Sketch ribbon tab.
11. On the ribbon, click Sketch > Create > Line.
12. Create a closed profile, as shown.

18. Draw the thread profile.

13. On the ribbon, click Sketch > Constrain >
Symmetric
.
14. Select the two inclined lines of the sketch, and
then select the construction line; the two inclined
lines are made symmetric about the construction
line.

19. On the ribbon, click Sketch > Create > Fillet
20. Type 0.04 in the 2D Fillet box.
21. Make sure that the Equal
button is active on
the 2D Fillet box.
22. Select the two corners of the sketch, as shown.

15. Click the Dimension button on the Constrain
panel.
16. Select the two inclined lines, move the cursor
horizontally toward left and click.
17. Type 60 in the Edit Dimension box and press
Enter.

23. Close the 2D Fillet dialog box.
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29. Click OK.

24. Click Finish Sketch on the ribbon.
25. On the ribbon, click 3D Model > Create > Coil
30. In the Browser Window, right click on the YZ
Plane, and then select New Sketch.
31. On the ribbon, click Sketch > Create > Project

; the closed profile of the sketch is selected,
automatically.
26. Select the axis of the coil.

Cut Edges > Project Geometry
.
32. Select the edges of the end face of the thread.

27. On the dialog, click the Coil Size tab and select
Type > Pitch and Revolution.
28. Type-in 0.275 and 2 in the Pitch and Revolution
boxes, respectively.

33. Draw a straight line connecting the end points of
the projected elements.
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Note that you need the reverse the direction of
revolution.

34. Click Finish Sketch.
35. Activate the Revolve tool and click on the
vertical line of the sketch.
36. On the dialog, select Extents > Angle, and then
type-in 100 in the Angle1 box.
37. Click the Direction 1 button.

40. Save the model.

TUTORIAL 5
In this tutorial, you create a chair, as shown.

38. Click OK.

Creating a 3D Sketch
1.

2.

39. Likewise, blend the other end of the thread.

3.
405

Open a new Inventor file using the Standard.ipt
template (See Chapter 2, Tutorial 3, Starting a
New Part File section).
Click the Home icon located above the
ViewCube. This changes the view orientation to
Home.

On the ribbon, click 3D Model > Sketch > Start
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2D Sketch > Start 3D Sketch.

4.

On the 3D Sketch tab of the ribbon, click Draw
> Line.

5.

Expand the Draw panel on the ribbon and
activate the Precise Input option.

6.

On the Precise Input toolbar, click the Reset to
Origin button.
Select the Relative option from the drop-down
available on the Precise Input toolbar.

7.

12. Type-in 12 in the X box and press Tab on your
keyboard.
13. Likewise, type-in 0 in the Y and Z boxes. Press
Enter to specify the second point.

14. Type-in 0, 0, and 20 in the X, Y, and Z boxes,
respectively. Press Enter.

15. Type-in 0,18, 0 in the X, Y, and Z boxes,
respectively. Press Enter.

8.

On the Precise Input toolbar, click in the X box
and type 0.
9. Press the Tab key and type 0 in the Y box.
10. Likewise, type 0 in the Z box.
11. Press Enter to specify the first point.
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16. Type-in 0, 0 and -22 in the X, Y and Z boxes,
respectively. Press Enter.

18. Type-in -12, 0, and 0 in the X, Y, and Z boxes,
respectively. Press Enter.

17. Type-in 0, 18, and 0 in the X, Y, and Z boxes,
respectively. Press Enter.

19. Click the right mouse button and select OK.
20. On the 3D Sketch tab of the ribbon, click Pattern
> Mirror.
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25. Type-in 3 in the Bend dialog and select the
intersecting lines, as shown in figure.

21. Drag a selection box and select all the sketch
elements.

22. Click the Mirror Plane button on the dialog, and
then select YZ Plane from the Browser window.
23. Click Apply and Done on the dialog.

26. Likewise, bend the other corners of the 3D
sketch.

24. On the ribbon, click 3D Sketch > Draw > Bend.
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27. Click the right mouse button and select OK.
28. On the ribbon, click 3D Sketch > Constrain >
Fix .
29. Select the origin point of the sketch.
31. Click Finish Sketch on the ribbon.
32. On ribbon, click 3D Model > Work Features >
Plane > Normal to Axis through Point.

33. Click on the horizontal line of the sketch and its
end point.

30. Add dimensions to fully define the sketch.

34. Click 3D Model > Sketch > Start 2D Sketch on
the ribbon.
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Creating the Sweep feature
35. Select the newly created plane.
36. Create two concentric circles of 1.250 and 1
diameters.

1.

On the ribbon, click 3D Model > Create >
Sweep.

2.

Zoom into the circular sketch and click in the
outer loop.

3.

Click on the 3D sketch to define the sweep path.

4.

Click OK to sweep the profile.

37. Add dimensions from the sketch origin to
position the circles.

38. Click Finish Sketch.
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10. On the Extrude dialog, select Extents >
Between.
11. Click on the tubes on both sides of the sketch.
5.

Start a sketch on the YZ Plane.

6.

Click the Slice Graphics icon at the bottom of
the graphics window.
Draw two concentric circles and dimension
them.

7.

12. On the Extrude dialog, uncheck the Check to
terminate feature on the extended face options.

8.
9.

Click Finish Sketch.
Activate the Extrude tool and click in the outer
loop of the sketch.
This will avoid the extruded feature from
terminating on the extended portion of the
selected surface.
13. Click OK to extrude the sketch.
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Creating the Along Curve pattern
1.

On the Browser window, click the right mouse
button on the 3D Sketch and select Visibility;
the 3D sketch is displayed.

5.

8.

Type-in 3 and 23 in the Column Count and
Column Spacing boxes, respectively.
Select Spacing > Distance from the drop-down
menu.
Click the double-arrow button located at the
bottom of the dialog. This expands the dialog.
Set the Orientation to Direction 1.

9.

Click OK to pattern the extruded feature.

6.
7.

2.

On the ribbon, click 3D Model > Pattern >
Rectangular Pattern.

3.
4.

Click on the extrude feature.
On the Rectangular Pattern dialog, click the
Direction 1 button, and then click on the 3D
sketch.
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10. On the Browser window, click the right mouse
button on the 3D sketch and select Visibility.
This hides the 3D sketch.

On the ribbon, click 3D Model > Work Features
> Plane.

2.

On the Browser window, click the XZ Plane. A
plane appears on the XZ Plane.
Click on top portion of the extruded feature. A
plane appears tangent to the extruded feature.

3.

Place a point on the sketch plane and add
dimensions to position it.

6.
7.

Click Finish Sketch.
On the ribbon, click 3D Model > Freeform >

Box
.
Select the plane tangent to the extruded feature.
Select the sketch point to define the location of
the freeform box.
10. Click and drag the side-arrow of the freeform
box.

Creating the Freeform feature
1.

5.

8.
9.

11. Click and drag the front arrow of the freeform
box.

4.

Start a sketch on the new plane.
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14. Click OK to create the freeform shape.

12. Click and drag the top arrow to increase the
height of the freeform box.

Editing the Freeform Shape

13. On the Box dialog, type-in 4, 1, and 2 in the
Faces boxes, respectively.
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1.

On the ribbon, click Freeform > Edit > Edit

2.

Form
.
Hold the Ctrl key and click on top faces of the
freeform shape.
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8.

3.
4.

Click on the arrow pointing upwards.
Drag it downwards.

5.
6.

Click OK on the dialog.
On the ribbon, click Freeform > Edit > Edit

7.

Form
.
Hold the Ctrl key and click on the two edges at
the front.

Drag the vertical arrow downwards.

9. Click OK on the Edit Form dialog.
10. Click Finish Freeform on the ribbon.

Create another Freeform box
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1.

On the ribbon, click 3D Model > Work Features

2.
3.

> Plane
.
On the Browser window, click the XY Plane.
Click on the vertical portion of the sweep feature
to create a plane tangent to it.
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Length, Width, and Height boxes, respectively.
10. Click OK, and then click Finish Freeform.

11. Save and close the file.

TUTORIAL 6
4.
5.

In this tutorial, you create a bolt.

Start a sketch on the new plane.
Place a point and add dimensions to it.

Start a new part file
1.

2.
3.
4.
6.

Click Finish Sketch.

7.
8.

Activate the Freeform Box
tool.
Select the new plane and click on the sketch
point.
On the Box dialog, type-in 27, 16, and 3 in the

9.

5.
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Start a new part file using the Standard.ipt
template (See Chapter 2, Tutorial 3, Starting a
New Part File section).
On the ribbon, click 3D Model > Primitives >
Primitive drop-down > Cylinder
.
Click on the YZ Plane.
Click the origin point of the sketch to define the
center point of the circle.
Move the pointer and type-in 0.75 in the box,
and then press Enter.
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6.

Type-in 3 in the Distance box and press Enter.

4.

Type-in 6 in the Polygon dialog.

5.

Move the pointer vertically upward. You will
notice that a dotted trace line appears between
the origin point and the pointer.

6.
7.
8.

Click to create the polygon.
Click Done on the dialog.
On the ribbon, click the Sketch > Format >

9.

Construction .
Activate the Line tool and select the vertices of
the polygon.

Creating the second feature
1.

Start a sketch on the YZ Plane.

2.

On the ribbon, click Sketch > Create >
Rectangle drop-down > Polygon.

3.

Click the sketch origin.
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Adding Threads
1.
2.
3.

On the ribbon, click 3D Model > Modify >
Thread .
Click on the cylindrical face of the model
geometry.
On the Thread dialog, uncheck the Full Length
option and type-in 1.5 in the Length box.

10. Activate the Dimension tool and create a
dimension, as in figure.

4.

Click the Specification tab to specify the thread
settings.

5.

Click OK to add the thread.

11. Finish the sketch.
12. Activate the Extrude tool and select the sketch, if
not already selected.
13. On the Extrude dialog, type-in 0.5 in the
Distance box.
14. Use the Direction 1
or Direction 2
buttons to make sure that the polygon is
extruded toward left.
15. Click OK.
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Creating iParts
The iParts feature allow you to design a part with
different variations, sizes, materials and other
attributes. Now, you will create different variations
of the bolt created in the previous section.
1.

On the ribbon, click Manage > Parameters >
Parameters. This opens the Parameters dialog.

2.

On the Parameters dialog, click in the first cell of
the Model Parameters table, and type-in
Diameter.

3.

Likewise, change the names of other parameters.

4.
5.

Click Done on the Parameters dialog.
Click the right mouse button in the graphics
window and select Dimension Display >
Expression.

419

6.

On the Browser window, click the right mouse
button on the Extrusion1 and select Show
Dimensions. You will notice that the
dimensions are shown along with the names.

7.

On the ribbon, click Manage > Author > Create
iPart.
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values (5, 0.75, and 3) in the Height, Headwidth,
and Threadlength boxes. This creates the second
version of the bolt.

This opens the iPart Author dialog. In this dialog,
you will define the parameters to create other
versions of the model geometry.

11. In the third row of the table, type-in new values
in (2, 0.75, and 3) the Headsize, Headwidth, and
Threadlength boxes. This creates the third
version of the bolt.

Now, you have to set the default version of the bolt.
The table at the bottom of this dialog shows the
parameters for the iPart factory. You will notice that
the renamed parameters are automatically added to
the table. If you want to add more parameters to the
table, then select them from the section located at the
left side. Click the arrow button pointing towards
right. Likewise, if you want to remove a parameter
from the table, then select it from the right side
section and click the arrow pointing toward left.

12. Click the right mouse button on the third row of
the table and select Set As Default Row.

8.

Now, click the right mouse button on the table
and select Insert Row. Notice that a new row is
added to the table.

13. Click OK to close the dialog. Notice that the
default version of the bolt changes.

9.

Likewise, insert another row.
In the Bowser Bar, you will notice that the Table
item is added.
14. Expand the Table item in the Browser Window

10. In the second row of the table, type-in new
420
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to view the different variations of the iPart.
Notice that the activated version of the iPart is
designated by a check mark.

If you want to edit the table using a spreadsheet,
then click the right mouse button on Table and
select Edit via Spreadsheet. Click OK on the
message box.

15. Double-click on any other version of the iPart to
activate it.

Now, modify the values in the spreadsheet and close
it. A message pops up asking you to save the
changes. Click Save to save the changes.

If you want to save anyone of the iPart versions as a
separate part file, then click the right mouse button
on it and select Generate Files.

If you want to make changes to any version of the
bolt, then click the right mouse button on it and
select Edit table.

16. Save and close the file.

TUTORIAL 7
In this tutorial, you create a plastic casing.
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7.
8.
9.

Creating the First Feature
1.

2.
3.
4.
5.

Select the right endpoint of the horizontal line.
Move the cursor vertically downwards and click
to define the second point.
Move the pointer towards right and click on the
horizontal axis line.

Open a new Autodesk Inventor part file using
the Standard.ipt template (See Chapter 2,
Tutorial 3, Starting a New Part File section).
On the ribbon, click 3D Model > Sketch > Start
2D Sketch.
Select the XZ Plane.
On the ribbon, click Sketch > Create > Line.
Click in the second quadrant, move the cursor
horizontally toward right, and then click to
create a horizontal line, as shown.

10. Likewise, create another three-point arc and
horizontal line, as shown.

6.

On the ribbon, click Sketch > Create > Arc dropdown > Arc Three Point.
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11. Create a vertical construction from the origin
point.

15. Add dimensions to the sketch. Also, add the
Vertical constrain between the origin and center
point of the arc.

12. On the ribbon, click Sketch > Constrain >
Symmetric
.
13. Select the two arcs and the construction

16. Click Finish Sketch.
17. Click the 3D Model > Create > Extrude on the
ribbon; the Extrude dialog appears.
18. Set the Distance to 3.15.
19. Click the More tab and set the Taper angle to -10.
20. Click the OK button.

14. Likewise, create a horizontal construction line
from the origin point, and then make the two
horizontal lines symmetric about it.
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Creating the Extruded surface
1.

Click 3D Model > Sketch > Start 2D Sketch on
the ribbon, and then select the XY Plane.

6.

Click Finish Sketch.

7.

Click the Extrude

8.
9.

Select the sketch, if not already selected.
On the Extrude dialog, set the Output type to
Surface.

button.

10. Set the Extents type to Distance.
26. Select the Symmetric button.
27. Extrude the sketch up to 17 in distance.

2.
3.
4.

Click the Slice Graphics
button at the bottom
of the window or press F7 on the keyboard.
Click Sketch > Create > Line > Spline
Interpolation on the ribbon.
Create a spline, as shown in figure (See Chapter
5, Tutorial 4, Creating the First Section and Rails
section).

Replacing the top face of the model with
the surface
1.
5.

Apply dimensions to the spline, as shown
below.

On the Surface panel of the 3D Model ribbon,
click the Replace Face
Face dialog appears.

button; the Replace

Now, you need to select the face to be replaced.
2.

424

Select the top face of the model.
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Next, you need to select the replacement face or
surface.
3.

Click the New Faces button on the dialog and
select the extruded surface.

You can also use a solid face to replace an existing
face.
4.

Click OK to replace the top face with a surface.

4.

Set the Radius to 1.5 and click the OK button to
create the face fillet.

5.

Hide the extruded surface by clicking the right
mouse button on it in the Browser Window and
un-checking Visibility.

5.

Likewise, apply a face fillet of 1.5 radius
between top surface and the back inclined face
of the model.

Creating a Face fillet
1.
2.

Click the Fillet button on the Modify panel.
Click the Face Fillet button on the Fillet dialog.

3.

Select the top surface as the first face and the
inclined front face as the second face.

Creating a Variable Radius fillet
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1.

Click the Fillet

button on the Modify panel.

2.

Click the Variable tab on the Fillet dialog.
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6.

3.

Set the radii of the Start, End, Point 1 and Point
2 as shown below.

Select the curved edge on the model; the
preview of the fillet appears.

You can also specify the fillet continuity type. By
default, the Tangent Fillet type is specified.

4.

6.

Select Smooth (G2) Fillet type from the Edges
section.

7.

Make sure that the Smooth radius transition
option is checked.
Click OK to create the variable fillet.

Select a point on the fillet, as shown in figure.

8.

5.

Select another point the fillet, as shown in figure.
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Mirroring the fillet
4.
9.
10.
11.
12.
13.

Click the Mirror
button on the Pattern panel;
the Mirror dialog appears.
Select the variable radius fillet from the model.
Click the Mirror Plane button on the dialog.
Select the XY Plane from the Browser window.
Click OK to mirror the fillet.

Creating the Boss Features
1.

Click 3D Model > Sketch > Start 2D Sketch on
the ribbon and select the bottom face of the
model.

2.

Activate Construction
button on the Format
panel.
On the ribbon, click Sketch > Create >
Rectangle drop-down > Rectangle Two Point
Center.

3.

Shelling the Model
1.

Click the Shell
button on the Modify panel;
the Shell dialog appears.

2.

Click the Inside
button on the dialog and set
the Thickness to 0.2 in.
Rotate the model and select the bottom face.

3.

Click OK.
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4.
5.
6.
7.
8.

Select the origin point of the sketch.
Move the cursor outward and click to create the
rectangle.
Apply dimensions to the rectangle.
Click the Point button on the Create panel.
Place four points at corners of the rectangle.

13. Select the From Sketch option from the
Placement group.
14. Select the points located on the corners of the
rectangle, if not already selected; the bosses are
placed at the selected points.

9.

Click Finish Sketch.

15. Click the Thread tab and specify the parameters,
as shown below.

Now, you will create bosses by selecting the points
created in the sketch.
10. On the ribbon, click the Show Panels
button
located at the right side, and then select Plastic
Part from the menu.
11. Click the Boss button on the Plastic Part panel;
the Boss dialog appears.

16. Click the Ribs tab and check the Stiffening Ribs
option.
17. Set the rib parameters, as shown next.
12. Click the Thread button on the dialog.
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Creating the Lip feature
1.
2.

Click the Lip
button on the Plastic Part panel
of the ribbon; the Lip dialog appears.
Click the Lip button on the dialog.

3.

Select the outer edge of the bottom face.

4.

Click the Guide Face button on the dialog and
select the bottom face of the model.

18. Expand the Fillet options.

19. Specify the fillet options, as shown below.

20. Click OK to create the bosses with ribs.
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2.

Click the corner point of the ViewCube, as
shown.

3.

On the ribbon, click 3D Model > Sketch >>
Start 2D Sketch.
Select the inclined face, as shown.

4.
5.

6.

Click the Lip tab and set the parameters, as
shown below.

Create the sketch using the Rectangle Two
Point Center and Line tools.

6.
7.

Click Finish Sketch.
Click the Grill button on the Plastic Part panel.

8.

Select the rectangle as the boundary and set the
Boundary parameters, as shown below.

Click OK to create the lip.

Creating the Grill Feature
1.

5.

Click the Home button located at the top of the
ViewCube.
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12. Save the model as Plastic Cover.ipt.

Creating Ruled Surface

9.

1.

Click 3D Model > Surface > Ruled Surface
on the ribbon and select the bottom edge of the
model.

2.

Click the Normal
Surface dialog.

Click the Rib tab and select the horizontal lines.

10. Set the rib parameters, as shown below.

button on the Ruled

The preview of the ruled surface appears normal
to the selected edge.
You can click the Alternate All Faces
button
to change the direction of the ruled surface.

11. Click OK to create the grill.
3.
4.
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Type in 2 in the Distance box.
Click OK to create the ruled surface.
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6.
7.

On the Extrude dialog, select Extents dropdown > Distance from Face.
Select the curved face, as shown.

The ruled surface can be used as a parting split
while creating a mold.
5.

Close the part file without saving.

TUTORIAL 8 (The Distance from
Face option)
In this tutorial, you will learn to extrude a sketch
from a face.
1.
2.
3.

Download the Tutorial_8.ipt from the
companion website.
Open the downloaded file.
On the ribbon, click 3D Model tab > Create

4.

panel > Extrude
.
Click in the region of the sketch, as shown.

The sketch region is extruded from the selected
face.

8.

On the Extrude dialog, uncheck the Select to
terminate feature by extending the face
option.

5.

On the Extrude dialog, type 5 in the Distance1
box located in the Extents section.
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The Extrusion distances are 5 and 10 for region 1
and region 2, respectively.

9. Click OK on the Extrude dialog.
10. In the Browser Window, expand the Extrusion
feature, and then right click on the Sketch.
11. Select Visibility from the Shortcut Menu; the
sketch is displayed.

13. Save and close the part file.

12. Likewise, extrude the other two sketch regions,
as shown. Use the Distance from Face option to
define the extent.

TUTORIAL 9 (The Extent Start
option)
In this tutorial, you will learn use of the Extent Start
option in the Hole tool.
1.
2.
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Download the Tutorial_9.ipt from the
companion website.
Open the downloaded file.
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8.
9.

3.
4.
5.
6.

In the Browser Window, expand the Hole
feature, and then right click on the Sketch.
Select Edit Sketch from the Shortcut Menu; the
sketch is displayed.
Double click on the 0.19 dimension.
Type 0.12 in the Edit Dimension box, and then
click the green check.

In the Browser Window, right click on the Hole
feature, and then select Edit Feature.
On the Hole dialog, check the Extent Start
option located at the bottom right corner.

10. Click OK to close the dialog.
The Extent Start option removes the overlapping
material.

7.

Click Finish Sketch on the ribbon.

Notice that the fillet overlaps with the holes.

TUTORIAL 10 (Partial chamfer)
In this tutorial, you will learn to create partial
chamfer.
1.
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Start a new part file using the Standard(in).ipt
template.
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2.

3.

Create a 1 X 1 X 1 box using the Extrude tool, as
shown.

On the ribbon, click 3D Model tab > Modify
panel > Chamfer.

4.

On the Chamfer dialog, click the Partial tab, and
then click on the selected edge, as shown.

5.

On the Partial tab, select Set the Driven

7.

Dimension > To End.
Change the To Start and Chamfer values to 0.25
and 0.5, respectively.
Click OK.

8.

Save and close the part file.

6.
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Chapter 6: Sheet Metal
Modeling

Setting the Parameters of the Sheet Metal
part
1.

To set the parameters, click Sheet Metal > Setup
> Sheet Metal Defaults on the ribbon; the Sheet
Metal Defaults dialog appears.

This chapter will show you to:









Create a face feature
Create a Flange
Create a Contour Flange
Create a Corner Seam
Create Punches
Create a Bend Feature
Create Corner Rounds
Flat Pattern

TUTORIAL 1
In this tutorial, you create the sheet metal model
shown in figure.

This dialog displays the default preferences of the
sheet metal part such as sheet metal rule, thickness,
material, and unfold rule. You can change these
preferences as per your requirement.
2.

To edit the sheet metal rule, click the Edit Sheet
Metal Rule button on the dialog.

Starting a New Sheet metal File
1.
2.

To start a new sheet metal file, click Get Started
Launch > New on the ribbon.
On the Create New File dialog, click the Sheet
Metal.ipt icon, and then click Create.
In the Sheet tab of the Style and Standard Editor
dialog, you can set the sheet preferences such as
sheet thickness, material, flat pattern bend angle
representation, flat pattern punch representation
and gap size.
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7.
3.
4.

In the Sheet tab, set the Thickness to 0.12 and
leave all the default settings.
Click the Bend tab.

After setting the required preferences, click the
Save and Close button.

The Unfold Rule option on the Sheet Metal
Defaults dialog defines the folding/unfolding
method of the sheet metal part. To modify or set a
new Unfold Rule, click the Edit Unfold Rule button
on the Sheet Metal Defaults dialog.

In the Bend tab of this dialog, you can set the bend
preferences such as bend radius, bend relief shape
and size, and bend transition.

On the Style and Standard Editor dialog, select the
required Unfold Method.

You can define the Unfold rule by selecting the
Linear method (specifying the K factor), selecting a
Bend Table, or entering a custom equation. Click
Save and Close after setting the parameters.
5.
6.

Set the Relief Shape to Round.
Click the Corner tab.

8.

In the Corner tab, you can set the shape and size of
the corner relief to be applied at the corners.

Close the Sheet Metal Defaults dialog.

Creating the Base Feature
1.
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Create the sketch on the XZ Plane, as shown in
figure (Use the Rectangle Two Point Center
tool).
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2.
3.

4.

3.

Set the Distance to 4.

4.

Click on the Bend from the intersection of the
two outer faces icon in the Height Datum
section. This measures the flange height from
the outer face.

5.

Under the Bend Position section, click the
Inside of the Bend extents icon.

6.

Click OK to create the flange.

Click Finish Sketch.
To create the base component, click Sheet Metal
> Create > Face on the ribbon; the Face dialog
appears.

Click OK to create the tab feature.

Creating the flange
1.

To create the flange, click Sheet Metal > Create
> Flange on the ribbon; the Flange dialog
appears.

2.

Select the edge on the top face, as shown.

Creating the Contour Flange
1.
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Draw a sketch on the front face of the flange, as
shown in figure.
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2.
3.

4.
5.

Click Finish Sketch.
To create the contour flange, click Sheet Metal >
Create > Contour Flange on the ribbon; the
Contour Flange dialog appears.

Select the sketch from the model.
Select the edge on the left side of the top face;
the contour flange preview appears.
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6.

Select Edge from the Type drop-down.

7.

Click OK to create the contour flange.
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5.

Creating the Corner Seam
1.

To create the corner seam, click Sheet Metal>
Modify > Corner Seam on the ribbon; the
Corner Seam dialog appears.

6.

Click the Bend tab and make sure that the
Default option is selected in the Bend
Transition drop-down.
Click the Corner tab and set the Relief Shape to
Round.

You can also apply other types of relief using the
options in the Relief Shape drop-down.
7.
2.
3.

Rotate the model.
Select the two edges forming the corner.

4.

Set the parameters in the Shape tab of the
dialog, as shown.

Click OK.

Creating a Sheet Metal Punch iFeature
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1.

Open a new sheet metal file using the Sheet
Metal.ipt template.

2.

Create a sheet metal face of the dimensions 4x4.
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14. Move the cursor outward and click to define the
slot radius.

3.
4.

5.
6.

15. Click Dimension on the Constrain panel and
select the round end of the slot.
16. Click to display the Edit Dimension box.
17. Click the arrow button on the box and select List
Parameters from the shortcut menu; the
Parameters list appears.

Click Manage > Parameters > Parameters
on
the ribbon; the Parameters dialog appears.
Select the User Parameters row and click the
Add Numeric button on the dialog. This adds a
new row.

Enter Diameter in the new row.
Set Unit Type to in and type-in 0.04 in the
Equation box.

18. Select Diameter from the list and click the green
check on the Edit Dimension box.
7.

Likewise, create a parameter named Length and
specify its values, as shown below.

8.
9.

Click Done.
Click Sheet Metal > Sketch > Start 2D Sketch
on the ribbon.
Select the top face of the base feature.
On the ribbon, click Sketch > Create >
Rectangle drop-down > Slot Center to Center.
Click to define the first center point of the slot.
Move the cursor horizontally and click to define
the second center point of the slot.

10.
11.
12.
13.

19. Likewise, dimension the horizontal line of the
slot and set the parameter to Length.
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‘
26. On the dialog, select Type > Sheet Metal Punch
iFeature.
27. Select the cut feature from the model geometry
or from the Browser window. The parameters of
the cut feature appear in the Extract iFeature
dialog.

20. Click the Point button on the Create panel and
place it at the center of the slot.
21. Delete any projected edges (yellow lines) from
the sketch.
22. Click Finish Sketch.
23. Click Sheet Metal > Modify > Cut on the
ribbon; the Cut dialog appears.

Next, you must set the Size Parameters of the
iFeature.
28. Set the Limit of the Diameter value to Range.
The Specify Range dialog appears.

29. Set the values in the Specify Range dialog, as
shown below and click OK.

24. Accept the default values and click OK to create
the cut feature.

30. Set the Limit of the Length value to List. The
List Values dialog appears.
31. Click on Click here to add value and enter 0.2 as
value.

25. Click Manage > Author > Extract iFeature on
the ribbon; the Extract iFeature dialog appears.
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32. Likewise, type-in values in the List Values
dialog, as shown below.

38. Click Save on the dialog; the Save As dialog
appears.
39. Browse to the Punches folder and enter Custom
slot in the File name box.

33. Click OK.
34. Set the Limit of the Thickness value to Range.
The Specify Range dialog appears.
35. Set the values in the Specify Range dialog, as
shown below. Next, click OK.
40.
41.
42.
43.

Click Save and Yes.
Click File Menu > Save.
Save the sheet metal part file as Custom slot.
Switch to the sheet metal file of the current
tutorial.

Creating a Punched feature
1.
2.
3.

Next, you need to select the center point of the slot.
This point will be used while placing the slot.
36. Click the Select Sketch button on the Extract
iFeature dialog.

37. Select the sketch of the cut feature from the
Browser window.
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Start a sketch on the top face of the base sheet.
On the ribbon, click Sketch > Create > Point.
Place a point and add dimensions to it, as shown
below.
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8.

4.
5.

Click Finish Sketch.
To create the punch, click Sheet Metal > Modify
> Punch Tool on the ribbon; the PunchTool
Directory dialog appears.

6.

Select Custom slot.ide from the dialog and click
Open; the PunchTool dialog appears.

Set Length to 0.45 and Diameter to 0.1.

9. Click Refresh to preview the slot.
10. Click Finish to create the slot.

Note: If the slot is not oriented as shown in figure,
then click the Geometry tab on the PunchTool
dialog and type-in 90 in the Angle box.

Creating the Rectangular Pattern
7.

1.

Click the Size tab on the PunchTool dialog.
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Click Sheet Metal > Pattern > Rectangular
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Pattern on the ribbon. The Rectangular Pattern
dialog appears.

2.

Select the slot feature.

8.

Click the Direction 2 button on the dialog.

9.

Select the edge on the base feature, as shown
below.

You can also select multiple solid bodies from the
graphics window using the Pattern Solids
3.

4.

5.
6.
7.

option.

Click the Direction 1 button on the dialog.

Select the edge of the base feature, as shown
below.

10. Click the Flip
button in the Direction 2
section to make sure the arrow is pointed
toward right.
11. Select Spacing from the drop-down located in
the Direction 2 group.
12. Specify Column Count as 2.
13. Specify Column Span as 2.

Select Spacing from the drop-down located in
the Direction 1 group.
Specify Column Count as 5.
Specify Column Span as 0.6.
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14. Click OK to create the pattern.

3.
4.

Click Finish Sketch.
Click Sheet Metal > Create > Face on the ribbon
and create a face feature.

5.

Click Sheet Metal > Create > Bend on the
ribbon. The Bend dialog appears.

6.

Select the edges from the model, as shown
below.

Creating the Bend Feature
1.

2.

Create a plane parallel to the front face of the
flange feature. The offset distance is 6.3.

Create a sketch on the new work plane.
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Modify > Corner Round on the ribbon; the
Corner Round dialog appears.

7.

8.

9.

Make sure the Bend Extension is set to
perpendicular.

Set the Radius value to 0.2.
Set the Select Mode to Feature.

4.

Select the face feature from the model.

5.

Click OK to apply the rounds.

Click OK to create the bend feature.

Hide the work plane (Right-click on it and
uncheck Visibilty).

Applying a corner round
1.

2.
3.

To apply a corner round, click Sheet Metal >
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Creating Countersink holes
1.

Click Sheet Metal > Modify > Hole on the
ribbon; the Hole dialog appears.

2.
3.
4.

Set the Placement method to Concentric.
Set the hole type to Countersink.
Set the other parameters on the dialog, as shown
below.

5.

Click on the face of the flange, as shown below.
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6.

Select the corner round as the concentric
reference.

7.

Click Apply.

8.

Again, click on the flange face and select the
other corner round as the concentric reference.
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4.

9.

Leave the default settings of the dialog and click
OK to create the hem.

Click OK to create the countersink.

Creating Hem features
1.

To create the hem feature, click Sheet Metal >
Create > Hem on the ribbon; the Hem dialog
appears.

Mirroring the Features
1.
2.

2.

Set the Type to Single.

3.

Select the edge of the contour flange, as shown
below.

3.
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Click Mirror
on the Pattern panel; the Mirror
dialog appears.
Click >> at the bottom of the dialog and make
sure the Creation Method is set to Identical.

Select the features from the Browser window, as
shown below.
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You can set the order in which the bends will be
annotation.
2.
4.
5.
6.

Click the Origin YZ Plane button on the
dialog
Click OK to mirror the feature.
Create a corner seam between the mirrored
counter flange and flange.

Creating the Flat Pattern
1.

To create a flat pattern, click Sheet Metal > Flat
Pattern > Flat Pattern on the ribbon.
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Click the Bend Order Annotation button on the
Manage panel of the Flat Pattern tab. The order
in which the bends will be annotated is
displayed.
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3.

4.

To change the order of the bend annotation,
click on the balloon displayed on the bend. The
Bend Order Edit dialog appears.
Select the Bend Number check box and enter a
new number in the box.

5.
6.

Click OK to change the order.
To switch back to the folded view of the model,
click Go to Folded Part on the Folded Part
panel.

7.

Save the sheet metal part.

Creating 2D Drawing of the sheet metal
part
1.
2.
3.
4.
5.
6.

On the Quick Access toolbar, click the New
button.
On the Create New File dialog, double-click on
Standard.idw.
Activate the Base View tool.
Click Home icon on the ViewCube.
Leave the default settings on the Drawing View
dialog and click OK.
Click and drag the drawing view to top right
corner of the drawing sheet.
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7.

Likewise, create the front, and top views of the
sheet metal part.

8.

Activate the Base View tool and select Sheet
Metal View > Flat Pattern on the Drawing
View dialog.

9.

Place the flat pattern view below the Isometric
view.
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12. Likewise, select other bend lines on the flat
pattern. You can also drag a selection box to
select all the bend lines from the flat pattern
view.

10. To add bend notes to the flat pattern, click
Annotate > Feature Notes > Bend on the ribbon.

11. Click the horizontal bend line on the flat pattern
to add the bend note.
13. To add centerlines to the flat pattern view, click
the right mouse button on it and select
Automated Centerlines.

14. On the Automated Centerlines dialog, click the
Punches button under the Apply To section.
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20. Use the Retrieve Dimension and Dimension
tools to add dimensions to drawing.
21. Save and close the drawing and sheet metal
part.

15. Click OK to add centerlines to the flat pattern
view.

16. Likewise, add centerlines to other views on the
drawing sheet.
17. To add a punch note, click Annotate > Feature
Notes > Punch on the ribbon.

18. Zoom into the flat pattern view and click on the
arc of the slot.
19. Move the pointer and click to create annotation.
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dialog appears.

Chapter 7: Top-Down
Assembly and Joints
In this chapter, you will learn to





Create a top-down assembly
Insert Fasteners using Design Accelerator
Export to 3D PDF
Create assembly joints

2.

Enter Base in the New Component Name field.

3.

In the Create In-Place Component dialog, set
the New File Location to the current project
folder.

4.
5.

Click the Browse to New File Location
icon.
On the Save As dialog, click the Create New

TUTORIAL 1
In this tutorial, you will create the model shown in
figure. You use top-down assembly approach to
create this model.

6.
7.
8.

Creating a New Assembly File
1.

To create a new assembly, click New Assembly
on the Home screen.

Creating a component in the Assembly
In a top-down assembly approach, you create
components of an assembly directly in the assembly
by using the Create tool.
1.

Click Create on the Component panel of the
Assembly tab. The Create In-Place Component

9.

Folder
icon.
Type C07_Tut_01 as the name of the folder.
Double-click on the new folder and click Save.
Click OK on the Create In-Place Component
dialog.
Expand the Origin folder in Browser window
and select the XZ Plane. The 3D Model tab is
activated in the ribbon.
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10. Click Sketch > Start 2D Sketch on the ribbon.
11. Select XZ Plane.
12. Create a sketch as shown below.

31. Click Finish Sketch
32. Extrude the sketch up to 3.75 in distance.

28. Click Finish Sketch.
29. Click 3D Model > Create > Extrude on the
ribbon and extrude the sketch up to 1.5 in.

33. Create a counterbore hole on the second feature
(See Chapter 5, Tutorial 1, Create a Counterbore
Hole section). The following figure shows the
dimensions of the counterbore hole.
30. Start a sketch on the top face and draw a circle
of 2 in diameter.
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38. Click Finish Sketch.
39. On the ribbon, click 3D Model > Modify >
Hole.
40. On the Hole dialog, specify the settings, as
shown.

34. Start a new sketch on the top face of the first
feature.
35. Create a 3.5 diameter circle with the
Construction button active.

41. Make sure that the sketch point is selected.

36. On the ribbon, click Sketch > Create > Point.
37. Place a point on the circle, as shown.
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42. Click OK to create the hole.
43. Create a circular pattern of the hole (See Chapter
5, Tutorial 1, Create a Circular Pattern).

6.
7.

Click Sketch > Start 2D Sketch on the ribbon.
Select top face of the Base.

8.

On the ribbon, click Sketch > Create > Project
Geometry and select the circular edges of the
Base.

9.

Draw a circle of 4.5 in diameter.

44. Click the Return button on the ribbon.

Creating the Second Component of the
Assembly
1.

2.
3.
4.
5.

Click Assemble > Component > Create
on
the ribbon; the Create In-Place Component
dialog appears.
Enter Spacer in the New Component name
field.
Check Constrain sketch plane to selected face
or plane option.
Click OK.
Select the top face of the Base.
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10. Click Finish Sketch.
11. Extrude the sketch up to 1.5 in.

12. Click Return

6.

Start a sketch on the YZ Plane.

7.

Draw a sketch, as shown in figure.

8.
9.

Click Finish Sketch.
Activate the Revolve tool and revolve the
sketch.

on the ribbon.

Creating the third Component of the
Assembly
1.

2.
3.
4.
5.

Click Assemble > Component > Create
on
the ribbon; the Create In-Place Component
dialog appears.
Enter Shoulder Screw in the New Component
name field.
Check Constrain sketch plane to selected face
or plane option.
Click OK.
Click on the top face of the Base.
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10. Activate the Chamfer tool and chamfer the
edges, as shown in figure.
12. Click Return
on the ribbon.
13. Save the assembly.

Adding Bolt Connections to the assembly
1.

On the ribbon, click Design > Fasten > Bolt
Connection.

2.

3.

On the Bolted Connection Component
Generator dialog, under the Design tab, select
Type > Through All.
Select Placement > Concentric.

4.

Select the top face of the Spacer.

11. Activate the Fillet tool and round the edges, as
shown in figure.
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8.
9.

Make sure that the Diameter is set to 0.5 in.
On the dialog, click Click to add a fastener.

10. On the pop up dialog, set the Standard to ANSI
and Category to Hex Head Bolt.
11. Select Hex Bolt-Inch. This adds a hex bolt to the
list.

5.

Click on the hole to define the circular reference.

12. On the list, click Click to add a fastener below
the Hex Bolt.
13. On the pop up dialog, scroll down and select
Plain Washer (Inch).

6.

Rotate the model and click on the bottom face of
the base. This defines the termination.

14. Click Click to add a fastener at the bottom of
the list.

7.

15. On the pop up dialog, scroll down and select
Plain Washer (Inch).
16. Click Click to add a fastener at the bottom of
the list.

On the dialog, set the Thread type to ANSI
Unified Screw Threads.
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17. On the pop up dialog, set the Category to Nuts
and select Hex Nut –Inch.

Circular tab and select the Axis Direction
button.

18. Click OK twice to add a bolt connection
subassembly.

4.
5.
6.

Click on the large cylindrical face of the Spacer
to define the axis of the circular pattern.
On the dialog, type-in 4 and 90 in the Circular
Count and Circular Angle boxes, respectively.
Click OK to pattern the bolt connection.

Patterning components in an assembly
1.

On the ribbon, click Assemble > Pattern >
Pattern.

2.

Select the Bolt connection from the Browser
window.

Applying the constraint to the
components
1.

3.

On the Pattern Component dialog, click the
461

On the ribbon, click View > Visibility >
Degrees of Freedom.
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6.
7.
8.

9.
2.
3.

Click Apply.
On the dialog, select Flush from the Solution
section.
In the Browser Window, expand the Origin
folder and select XY Plane.

Expand the Origin folder of the Shoulder Screw
and select XZ Plane.

On the ribbon, click Assemble > Relationships
> Constrain.
On the dialog, click the Mate icon and click on
the cylindrical faces of the Spacer and Base.

10. Click OK to fully-constrain the assembly.
11. Save the assembly and all its parts.

Using the Search tool in the Bowser
window
4.
5.

Autodesk Inventor 2018 provides you with the
search tool to locate the components or features very
quickly.

Click Apply.
Click on the cylindrical faces of the Shoulder
Screw and Base.

1.
2.
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In the Browser Window, click the Search icon.
Type ‘hex’ in the search bar; all the hexagonal
bolts appear in the browser window.
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3.

1.

In the Browser Window, click the Drop-down
menu next to the Search box, and then select
Edit Values in Browser.

2.

In the Browser Window, expand the Shoulder
Screw part, and then click on the Flush relation,
as shown; the selected relation is highlighted in
the graphics window, as shown.

3.

Type 1 in the box that appears next to the
selected relation, and then press Enter; the
relation is updated in the graphics window.

Place the pointer on the hexagonal bolts in the
browser window; they are highlighted in the
graphics window.

You can select all the hexagonal bolts by pressing
the Shift key and clicking on them. After selecting
them, you can perform a variety of operations at a
time such as hiding, deleting, solving, suppressing,
and so on.
4.

Click Clear Search to clear all the searched
components.

Editing Values in the Bowser window
Autodesk Inventor 2018 allows you to edit the
values of the assembly components directly in the
Browser Window.
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1.

4.

In the Browser Window, click the Drop-down
menu next to the Search box, and then select
Display Preferences > Hide Work Features.

Click Undo on the Quick Access Toolbar.

Changing the Display Preferences of the
Bowser window
Autodesk Inventor 2018 allows you to hide or
display items to reduce the clutter in your Browser
Window. For example, you can hide or display the
work features such as plane and UCS in the Browser
Window.

The work features are hidden.

Using the Measure tool
The Measure tool helps you measure the size and
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position of the model. You can measure the various
parameters of the model such as length, angle,
radius, and so on.
1.

3.

Select the Select faces and edges
select the linear edge, as shown.

filter and

On the ribbon, click Inspect tab > Measure
panel > Measure
; the Measure floating
window appears on the screen.

2.

Click and drag the Measure floating window,
and then release it on to the Browser Window;
the Measure window is docked to the Browser
Window.

The length of the selected edge is displayed in the
Measure window.

4.

Click Advanced Settings in the Measure
window.

In the Advanced Settings section, you can change
the Precision, Angle Precision of the displayed
measurement. In addition to that, you can display
the measurement in dual units by specifying the
Dual Units type.

The Measure Window has three selection filters:
Select faces and edges, Part Priority, and
Component Priority.
The Select faces and edges filter allows you to select
only the faces and edges of the model.
The Part Priority filter allows you to select the part
geometry for measurement.
The Component Priority filter allows you select the
part geometry and assemblies. This filter is useful to
while selecting subassemblies inside the main
assembly.

5.
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Select the cylindrical face, as shown; the
Measure window displays results.
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The Measure results section display the results of the
first and second selections separately. In addition to
that, the distance between the two selected entities is
displayed.

1.
2.

3.

4.
5.
6.
7.

6.

Save and close the assembly and its parts.

TUTORIAL 2
In this tutorial, you create a slider crank mechanism
by applying Joints.
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Create the Slider Crank Assembly folder inside
the project folder.
Download the part files of the assembly from
the companion website. Next, save the files in
the Slider Crank Assembly folder.
Start a new assembly file using the
Standard.iam template.
Click Assemble > Component > Place
on
the ribbon.
Browse to the Slider Crank Assembly folder
and double-click on Base.
Right-click and select Place Grounded at
Origin.
Right click and select OK.
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8.

Click Assemble > Component > Place
on
the ribbon.
9. Browse to the Slider Crank Assembly folder
and select all the parts except the Base.
10. Click Open and click in the graphics window to
place the parts.
11. Right click and select OK.
12. Click and drag the parts, if they are coinciding
with each other.
4.

Select the face on the Base, as shown below; the
two faces are aligned.

5.

On the dialog, click the First Alignment
button.
Select the face of the Slider1, as shown.

Creating the Slider Joint
1.

Click Assemble > Relationships > Joint on the
ribbon; the Place Joint dialog appears.

6.
2.

Set the Type to Slider.

3.

Select the face on the Slider1, as shown below.
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7.

Select the face of the Base, as shown; the Slider 1
is aligned to the selected face.

10. Click the corner of the ViewCube, as shown; the
orientation of the assembly is changed.
5.
6.
7.

Click the Limits tab on the Place Joint dialog.
Check the Start and End options under the
Linear group.
Set the Start value to 1.5 in and End to -1.5 in.

11. Click Assemble > Relationships > Joint
on
the ribbon.
12. On the dialog, set the Type to Slider .
13. Select the face on the Slider2, as shown below.

8.
9.

Click OK.
Select the Slider1 and drag the pointer; the
Slider1 slides in the slot of the Base. Also, the
slider motion is limited up to the end of the slot.

14. Select the right edge of the top face of the
ViewCube; the orientation of the assembly
changes.
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15. Select the face on the Slider1, as shown below.
Next, click OK.

4.

Select the circular edge of the Slider2.

6.

Click the Flip Component button under the
Connect group.

7.

Click OK

Creating the Rotational Joint
1.
2.

3.

Click Assemble > Relationships > Joint on the
ribbon.
Set Type to Rotational.

Select the circular edge of the arm, as shown
below.

Creating the Rigid Joint
1.
2.
469

Click Assemble > Relationships > Joint
the ribbon.
Set the Type to Rigid.

on
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3.

Select the top face on the pin.

4.

Click the on the corner point of the ViewCube,
as shown.

Adding more assembly joints
1.

5.

Select the circular edge on the back face of the
arm.

6.

Click OK.
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Create another rotational joint between the Pin
and the Pivot.
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Next, you need to constrain the Pivot by applying
constraints.
2.

Click the Assemble button on the Relationships
panel.

10. On the Assembly mini toolbar, select Mate –
Flush from the drop-down.
12. Click Apply (plus symbol on the mini toolbar).
13. Select the XY Plane of the Pivot and XY Plane of
the Base from the Browser window.

11. Select the bottom face of the Pivot, and then
select the bottom face of the Base.

14. Click OK (check mark on the mini toolbar).
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Driving the joints
1.
2.

In the Browser window, expand Pivot and click
the right mouse button on the Rotational joint.
Select Drive from the shortcut menu.

5.

Click the Record
button on the dialog.
Specify the name and location of the video file.
Click Save and OK.

6.

On the dialog, click the Forward
button to
simulate the motion of the slider crank
assembly.
Click OK to close the dialog.

7.

Creating Positions
1.

2.

3.
4.

On the Drive dialog, type-in 0 and 360 in the
Start and End boxes, respectively.
Expand the dialog by clicking the double-arrow
button located at the bottom. On the expanded
dialog, you can define the settings such as drive
adaptivity, collision detection, increment,
repetition, and so on.
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In the Browser window, expand the
Representations > View and notice that the
Master representation is set as default.
Right click on the Position node, and then select
New; a new position is created.
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1.

3.

4.

Click File Menu > Export > 3D PDF.

Double click on the Position1 and type
StartPosition; the view representation is
renamed.

The Publish 3D PDF dialog appears on the screen. It
is powered by Anark Core software. On the Publish
3D PDF dialog, you can select the properties to be
displayed on the PDF from the Properties section.
You can also select the required design view
representation, visualization quality, and export
scope.

Click and drag the Slider1 to the left end, as
shown.

2.

Leave the Template to the default setting.

If required, you can select another template by
clicking the icon next to the Template path. You can
also create a new 3D PDF template, if you have
Adobe Acrobat Pro. You can go through the
Autodesk Inventor Help file to know the procedure
to create a 3D PDF template.
3.
4.
5.
5.

6.

Double click on the Master positon to activate it.

Creating 3D PDF
Autodesk Inventor allows you to create a 3D PDF
from the model. The 3D PDF file is helpful in
viewing the 3D without any CAD application or
viewer.
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Specify the File Output Location.
Check the View PDF when finished option.
Check the Generate and attach STEP file
option.
Click the Options button next to the Generate
and attach STEP file option; the STEP file Save
as Options dialog appears on the screen.
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On this dialog, select the required Application
Protocol option and spline fit accuracy. You can also
enter the authorization, author, organization, and
description.
7.

Click OK on the STEP file save as Options
dialog.

Use the Attachments button, if you want to add any
other attachments to the PDF file such as
spreadsheet, pdf, or text document.
8.

Likewise, examine the other options on the toolbar.
These options are similar to that available on the
View ribbon tab of the Autodesk Inventor
application.

Click Publish on the Publish 3D PDF dialog.

Inventor starts exporting the 3D model the PDF file.
After few seconds, the 3D PDF file opens in the PDF
viewer.

11. On the Side bar, click the Attachments icon to
view the STEP file.

9.

Click inside the graphics window of the PDF
file, and then drag to rotate the model.
10. Click the drop-down located at the top left
corner and notice the View options. These
options are same as that available on the
Navigation Pane.

You can open or save the STEP file by right clicking
on it and select the corresponding option.
12. Close the 3D PDF file
13. Save and close the assembly and its parts.
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Chapter 8: Dimensions and Annotations
In this chapter, you will learn to










Create Centerlines and Centered Pattern
Edit Hatch Pattern
Apply Dimensions
Place Hole callouts
Place Leader Text
Place Datum Feature
Place Feature control frame
Place Surface texture symbol
Modify Title Block Information

TUTORIAL 1
In this tutorial, you create the drawing shown below.
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1.
2.
3.
4.
5.
6.

7.
8.
9.

Open a new drawing file using the
Standard.idw template.
In the Browser Window, click the right mouse
on Sheet:1 and select Edit Sheet.
On the Edit Sheet dialog, select Size > A, and
then click OK.
Click Place Views > Create > Base on the
ribbon.
Click Open an existing file
button on the
dialog.
Browse to the location of the Adapter Plate
created in the Tutorial 1 of the Chapter 5. You
can also download this file from the companion
website and use it.
Select the Adapter Plate file and the click Open.
Set the Scale to 2:1.
Click the Front face on the ViewCube displayed
in the drawing sheet.

10. Set the Style to Hidden Line Removed
.
11. Click OK on the dialog.
12. Drag the view to the right-side of the drawing
sheet.
13. Click Place Views > Create > Section
ribbon.
14. Select the front view.
15. Draw the section line on the front view.

Creating Centerlines and Centered
Patterns
1.

Click Annotate > Symbols > Centerline
Bisector on the ribbon.

2.

Select the parallel lines on the section view, as
shown below; the centerline is created.

3.

Click Annotate > Symbols > Centered Pattern
on the ribbon.

4.

Select the circle located at the center.

on the

15. Right-click and select Continue.
16. Place the section view on the left side.
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5.

8.

Likewise, create another centered pattern on the
curved slots. Right-click and select Create.

9.

Press Esc to deactivate the tool.

Select the center point of anyone of the
counterbored holes.

Editing the Hatch Pattern
1.
6.
7.

Select the center points of other counterbored
holes.
Click the right mouse button and select Create.
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Double-click on the hatch pattern of the section
view; the Edit Hatch Pattern dialog appears.
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2.
3.

You can select the required hatch pattern from the
Pattern drop-down. If you select the Other option
from this drop-down, the Select Hatch Pattern
dialog appears. You can select a hatch pattern from
this dialog or load a user-defined pattern by using
the Load option. Click OK after selecting the
required hatch pattern.

2.

Click OK.

Applying Dimensions
1.

Click Annotate > Dimension > Dimension on
the ribbon.
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Select the center line on the slot located at the
left.
Select the endpoint of the center line of the hole
located at the center.

4.

Move the pointer toward left and click.

5.

Click OK.

6.

Likewise, create another angular dimension, as
shown below.
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9.
7.

Create angular dimensions between the holes,
and then between slots.

8.

Dimension the pitch circle radius of the slots.

With the Dimension tool active, select the
horizontal line of the front view and the lower
quadrant point of the view.

10. Place the dimension on the right side. Click OK.
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11. Click Annotate > Feature Notes > Hole and
Thread on the ribbon.
14. Click Leader Text on the Text panel.

12. Select the counterbore hole and place the hole
callout, as shown below.
15. Select the slot end, as shown below.

13. Add a pitch circle radius to counter holes.

16. Move the cursor away and click.
17. Right-click and select Continue; the Format Text
dialog appears.
18. Enter the text shown below.
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19. Click OK. Press Esc key.

25. Move the pointer toward right and click to place
the dimension.
26. On the dialog, click the Precision and Tolerance
tab.
27. Set the Tolerance Method to Limits/Fits - Show
tolerance.
28. Select Hole > H7.
29. Set the Primary Unit value to 3.123.
30. Set the Primary Tolerance value to 3.123.

20. Double-click on the section label below the
section view.
21. On the Format Text dialog, select all the text and
set the Size to 0.120. Click OK.

22. Drag and place the section label on the top.

31. Click OK.

23. Click Dimension on the Dimension panel.
24. Select the lines, as shown below.
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32. Likewise, apply the other dimensions, as shown
below. You can also use the Retrieve
Dimensions tool to create the dimensions.

2.

Select the extension line of the dimension, as
shown below.

3.
4.

Move the cursor downward and click.
Move the cursor toward left and click; the
Format Text dialog appears. Make sure that A is
entered in the dialog.
Click OK.

Placing the Datum Feature
1.

Click Annotate > Symbols > Datum Feature on
the ribbon.

5.
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6.

4.

Right-click and select Continue; the Feature
Control Frame dialog appears.

5.

On the dialog, click the Sym button and select
Circular Run-out.

Likewise, place a datum feature B, as shown
below. Press Esc.

Placing the Feature Control Frame
1.

Click Annotate > Symbols > Feature Control
Frame on the ribbon.

2.
3.

Select a point on the line, as shown below.
Move the cursor horizontally toward right and
click.
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6.

Enter 0.001 in the Tolerance box and A in the
Datum box.

7.

Click OK.

3.
4.

8.

Right-click and select Continue; the Surface
Texture dialog appears.
Set the Roughness Average - maximum value to
63.

Right-click and select Cancel.

Placing the Surface Texture Symbols
1.

Click Annotate > Symbols > Surface Texture
Symbol on the ribbon.

2.

Click on the inner cylindrical face of the hole, as
shown below.
5.
6.

484

Click OK.
Right-click and select Cancel.
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7.

Apply the other annotations of the drawing. The
final drawing is shown below.

Modifying the Title Block Information
1.

Right-click on the Adapter Plate in the Browser
window. Select iProperties from the shortcut
menu.

2.

Click the Summary tab and enter the
information.
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Chapter 9: Model Based Dimensioning
Geometric Dimensioning and Tolerancing
During the manufacturing process, the accuracy of a part is an important factor. However, it is impossible to
manufacture a part with the exact dimensions. Therefore, while applying dimensions to a drawing you need to
provide some dimensional tolerances, which lie within acceptable limits. The following figure shows an example
of dimensional tolerances applied to the drawing.

The dimensional tolerances help you to manufacture the component within a specific size range. However, the
dimensional tolerances are not sufficient for manufacturing a component. You must give tolerance values to its
shape, orientation and position as well. The following figure shows a note, which is used to explain the tolerance
value given to the shape of the object.

Providing a note in a drawing may be confusing. To avoid this, we use Geometric Dimensioning and Tolerancing
(GD&T) symbols to specify the tolerance values to shape, orientation and position of a component. The following
figure shows the same example represented by using the GD&T symbols. In this figure, the vertical face to which
the tolerance frame is connected, must be within two parallel planes 0.08 apart and perpendicular to the datum
reference (horizontal plane).
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Providing GD&T in 2D drawings is a common and well known method. However, you can provide GD&T
information to 3D models as well. The tools available in the Annotate tab of the ribbon help you to add GD&T
information to the 3D models based on the universal standards such as ASME Y14.41 – 2003 and ISO 16792 : 2006.
However, you can add GD&T information based on your custom standard as well.
In this chapter, you will learn to use Annotate tools to add GD&T information to the part models. There are many
ways to add GD&T information and full-define the parts and assemblies. There are few methods explained in this
chapter but you need to use a method, which is most suitable to your design.

4.
5.

TUTORIAL 1
This tutorial teaches you to extract dimensions.

1.

2.

3.

6.

Download the Model Based Dimensioning part
files from the Companion website and open the
Tutorial 1 file.
On the ribbon, click the Tools tab > Options
panel > Document Settings to open the
Document Settings dialog.
Click the Standard tab and select ASME from
the Active Standard drop-down.

Click OK.
In the Browser Window, expand the View node,
and then double click on the Isometric view.
Right click on the Isometric view, and then select
Annotation Scale > Auto.

You can also change the Annotation Scale from the
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Annotation Scale drop-down available on the
Manage panel of the Annotate ribbon tab.

Adding Tolerances to the Model
dimensions
1.

In the Browser Window, right click on the
Extrusion 1 feature, and then select Show
Dimensions.

6.
7.
8.

Click OK on the dialog.
Click the green check on the Edit Dimension
box.
Likewise, add tolerances to the remaining
dimensions, as shown.

The dimensions of the feature are displayed.

9.

Right click on the Extrusion2 feature, and then
select Edit Sketch.
10. Add tolerances to the dimensions, as shown.
2.
3.

4.
5.

Double click on the 13.386 dimension.
On the Edit Dimension dialog, click the arrow
button pointing towards right, and then select
Tolerance.
On the Tolerance dialog, select Type >
Symmetric.
Type 0.002 in the Upper limit box.
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20. Likewise, add .002 tolerance to the remaining
location dimension. Click OK on the Tolerance
dialog.
21. Click OK on the Hole dialog.
22. In the Browser Window, right click on the
Rectangular Pattern1, and then select Show
Dimensions.
23. Add tolerances to the dimensions, as shown.

11. Click Finish Sketch on the ribbon.
12. Double-click on the Hole feature in the Browser
Window to display the Hole dialog.
13. On the Hole dialog, click the arrow pointing
toward right, and then select Tolerance.
14. On the Tolerance dialog, select Type >
Symmetric.
15. Type .002 in the Upper limit box, and then click
OK.
16. Zoom to the hole feature, and then click on the
location dimension, as shown.
17. Click the arrow pointing toward right, and then
select Tolerance.

Extracting the Model dimensions
1.

2.
3.

In the Browser Window, right click on the
Extrusion1 feature, and then select Show
Dimensions.
Select the 21.260 dimension.
Right click, and then select Promote.

The dimension is promoted as a 3D Annotation.
4.
18. On the Tolerance dialog, select Type >
Symmetric.
19. Type 0.002 in the Upper limit box, and then click
OK.
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Likewise, promote the other two dimensions of
the Extrusion1 feature.
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5.
6.

5.

Likewise, extract dimensions from the
Extrusion2, Hole, and Rectangular Pattern
features.

Adding Tolerance Feature
1.

On the ribbon, click Annotate tab > Geometric

2.

Annotation panel > Tolerance Feature
Click on the top face of the model.

.

3.

Select the Planar Surface option from the Mini
toolbar.

4.

Click OK on the Mini toolbar.

Move the pointer and click to place the tolerance
feature.
In the tolerance feature. click on the tolerance
value, and the type .002 in the Tolerance box.

7.

Click OK on the Mini toolbar.

8.

On the ribbon, click Annotate tab > Geometric

9.

Annotation panel > Tolerance Feature
Click on the left face of the model.

.

10. Click OK on the Mini toolbar.
11. Move the pointer and click to place the tolerance
feature.
12. In the tolerance feature. click on the tolerance
value, and the type .002 in the Tolerance box.
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22. Click to place the hole annotation.

13. Click OK on the Mini toolbar.
14. Likewise, create another tolerance feature, as
shown.

23. Click on the tolerance value, and then type .002
in the Tolerance box.
24. Select Maximum Material Condition from the
drop-down available next to the Tolerance box.

15. Select the hole annotation and press Delete on
your keyboard.

25. Click OK on the Mini toolbar.
The annotations and tolerance features are listed in
the Browser Window.

16. On the ribbon, click Annotate tab > Geometric
Annotation > Tolerance Feature
.
17. Select the Hole feature from the model.
18. Select Simple Hole Parallel Axis Pattern from
the Mini toolbar.
19. Click OK on the Mini toolbar.
20. Right click and select Select Annotation Plane
[Shift].
21. Select the top face of the model.
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26. Save and close the part file.
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